Pump connected to heated bed sometimes won't turn on [SOLVED]

  • Previously implemented @dc42's method for controlling a pump through the heated bed connection:

    Most of the time, the pump turns on (M42 P0 S1) fine and we have no problems.

    However, if we turn the pump off (M42 P0 S0) and try to turn it on again in less than 60 seconds, the pump gets "stuck" and won't start running. The Vin on the duet drops a few V, and you can hear the system responding to the command (LEDs dim, fan changes RPM, etc.), but the pump doesn't kick on.

    If you leave it in the "on" state, eventually after maybe 10 to 30 seconds the pump kicks on all of a sudden.

    What could be the cause of this?

  • administrators

    @sean can you start by checking that is not an issue with the pump. I am not sure how much on board control it has but it might have a enforced cool down period. One way to test it is to see if when you connect it directly to 24V and gnd, the switch of the 24V and then switch it back on it starts up immediately?

  • We believe the issue is insufficient wattage coming out of our PSU. From our previous model to this we dropped the PSU W by 30%. We will buy higher W PSU and try again. Thanks for responding.

  • administrators

    @sean is the pump the highest current draw in your system, in that case that makes sense.

  • @t3p3tony Yes, by far. We suspect its being greedy on startup and causing problems with our computer, thus resetting the port to the duet. PSUs ordered, hopefully by next week will have an update. Thanks for the responses.

  • This was an issue with the pump pulling against dead head and not getting enough momentum to turn over properly. Opening the solenoid to allow flow on pump startup solved the issue. Not related to duet.

Log in to reply