Weird G32/G29 Error



  • My G32 and my G29 doesn`t work anymore. Homeall works fine and in the directions i had defined. But if i send an G32 to the Duet my Hotend crashes against the front left motor mount.

    I tried this with FW 1.21 and with FW2.0 Set up the config complete new today and define also Minimum Axis to X/Y 20/20 and tried to define the bed.g at X40 Y270 at first point even then it rushes against the motor mount.

    I don`t had a clue anymore what to do exept of throw my Core XY out of the window


  • administrators

    If the problem has only occurred since you upgraded from an old firmware version, check whether you have any deployprobe.g and retractprobe.g files in /sys that you didn't create yourself, and delete them.



  • No, i had the problem since yesterday and didnt use a BL-Touch. I had an Orion and before an IR Probe. Just updated today from 1.21 to 2.0 and made the config complete new but both changed nothing. There aren`t deployprobe.g or an retractprobe.g in my sys.


  • administrators

    So it was working correctly with firmware 1.21 before? If so then it looks like the changes to the config files caused the problem.



  • No the error started at FW 1.21 and i did an upgrade to exclude an FW error. also G30, Homez and homeall did work but G32 and G29 doesnt do whats in bed.g or in M557


  • administrators

    What did you do that triggered the error: a firmware upgrade from a version earlier than 1.21, or something else?



  • I run the FW 1.21 a couple of weeks, two weeks ago i changed from IR Probe to Orion. I first thought i made a mistake at my config.g yesterday, so i build a new one today. As this didn`t worked i made the FW Update to exclude an Firmware Issue.

    Then i thought something on the Board is broken but G30, homeall and homez worked as they should.

    Dont shure if this also is a part of the problem, but my last 3 Thermistor and Thermistor Cables made Heater Faults if the cable is moved in the wrong way...



  • Tried it again, Setup Firmware again, Homeall works like a charm. Start G32, first start point should is defined in bed.g as X40 Y40 but he tried to move to X-90 Y-90? What am i doing wrong?


  • administrators

    Do you have any deployprobe.g. or retractprobe.g files that shouldn't be there?



  • @dc42 No, even after the new Installation of the Firmware isn't there a deployprobe.g or an retractprobe.g


  • administrators

    Please share your config.g and bed.g files.



  • config.g

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jun 30 2018 19:52:00 GMT+0200

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PHEVO ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800 E2673 ; Set steps per mm
    M566 X1000 Y1000 Z1000 E240 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z250 E40 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z250 E1000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X280 Y280 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P8 I1 R0.4 Z1 F300 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X140 Y140 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 X20:280 Y20:280 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M307 H1 A469.9 C164.2 D9.6 B0

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured
    M106 P1 S0
    M572 D0 S0.08 ;Pressure Advance

    bed.g
    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jun 30 2018 19:52:00 GMT+0200
    M561 ; clear any bed transform
    ; Probe the bed at 4 points
    G30 P0 X40 Y40 H0 Z-99999
    G30 P1 X40 Y140 H0 Z-99999
    G30 P2 X40 Y270 H0 Z-99999
    G30 P3 X140 Y270 H0 Z-99999
    G30 P4 X270 Y270 H0 Z-99999
    G30 P5 X270 Y140 H0 Z-99999
    G30 P6 X270 Y40 H0 Z-99999 S0


  • administrators

    In your G31 command you have specified that the Z probe is offset from the nozzle by 140mm (which is a very large offset) in both X and Y. So in order to put the probe at 40,40 the firmware has to put the nozzle at -100,-100.



  • facepalm feels like an idiot, doesn`t see that. Redefine the offset in G31 and everythings fine now. Thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.