Still having issues homing



  • So I've gotten to the point that the x and y axis home just fine, but the Z is still being difficult. It hits the endstop and stops moving and the menu pops up to adjust the carriage. It says to adjust until the hot end just touches and gives me options to move it in various increments up or down. When I hit one of the buttons to move it up/down it gives me an error. It says something like:

    M120

    G0/G1 Insufficient Axes Homed

    Which is confusing, because that's what I'm trying to do.

    Any help would be great!



  • Forgot to mention, I've built a D-bot/CoreXY. It's 330 x 330 x 450. My config.g file is below.

    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M584 X0 Y1 Z2:4 E3 ; Apply custom drive mapping
    M350 E16 I0 ; Configure microstepping without interpolation
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z2560 E420:2560 ; Set steps per mm
    M566 X900 Y900 Z12 E120:12 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:180 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z330 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:315 Y15:315 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • And here is homez:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Jul 02 2018 21:41:18 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 S2 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • administrators

    You can add M564 H0 to config.g. to avoid the message. However, if that menu pops up then your homing files are set up to home Z using a Z probe instead of an endstop switch, but you have no Z probe configured. I suggest you look at https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z.



  • I'll try the Homing to a z low end stop tonight. I'm not sure why it'd be configured to use a Z Probe though because I have "No Z Probe" selected in the configurator.



  • In that case you can remove the m558 command from the config.



  • @phaedrux Just remove it completely? I see in the config file it says it's disabled.



  • @dc42 One more quick question -- I'm assuming I want to do the min Z endstop as opposed to max, yeah?



  • @kskiff7034 said in Still having issues homing:

    @phaedrux Just remove it completely? I see in the config file it says it's disabled.

    Delete the line or add a ; to comment it out. If you ever add a z probe you will have to add a new line anyway..

    The DBot homes to zmin by default where the bed raises up to meet the nozzle at z0 and moves away from the nozzle in z+.

    It can be handy to have both zmin and zmax for instance for power loss recovery. But that's neither here nor there.



  • So I removed the M558 from config. I'm trying to follow the link dc42 sent to home z to a min endstop -- can I follow the guide on the Cartesian page? Because there's no information on homing the Z when you go to the coreXY page. It tells you how to do homeall, but the only mention of homing z says, "Z homing section to follow", but then it doesn't follow.



  • Yes it's the same as Cartesian.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.