Heater fault because of cooling fan



  • Hi everyone yesterday I started to print with PETG normally I only use PLA, and it was very hard for me to print the famous 3D Benchy but after about 5 tries and 1h I manage to make it work it without the message for heater fault, I realise this is happening because whenever the printer finish the first layer the cooling fan turns on and the heater goes down about 15ºc, yesterday I did the PID tuning with the fan on to see if it would solve the problem I thought it did since this morning the 3D Benchy was printed nicely, in the same morning before I went to work I started a big print, (around 12h) when I came back from work only the first layer was printed (basically when the fan turned on I got the heater fault again) how can I solve this?


  • administrators

    @black-canary once you have completed the PID tuning - did you save it? See:

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    After you have run auto tuning and checked that the heater control is working well, run M500 to save the heater parameters in config-override.g (this is supported in firmware 1.17 and later). Alternatively, construct a M307 command with the model parameters and add it to config.g. For example, if after tuning you run M307 H0 and see this:

    M307 H0
    Heater 0 model: gain 199.0, time constant 962.6, dead time 4.5, in use: yes

    then you should add the following to config.g to preserve this model:

    M307 H0 A199.0 C962.6 D4.5 B0



  • @t3p3tony Thank you for your answer, yes I did saved, with the command M500, anyways I am now doing the alternative option, I will let you know how it went.



  • What kind of hotend is it? What cooling shroud is being used?

    If it's an E3D hotend you can get a silicone sock that covers the hotend to protect it from drafts and to help keep it clean. If it's another style hotend, you may be able to wrap it with insulation and kapton tape.

    The cooling shroud may need to be adjusted or replaced to prevent it from blowing so strongly on the hotend.

    Also, for PETG you probably want a lot less part cooling to keep the interlayer adhesion strong. So maybe turn down your fan speed.



  • All of the above and you can also "desensitise" the fault detection by changing the P and T parameters in M570 (put it in config.g) https://duet3d.dozuki.com/Wiki/GCode#Section_M570_Configure_heater_fault_detection (but head the warning that is given on that page).



  • @t3p3tony @Phaedrux @deckingman Thanks for your answers guys, It still didn't work, but I manage to after the fault reset the fault (not the printer) and then heat up the hot end again with the fan on and it did work and have been now printing from 1h (Still sucks because this means that every time I want to print I have to wait until it finishes the first layer). It looks like that only happenness when it change the layer for some reason. My printer is an Anet A8 with some modifications, but I'm still using the original hotend, I was wondering maybe the resistor is too weak to handle higher temperatures?


  • administrators

    @black-canary, have you seen https://duet3d.dozuki.com/Wiki/Spurious_heater_faults_and_how_to_avoid_them ? It's linked to from the Troubleshooting page.



  • Hi everyone, I solved this buying a silicon cover for the heat block (as Phaedrux mentioned) you can get some pretty cheap on Ebay, I also realised that you don't need to have a E3D hotend, they are not available for every hotend, but you can found for the most common. With this the temperature only goes down 5 degrees and in a few seconds it's in the desired temperature again.
    Thanks everyone!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.