DWC UI position updates are behind causing leveling problems



  • https://youtu.be/ZZH8lp9UBPA

    The height map clear does not appear to work.
    Based on the firmware the defect must be in the DWC UI code and not in the Firmware Clear Map Code.

    Because you need to disable the mesh to set Z probe offsets and level the Z, setting the initial bed level height was confusing or just wrong.



  • What firmware version?



  • This might also explain why I get confusing readings when trying to clear map and home Z as it seem to compensate even after G29 S2 or even M561 from the GUI blue menu



  • @phaedrux said in DWC UI position updates are behind causing leveling problems:

    What firmware version?

    This was the latest stable 2.0 build release as of the date of post. It's been an issue in all versions from what we can tell.



  • What version of DWC? There is a beta update to the latest 1.21 that has some fixes. B2 I think. It should be on the main download site now.


  • administrators

    @3ddevil, thanks for your report and video. I confirm two problems in firmware 2.01beta1 which are almost certainly also present in 2.0/1.21 and perhaps in some earlier versions too:

    1. M561 disables bed compensation, but if bed compensation was previously enabled then it doesn't adjust the user Z coordinate to take account of whatever compensation was previously applied at the current XY position. Repeating M561 has no effect, however sending G29 S2 after M561 does adjust the coordinate.

    2. G29 S2 disables bed compensation, but the first time it is run it doesn't update the user Z coordinate.

    I will fix these in the next 2.01 beta release.



  • @dc42 Would this explain why I'm having trouble getting correct first layer heights? No matter what height I set I end up having to baby step extra height.


  • administrators

    @phaedrux said in DWC UI position updates are behind causing leveling problems:

    @dc42 Would this explain why I'm having trouble getting correct first layer heights? No matter what height I set I end up having to baby step extra height.

    Possibly!



  • @dc42 Would it be best to use the following as a homing order before a print?

    T0 ; Activate Tool 0
    M190 S[First layer bed temp] ; Wait for bed temp
    G10 P0 S[First layer nozzle temp] R100 ; Set Tool 0 to 210 active 100 standby
    M561 ; Disable bed compensation.
    G29 S2 ; Disable compensation again.
    G28 ; Home all
    G29 S1 ; Load heightmap.csv and enable compensation.
    G90 ; Absolute positioning
    G1 X0 Y270 F6000 ; Move to front left corner
    G1 Z0.3 F300; Move Z to prime height
    M400 ; clear movement buffer
    M116 ; Wait for temps
    G91 ; Relative positioning
    M83 ; Relative extrusion
    G1 X40 Y0 E10 F300 ; Prime nozzle
    G1 Y-1 E-0.5 F6000 ; Wipe nozzle
    G90 ; Absolute positioning
    G1 Z[First layer height] F300
    ; Start print Gcode
    G10 ; retract
    ; Skirt and brim gcode
    ; Model Gcode
    

  • administrators

    G29 S2 twice would be better than M561 followed by G29 S2.



  • @dc42 I don't think that's helped. Is it possible for that error to have propagated through measuring the probe trigger height?



  • @dc42 It would appear that it does effect the trigger height calibration.

    I re ran G30 S-1 again with G29 S2 twice before and the resulting Z offset is 2.4 now, whereas before it was 2.1.



  • @dc42 I started bed leveling from scratch. Ran G28, G29 S2 twice, G28 again before manually leveling the bed, Then did the same before measuring Z probe trigger height. Got 2.000 this time. Put that in config and reran mesh compensation. And now with G28, G29 S2, G29 S2, G28, G29 S1 before a print I get perfect first layers again.



  • So is there a bug here?

    When I home Z I should have a reading of what Z offset is (1.4) but it reports typically 1.3x-1.4x on the first dive.

    Here is the homez:
    M280 P3 S160 I1 ; Alarm Release and Push-Pin UP
    G29 S2 ; Clear Bed Comp
    M558 P9 H5 F300 T6000 ; probe, fast one probe
    G30 ; calibrate Z-axis
    M558 P9 H4 F120 T6000 A3 S0.04 ; probe, slow, multi-probe
    G30 ; find Z again



  • @dc42 loaded Beta2 today on my Maestro and can confirm that the need to run two G29 S2s has been resolved. Thanks for the quick repair on this.


Log in to reply