I need some help!



  • Hi Everyone.

    I've been trying to get my printer running with Duet hardware for a while now and I need some help getting over the finish line.

    My printer is a cartesian style.

    I'm using DuetWif 2.0 board, PT100 temp sensor and paneldue.

    Fans work, endstops work, bed and extruder heaters work, temp sensors work. I have a BLTouch, but it is not wired up yet, so no bed level sensor in the mix at this point.

    Here are my issues.

    • On the paneldue in the upper left hand corner, it says "connecting" it always says this. Does that matter or is something not working right? I can control the board over the web interface, but when I try to send commands to the printer from the Paneldue, it doesnt do anything. Also, no temps are registering on it.

    • X stepper is stuttery. When I send a command for it to move, it just kind of vibrates and the shaft sorta goes back and forth real quickly, but it doesnt turn. I've tried playing with the acceleration speeds and the stepper voltages. Neither of those have helped.

    • Y steppers are stuttery. Same as what the X stepper is doing. However, there is another problem. I frequently get "Error: Short-to-ground on drivers 1" message on the web console. I've checked and double checked the wiring to these steppers and I cant find a problem. I've tried different steppers, tried only plugging 1 in and I cant find the problem. Sometimes I can get a few "stutters" out of the stepper before I get the error and sometimes it starts giving me that error message as soon as I try to get the Y steppers to move. I cant figure out how to fix this.
    • Z stepper is also stuttery. And...the Z stepper always move the bed away from the hot end, no matter which direction I tell it to go. I'm not sure what to do to fix this.

    Here is my config file. If some of the values look weird, it could be because I was changing them to try and trouble shoot.

    *****; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 08 2018 12:40:23 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PFT5 ; Set machine name
    M551 Pcole ; Set password
    M552 S1 ; Enable network
    M587 S"interwebsofdoom" P"******" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z4000 E420 ; Set steps per mmhttp://192.168.2.114/#page_machine
    M566 X1500 Y900 Z500 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z100 E250 ; Set accelerations (mm/s^2)
    M906 X1200 Y1500 Z1500 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:285 Y15:285 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured*****

    I havent been able to get the extruder to try and move. I dont know how to do this (something with picking a tool?)

    If anyone could help me sort this, I would really appreciate it.

    Thanks.



  • Have you seen this? https://duet3d.dozuki.com/

    Particularly this? https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter

    It sounds like you have some wiring issues.

    How do you have the Paneldue connected?

    The motor behaviour you describe definitely sounds like either a bad crimp connection or wire pairs not correct.

    Are you sure that your Z steps per mm is 4000?

    Does your Z axis home to Z max or Z Min?

    Can you post your homing files as well?

    If you're currently not using a Z probe you should comment out the Z-Probe lines in the config for now by adding a semi-colon ( ; ) in front of them. M558, G31, M557



  • @phaedrux said in I need some help!:

    Have you seen this? https://duet3d.dozuki.com/

    Particularly this? https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter

    I have seen both of those. I didnt read through your second link entirely, but perhaps i need to. I was hoping not to have to get that far down in the weeds.

    It sounds like you have some wiring issues.

    How do you have the Paneldue connected?

    The paneldue is connected via the 4 wire molex connector, not the ribbon cable.

    The motor behaviour you describe definitely sounds like either a bad crimp connection or wire pairs not correct.

    I dont think its a bad crimp connection since it does it on all of the steppers. Surely I'd get at least one correct, right? How do I check to see if the wire pairs are correct or not?

    Are you sure that your Z steps per mm is 4000?

    No, its not 4000. When I tell it to move 1mm, it goes way more than that. I was going to get it work correctly then fix the steps/mm issue. I need it to stop stuttering and move up and down, not just down (away from print head).

    Does your Z axis home to Z max or Z Min?

    Zmin (endstop is triggered when bed is closest to extruder nozzle.)

    Can you post your homing files as well?

    2_1531081401489_homez.g 1_1531081401489_homey.g 0_1531081401489_homex.g

    If you're currently not using a Z probe you should comment out the Z-Probe lines in the config for now by adding a semi-colon ( ; ) in front of them. M558, G31, M557

    I will do this.



  • If you're currently not using a Z probe you should comment out the Z-Probe lines in the config for now by adding a semi-colon ( ; ) in front of them. M558, G31, M557

    I commented those lines out, saved the config file and rebooted the board. The stepper seemed to be working correctly (in the sense that its moving the way I tell it), but after a second reboot, its gone back to stuttering.



  • Also, not sure if it matters or not, but I am running a 24v PSU on the board and steppers.



  • @cyoung said in I need some help!:

    I was hoping not to have to get that far down in the weeds.

    Far from it. Following the setup guide will save you a great deal of trouble.

    For the stepper wiring I just followed the color coding of the stepper wires and the wiring diagram of Duet. But you can manually verify the pairs by checking for continuity with a multimeter.

    You can also use the continuity testing function to verify if your crimps are good.

    For the paneldue cable make sure it's connected the right way round. https://duet3d.dozuki.com/Wiki/Connecting_an_LCD_control_panel#Section_Option_2_4_way_cable



  • Your Z home file is setup to work as though you have a Z Probe.

    Comment out the G30 probe bed command and replace it with

    G91 ; relative movement
    G1 S1 Z-400 F600 ; Move Z axis to endstop

    Again, all of these details are in the cartesian printer setup guide.



  • @phaedrux said in I need some help!:

    Your Z home file is setup to work as though you have a Z Probe.

    Comment out the G30 probe bed command and replace it with

    G91 ; relative movement
    G1 S1 Z-400 F600 ; Move Z axis to endstop

    Again, all of these details are in the cartesian printer setup guide.

    Sorry, not trying to waste your time, but I havent been able to read the guides and get through this.

    I did this, no help. I am reading through the cartesian setup guide more carefully. My main config file matches what the setup guide says for the general preference and for the movement section.

    When I try to home y or z, i get movement out of both steppers! (stuttering)



  • I just checked the wire pairs on the steppers and as far as I can tell, they are correct.



  • No worries, I don't mind helping to solve problems, but a lot of the basic setup is covered in the documentation far better than I can describe.

    After you've made the motors stutter, run an M122 command in the console and paste the contents here.


  • administrators

    1. Panel Due running but not connecting. The usual causes are:
    • bad connection in the Din or Dout wire of the 4-pin cable
    • Din and Dout wires swapped
    • mismatched baud rates. Both default to 57600 but both can be changed.
    1. Stepper motors not moving. Usual causes:
    • Bad crimp connection between the cable and the connector.
    • unsuitable current setting. Please provide a link to the datasheet for your stepper motors.
    • trying to move the motor too fast or accelerate it too fast. Use low M201 and M203 parameters until your printer is working.
    • Wires not paired correctly into phases. In this case the motor will vibrate loudly.
    • blown driver.


  • @phaedrux said in I need some help!:

    No worries, I don't mind helping to solve problems, but a lot of the basic setup is covered in the documentation far better than I can describe.

    After you've made the motors stutter, run an M122 command in the console and paste the contents here.

    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (10 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4SD-6JKF0-3SN6L-T2ZMY
    Static ram used: 21176
    Dynamic ram used: 95928
    Recycled dynamic ram: 1680
    Stack ram used: 1304 current, 4840 maximum
    Never used ram: 7448
    Last reset 00:00:18 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 7448 bytes (slot 2)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 25.2, current 29.2, max 29.4
    Supply voltage: min 24.0, current 24.2, max 24.5, under voltage events: 0, over voltage events: 0
    Driver 0: standstill
    Driver 1: standstill
    Driver 2: standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2018-07-08 15:31:31
    Slowest main loop (seconds): 0.008299; fastest: 0.000034
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19
    WiFi MAC address 5c:cf:7f:a4:a2:4c
    WiFi Vcc 3.13, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 39360
    WiFi IP address 192.168.2.114
    WiFi signal strength -76dBm
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)



  • @dc42 said in I need some help!:

    unsuitable current setting. Please provide a link to the datasheet for your stepper motors.

    I dont have a data sheet handy. The steppers came with a folgertech printer kit. I've looked at their website but cant find any technical info on the steppers. There is a no part number on the motor. I could try to email them and get a data sheet.


  • administrators

    My understanding is that Folgertech used 12V 0.4A motors on their early kits. That was a terrible choice and if you have those motors, your best bet is to replace them. You could try reducing the motor current to 400mA in case that improves things.

    In later kits, I understand they supplied more suitable motors for 3D printer use.



  • I have 2 steppers motors for the y axis, they are wired to each other and plugged into the y driver on the board.

    I'm not sure this wire is assembled correctly. On y stepper 1, paired wires 1a and 1b dont connect to 1a and 1b on y stepper 2.

    This is what the wiring looks like for the y steppers.
    0_1531086261105_Y STEPPER WIRNIG.png

    Before I added the duet hardware, I was running an MKS board with Marlin on it and the printer worked correctly. All of the wiring and other components that arent Duet are reused from the MKS setup. I had to swap some pins on the e-stop connectors but everything else (wiring wise) is unchanged.



  • @dc42 said in I need some help!:

    My understanding is that Folgertech used 12V 0.4A motors on their early kits. That was a terrible choice and if you have those motors, your best bet is to replace them. You could try reducing the motor current to 400mA in case that improves things.

    On the stepper motor, it says "1.8deg 5.0kg/cm 1.5A"

    Ill try lowering the current and see what happens.


  • administrators

    If they are rated at 1.5A then they should be ok.



  • So I got the paneldue to work. There was a bad crimp on one of the pins in the plug. So at least one issue is sorted. Still havent been able to figure anything out with getting the steppers to work the right way.


  • administrators

    The X and Z motor issues are probably also caused by bad crimp connections, if the motors really are rated at 1.5A and you have set the steps/mm about right. The error message when you command Y movement suggests a short in the wiring or a faulty driver.



  • So worked on the printer some more yesterday. I took one of the legs off the 2 stepper motor wiring harnesss for the y axis. Used this harness (with a junction block in the middle) and the motor works correctly! I can plug any stepper into any axis on the board and, as long as i use this specific wiring harness, the stepper works as expected. I tried a few other things and I am now under the impression that I need to rewire the steppers. We tested the "bad wires" every way we could with a multi-meter. Conductivty, resistance, cross-talk/shorts....we couldnt find anything wrong with the bad wires. Not sure what that means but Im thinking Ill try rewiring and see how that turns out.

    Even the Y axis works in this setup so I'm hopeful that I dont have a blown driver.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.