Z probe already triggered at start of probing move



  • I'm converting my Tevo Little Monster to a Duet. I've nearly completed the conversion, but when the BL touch is used i get the following: Z probe already triggered at start of probing move. I'm at a loss t explain it.

    Configurations below.

    Config.g
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 22 2018 13:17:26 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R170 L397.19 B155 H520 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PTLM ; Set machine name
    M552 S1 ; Enable network
    M587 S"Tokyo" P"H@ppyD@y!" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E403 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P5 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X0 Y20 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 R150 S45 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H1 T50 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M591 D0 C3 P2 E6 0

    deployprobe.g
    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 22 2018 13:17:26 GMT-0700 (Pacific Daylight Time)
    M280 P3 S160 ; clear and reset BL touch
    M280 P3 S10 ;

    Bed.g
    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 22 2018 13:17:26 GMT-0700 (Pacific Daylight Time)
    M561 ; clear any bed transform
    G28
    M190 S70
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y132.28 H0 Z-99999
    G30 P1 X121 Y69.86 H0 Z-99999
    G30 P2 X129.9 Y-75 H0 Z-99999
    G30 P3 X0 Y-150 H0 Z-99999
    G30 P4 X-129.9 Y-75 H0 Z-99999
    G30 P5 X-121 Y69.86 H0 Z-99999
    G30 P6 X0 Y59.15 H0 Z-99999
    G30 P7 X56.09 Y32.38 H0 Z-99999
    G30 P8 X64.95 Y-37.5 H0 Z-99999
    G30 P9 X0 Y-75 H0 Z-99999
    G30 P10 X-64.95 Y-37.5 H0 Z-99999
    G30 P11 X-56.09 Y32.38 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    M98 Pretractprobe.g ; retract mechanical Z probe
    G29



  • What firmware version are you using?

    In the latest stable firmwares 1.21 and 2.0 the BLTouch has it's own probe type P9 and is deployed and retracted automatically when a G30 is called. The new 2.01 beta 2 also has a couple of fixes for BLTouch.

    I suggest testing with the latest firmware using this as your M558 and G31 commands and see how it behaves. You can remove the manual M98 Pretractprobe.g and deploy calls as they are no longer needed.

    M558 P9 H5 F100 T6000 A5 R0.1 ; P9 for BLTouch, dive height 5mm, probe at 100mm/min, travel 6000mm/min, up to 5 probes, pause 0.1s
    G31 X# Y# Z# P25 ; probe XY offset and Z trigger height and trigger value 
    

    You should probably also remove the clear and reset servo command for the bltouch from the deploy and retract macros and add it to the start of your homing files instead.



  • Firmware Info:
    0_1532396447845_Firmware.PNG

    The change you recommended did something but didn't fix it. Now when i run G30 S-1, the probe deploys then throws the Error: Z probe already triggered at start of probing move.
    I've commented out the M98 commands, and M280 P3 S160

    Per the guide i was following i did remove the bridge on the BL Touch to use 3.3v logic.
    0_1532396709027_bltouch.png

    Thanks



  • If you send the deploy and retract servo commands manually does it work?



  • yep works fine

    M280 P3 S90 I1 retracts
    M280 P3 S10 I1 deploys



  • And if you manually send a G30 command does the pin deploy?



  • Yes then immediately bounces back.



  • What does it do if you send it the self test servo command?



  • Bounces in and out. No errors.



  • I'm at a bit of a loss then. If the pin was dirty and getting stuck a bit that would explain it triggering before it should but if the self test works fine then that would indicate the pin is fine. The servo commands work as expected so the wiring would appear to be ok.

    Can you post your config files again as they are currently?



  • Sure thing:
    Config.g
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R155 L397.19 B155 H525 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PTLM ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E425 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 A5 R0.1 ; P9 for BLTouch, dive height 5mm, probe at 100mm/min, travel 6000mm/min, up to 5 probes, pause 0.1s
    G31 X0 Y20 Z0 P25 ; Set Z probe trigger value, offset and trigger height
    M557 R150 S45 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H0 T50 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M591 D0 C3 P2 E6.0

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory

    ;bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    M561 ; clear any bed transform
    G28 ; home all towers
    ;M280 P3 S160 I1 ; Clear any errors in BLTouch
    G0 Z400 ; Move while giving the BLTouch time to clear the error
    ;M98 Pdeployprobe.g ; deploy mechanical Z probe
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y132.28 H0 Z-99999
    G30 P1 X121 Y69.86 H0 Z-99999
    G30 P2 X129.9 Y-75 H0 Z-99999
    G30 P3 X0 Y-150 H0 Z-99999
    G30 P4 X-129.9 Y-75 H0 Z-99999
    G30 P5 X-121 Y69.86 H0 Z-99999
    G30 P6 X0 Y59.15 H0 Z-99999
    G30 P7 X56.09 Y32.38 H0 Z-99999
    G30 P8 X64.95 Y-37.5 H0 Z-99999
    G30 P9 X0 Y-75 H0 Z-99999
    G30 P10 X-64.95 Y-37.5 H0 Z-99999
    G30 P11 X-56.09 Y32.38 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    ;M98 Pretractprobe.g ; retract mechanical Z probe
    G29

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    ;M280 P3 S160 I1
    M280 P3 S10 I1

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    M280 P3 S90 I1



  • Everything looks ok to me.

    One question that I'm not sure matters or not because I'm not familiar with deltas but you have axis minima set but not maxima. Is that normal for deltas?

    Hopefully someone with more experience with the Tevo little monster and the BLTouch will chime in.



  • If i had a bad crimp on say pin1, pin2, or pin 8 on the duet, do you think that could cause it?



  • Anything is possible. Going back to the start and verify the wiring would be my next step.


  • administrators

    Check the crimp on the white wire in particular, and make sure you have connected it to the correct pin on the Z probe connector as shown here.

    alt text



  • Hello
    I have exactly the same problem, have you solved your problem and if so, can you tell me how did you do it?

    thank you in advance



  • Got it solved. The code changes form Phaedrux helped a bunch, but the white wire dc42 recommended was ultimately the culprit.

    Thanks both for your help!

    now to finish calibrating it.


Log in to reply