PT100s and thermistors



  • Hi Everyone,
    I was wondering if I could get some help.
    I am updating my control to use a Diamond mixing head, I have added a duex5.
    I did have a few problems when I updated the firmware but have solved them all except one.
    At the same time as adding the duex5 I added the PT100 controller and fitted the head with a PT100 sensor fitted to channel 201,
    I intended to continue to use the thermistor that I had fitted to the heatbed.
    Since fitting the PT100 I cant read the HB thermistor?
    I reassigned it to the thermistor that would have been used for hotend 1 and still get no reading?
    I take it I can use PT100s and thermistors together, so can any one tell me what I have done wrong.

    Thanks in advance
    Martin


  • administrators

    Yes you can use both together, as I do. I suspect that either you have a problem in your config.g file, or a problem with the bed thermistor or its wiring.



  • if i put a tester on either side of the plug going to the thermistor at room temperature i get 98K, My config.g is below everything else seems to work the only thing i haven't tried yet are the 3 extruders but i cant see why these should be a problem as XY&Z work ( i haven't set the steps per mm on the extruders yet but is somewhere about right):-

    ; Configuration file for Duet WiFi (firmware version 1.16)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Dec 22 2016 22:17:33 GMT+0000 (GMT)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y275 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P530 X-40 Y0 Z0.5 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M350 X64 Y64 Z64 E16:16:16 I0 ; Configure microstepping without interpolation
    M92 X403 Y403 Z8842 E418.5:418.5:418.5 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y1000 Z800 E800:800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T10000 B3988 C0 R4700 X1 ; Set thermistor + ADC parameters for heater 0 and remap it to channel 1
    M305 P1 T100000 B4138 C0 R4700 X201 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 201
    M307 H1 A223.8 C160.4 D6.5 B0

    ; Tools
    M563 P0 D0:1:2 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M568 P0 S1 ; Enable mixing for tool 0
    M567 P0 E0.01:0.01:0.98 ; Set mixing ratios for tool 0
    M563 P1 D0:1:2 H ; Define tool 1
    G10 P1 X0 Y0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M568 P1 S1 ; Enable mixing for tool 1
    M567 P1 E0.33:0.33:0.34 ; Set mixing ratios for tool 1
    M563 P2 D0:1:2 H ; Define tool 2
    G10 P2 X0 Y0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C
    M568 P2 S1 ; Enable mixing for tool 2
    M567 P2 E0.01:0.98:0.01 ; Set mixing ratios for tool 2
    M563 P3 D0:1:2 H ; Define tool 3
    G10 P3 X0 Y0 ; Set tool 3 axis offsets
    G10 P3 R0 S0 ; Set initial tool 3 active and standby temperatures to 0C
    M568 P3 S1 ; Enable mixing for tool 3
    M567 P3 E0.98:0.01:0.01 ; Set mixing ratios for tool 3

    ; Network
    M550 PMy printer ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P1 S1 I0 F500 H1 T120 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P0 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool


  • administrators

    @mjhall29:

    if i put a tester on either side of the plug going to the thermistor at room temperature i get 98K,

    Do you mean yo get a reading of 96Kohms? if so, that suggests that you have a 100K thermistor, unless the temperature is very low. But you have specified a 10K bed thermistor in the M305 command.

    Also, what do you mean when you say you "get no reading"?



  • Thank you,
    I have looked at that line hundreds of times and didn't see it. again thank you for saving my sanity.
    Perhaps i need some new glasses.
    Sorry for wasting your time due to either bad eyesight or just stupidity.



  • Not seeing things is normal. I had a recurring problem, when the y homed, y0 kept changing and I didn't see the problem until I turned the printer around. The bed insulation was hitting one of the switch connectors just right to disconnect it while homing, but it reconnected enough when the bed moved away from it. 🙂


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.