Starting Print in mid air???



  • I am having an issue with slicing. The starting G-code I am using may be faulty. The printer homes well and moves to begin the print. However, it will not lower itself to the bed. Instead it begins the print in mid-air about 10mm of the bed. I have tried several iterations of starting code but alas no luck. In the latest I inserted several Z0 variations (no luck) and M565 Z-.945. Can anyone direct me and provide me with instruction to move forward?? Here is the latest Cura Starting code I have tried (below).

    G21 ;metric values
    G91 ;Relative positioning
    G1 Z-1 ;Move Z down 1mm
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 ;Home XY
    M561 ;Clear any bed transform
    G1 X345 Y565 ;Move probe to center of bed
    G32 ;Start 2-point probe sequence
    G29 S1 ;Load height map
    G1 Z20.0 ; Move Z to 20
    G1 X345 Y565 ;Move probe to center of bed
    M565 Z-.945 ;Set Z offset
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again



  • @vernon1xx I don't see you homing Z in there anywhere. But you are moving it around a lot.

    I don't think M565 is a valid gcode for reprap. Did you mean something else?

    How are you homing your printer?



  • Thank you for your reply! I have tried numerous iterations!!!!! The M565 was just one of many to get Z to zer0 (0). I will modify to the following, changing line 7 to G28: "home all". Line 10 to G30: "single probe". Remove line 14 that references M565. Thoughts???

    G21 ;metric values
    G91 ;Relative positioning
    G1 Z-1 ;Move Z down 1mm
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 ;Home XYZ
    M561 ;Clear any bed transform
    G1 X345 Y565 ;Move probe to center of bed
    G30
    G32 ;Start 2-point probe sequence
    G29 S1 ;Load height map
    G1 Z20.0 ; Move Z to 20
    G1 X345 Y565 ;Move probe to center of bed
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again



  • Well let's start at the beginning.

    Can you post your config.g and homing files?

    How are you homing Z? Z Probe? What kind? Have you measured the trigger height?

    After you home z, what happens if you try and move the head manually to Z0? Are you right touching the bed?

    If you disabled all bed compensation does it work better or worse? You may need to redo your mechanical bed level, and recalibrate your trigger height, and run G29 again to generate a new heightmap.



  • Your start code seems overly complicated. Most worrisome to me is why are you setting your Z offset at the beginning of every print? This should be set with G31 "trigger value" in config.g.

    I showed how to do it in the video here: https://youtu.be/BgkJVgFnPaE?t=21m47s

    Once that is set correctly, you should be able to use a very simple start script. Mine is this:
    G28 ;Home All
    G29 S1 ; Load old Bed Map -- remove the S1 to build a new bed height map
    G0 X0 Y0 Z5 ; Move print head to front left corner 5mm off the print surface in preparation for printing
    G92 E0 ; Set the extruder to zero
    G1 E8 ; prime the nozzle
    G92 E0 ; Set the extruder to zero



  • I only tried that version of start code once after many others. I really appreciate the assistance!!! I will post my config files and associated info ASAP!



  • Please find attached my config.g, and homing files. I am using a BLtouch to home Z. I configured the Z-probe offset in the config.g by moving the nozzle to the bed and entering G92 Z0. I then went to the G-code console and entered the command G30 S-1. The result was stopped at height of 0.974 the first time and 0.976 the second and so on. I updated the Z-probe trigger height to 0.97. I am able to home Z and actuate to the table. It allows me to move no farther than that. Thank you for the help, please let me know if I need to change anything or post additional files/info. I will view the video and try to disable all bed compensation.

    Config.g ☺

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards x
    M569 P1 S1 ; Drive 1 goes forwards y1
    M569 P2 S1 ; Drive 2 goes forwards z1
    M569 P3 S0 ; Drive 3 goes backwards y2
    M569 P4 S1 ; Drive 4 goes forwards z2
    M569 P5 S1 ; Drive 5 goes forwards E0
    M569 P9 S1 ; Drive 9 goes forwards E1

    M584 X0 Y1:3 Z2:4 E5:9 ; Define X, Y, Z, E drives
    M350 X16 Y16:16 Z16:16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100:100 Z3200:3200 E400:400 ; Set steps per mm
    M566 X900 Y900:900 Z12:12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000:12000 Z180:180 E3000:3000 ; Set maximum speeds (mm/min)
    M201 X500 Y500:500 Z250:250 E250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800:800 Z2800:2800 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X690 Y1130 Z1000 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active Low endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H7 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P5 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X35 Y-25 Z0.97 ; Set Z probe trigger value, offset and trigger height
    M557 X15:650 Y15:1100 S50 ; Define mesh grid
    M671 X345:345 Y-150:1230 S3 ; Leadscrew Coordinates for G32

    ; Heaters
    ;Bed Zone 5,6
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S85 ; Set temperature limit for heater 0 to 85C Bed, heat zones 5,6
    M307 H0 A28.2 C78.3 D10 S1.0 B0
    ;Extruder 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S240 ; Set temperature limit for heater 1 to 240C E0
    M307 H1 A177.4 C115.6 D8.1 S0.5 B0
    ;Extruder 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S240 ; Set temperature limit for heater 2 to 280C E1
    M307 H2 A288.7 C190.4 D5.6 S0.5 B0
    ;Bed Zone 1
    M305 P3 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 3
    M143 H3 S85 ; Set temperature limit for heater 0 to 85C Bed, heat zone 1
    M307 H3 A27.7 C69.3 D10 S1.0 B0
    ;Bed Zone 2
    M305 P4 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 4
    M143 H4 S85 ; Set temperature limit for heater 4 to 85C Bed, heat zone 2
    M307 H4 A21.8 C65.8 D10 S1.0 B0
    ;Bed Zone 3
    M305 P5 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 5
    M143 H5 S85 ; Set temperature limit for heater 5 to 85C Bed, heat zone 3
    M307 H5 A21.1 C53.1 D10 S1.0 B0
    ;Bed Zone 4
    M305 P6 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 6
    M143 H6 S85 ; Set temperature limit for heater 6 to 85C Bed, heat zone 4
    M307 H6 A21.1 C45.6 D10 S1.0 B0

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X-65 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M563 P2 H3 ; Define tool 2
    G10 P2 R70 S70 ; Set initial tool 2 active and standby temperatures to 0C
    M563 P3 H4 ; Define tool 3
    G10 P3 R70 S70 ; Set initial tool 3 active and standby temperatures to 0C
    M563 P4 H5 ; Define tool 4
    G10 P4 R70 S70 ; Set initial tool 4 active and standby temperatures to 0C
    M563 P5 H6 ; Define tool 5
    G10 P5 R70 S70 ; Set initial tool 5 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; homex.g ☺
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 20 2018 18:58:43 GMT-0700 (Pacific Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    G1 X-690 F1800 S1 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000 ; go back a few mm
    G1 X-870 F360 S1 ; move slowly to X axis endstop once more (second pass)
    M98 Pretractprobe.g ; retract the mechanical Z probe
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homey.g ☺
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 20 2018 18:58:43 GMT-0700 (Pacific Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-1130 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-1130 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homez.g ☺
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 20 2018 18:58:43 GMT-0700 (Pacific Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X345 Y565 F6000 ; go to first probe point center of bed and home Z
    G30 ; home Z by probing the bed
    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 Z5 F100 S2 ; lift Z relative to current position
    G90 ; absolute positioning

    ; homeall.g ☺
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 20 2018 18:58:43 GMT-0700 (Pacific Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    G1 S1 X-690 Y-1130 F1800 ; move quickly to X, Y and U axis endstops and stop there (first pass)
    G1 X5 Y5 U5 F6000 ; go back a few mm
    G1 S1 X-690 Y-1130 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X345 Y565 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    G1 Z5 F100 S2 ; uncomment this line to lift the nozzle after homing

    M98 Pretractprobe.g ; retract mechanical Z probe



  • Hi,

    Well first simple question.

    When you move Z down to 0 is the tip of the nozzle almost touching the bed?

    I configure my printer for a gap of 0.05mm.

    Frederick



  • Ok good, it sounds like you have measured the probe trigger height properly.

    Next question, what firmware version are you using?

    If you're using a version 1.21 or newer, you can use M558 P9 instead of M558 P5 for the BLTouch, this will let the system control deploying and retracting automatically when G30 is called, so you don't have to do it manually anymore. Also in the latest 2.0 versions there are a few changes to the handling of the BLTouch to make it a bit more responsive to triggering.

    But otherwise, if your BLTouch is working properly it looks like it is configured properly in your config.g.

    In your homex it looks like you're deploying and retracting the z probe. Not sure why.

    Your other homing files look ok.

    As for your start script, you have the option of also loading the mesh compensation map at startup rather than right before the print.

    Can you post a picture of what your heightmap looks like? It's possible that something is really off on the heightmap and so it;s trying to compensate for an error.



  • You may want to rerun the G30 S-1 test several times so that you get a better average value for the trigger height. It can take a while for the probe to setting in sometimes.

    You may also want to add a few values to the M558 command to help eliminate some bltouch problems.

    M558 P9 H3 F100 T6000 A5 R0.2 S0.01 B1

    A5 S0.01 tells it to probe up to 5 times if it doesn't get two results to within 0.01 of each other. And B1 turns off any heaters while probing to eliminate any possible wiring interference.

    Also, can you post the first 50 lines or so of a sliced gcode file that exhibits the problem? It would be helpful to see what the printer is actually being commanded to do.



  • Firmware Name:
    Firmware version:

    RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics:
    Duet WiFi 1.02 or later + DueX5
    Firmware Version:
    1.21 (2018-03-21)
    WiFi Server Version:
    1.21RC4(08b3)
    Web Interface Version:
    1.21-RC4



  • I will make the changes, and post accordingly. Thank you!!!!!



  • You should probably upgrade to the latest 1.21.x or 2.x releases for all your firmware as there were a few bug fixes that may be affecting you. You're also on release candidates and it's a good idea to upgrade to the full release once it's out.

    https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md

    Namely from 1.21.1

    If G30 was used to set an accurate Z height after mesh bed probing or loading a height map, if bed compensation was then cancelled then any Z offset from the height map remained. One consequence of this was that if bed probing was run again, the original height map Z offset was carried through to the new one, but the sign of the offset was reversed.

    https://github.com/dc42/RepRapFirmware/releases


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.