Dual Z screws are screwed

  • I have dual Z screws, and the 1st time around I set this up, worked with no problem. I took out ove of the Z steppers to use it as an extruder for testing, and when I set up dual Z again, its messed up. After a print, I run Auto Bed Compensation, and one of the two sides is always much higher than the other. about 1 or 1.5 mm.
    Any ideas would be appreciated.

  • @bluedust Do you have one stepper for every screw or one stepper in total?

    Possible reasons I can think of:

    If one stepper for every screw:

    • slipping gear on the axis of one stepper, slipping coupling
    • steppers behave differently, loosings steps of one stepper e.g., try lowering current and speed
    • horizontal axis jams sometimes, one stepper looses steps (the side which jams more)

    If one stepper in total:

    • slipping pulley at one screw

    I would calibrate the X axis to be horizontal and it runs smoothly first. Test gears/couplin to be tightly screwed.

  • Moderator

    Another reason with one motor per screw might be to move Z motors just a tiny bit too fast (speed/accel/jerk), so that the one which has the higher vertical load at that moment (if you have a Cartesian this depends on where the extruder carriage is at this moment, on a CoreXZ... no idea if there could be any imbalance) skips a few steps. This might not be noticed especially on the rare moving Z axis but could lead to one side being off just a little as you describe.

  • From your post, I'm assuming that you have 2 Z stepper motors, and that the printer worked, but you (temporarily) removed one motor, and when you reinstalled it, you're getting inconsistent results.

    Is it consistent? Is it always the same motor that is lower at the end of the print, or does it go back and forth?

    I'm sure that you checked, but I'll ask for completeness. Are you certain that you didn't get anything stuck in the motor mount, like plastic debris, or bits of leftover plastic skirt/brim? Are all the screws tight? Are the Z screw couplers tight and have you checked them for play?

    I'd think that the most likely cuplrit would be a set screw that is allowing the motor to turn inside the coupler, or the coupler to turn without turning the screw. A very small amount would add up, particularly if you have fine-pitched screws. It's unlikely to be the control electronics, or the motor itself. I would think that a mechanical issue is the highest probability. (I just replaced my Z couplers, and had an issue where the threaded rod on one side would MOSTLY turn with the motor, buton high speed moves, or with sudden reversals like a short lift motion could get out of sync with the motor.)

    I'd go over all of the screws, from motor mounts to couplers and make sure that they're tight. I'd go with both sides, just to be sure. Make sure that you can't turn the screws without the motors turning. With them powered on, you shouldn't be able to turn the screws at all.

  • Thanks guys!

    The backlash nut on the screw/threaded rod that was always going too high was too tight. Not sure how it got that way as when I temporarily remove that Z stepper, as I didn't take it off the threaded rod.
    I would have thought I would have had more problems with the one too loose.

    Thanks for the ideas for me to look into!

Log in to reply