[help] Tevo Little Monster + DuetWiFi + DuetTouch7" errors



  • Hi All,
    Is my first post here.
    I come close this forum several time ago looking for buying a DuetWiFi for upgrade my Tevo Little Monster. (I build by my self the enclosure with magnetic latch)
    I followed this guide for adapt the DuetWiFi to this printer:
    https://www.akeric.com/blog/?p=4325
    That refer to this one:
    https://www.thingiverse.com/thing:2355136
    That refer to several post here...
    I also followed all wiki for connect the printer , update the bios , setup the BLTouch.
    The wires seems to be ok. I can make a sort of calibration. I can ear and see the BLT release the trigger on the glass and complete the calibration.
    BUT...im out of ideas about some errors that now stop the printer to work.
    Im using the last stable Firmware 2.01. The web control is 1.22.3.
    motors are original so 1.8 degree.
    Heater and fans are original too and seems to work.

    I managed to start a print that stop it self after 47min complaining :

    G28 Error: G0/G1: insufficient axes homed

    Then I received also other errors:

    Error: Z probe already triggered at start of probing move
    Warning: Macro file retractprobe.g not found.
    Error: G0/G1: attempt to move individual motors of a delta machine to absolute positions

    And try to printing:
    Cancelled printing file 0:/gcodes/Tevo_LM_Duet_Adapter_v1.gcode, print time was 0h 2m
    Error: G0/G1: attempt to move individual motors of a delta machine to absolute positions

    I tried to upload in the /sys directory the config files of the second guide. But of course the new releases of the firmware work different so I tried to use some setting posted by this guy here:
    https://forum.duet3d.com/topic/6148/z-probe-already-triggered-at-start-of-probing-move/11

    Nothing to do...is a mess. I could be useful have a working config.g for this printer with the new firmware. But I'm not able to find it the web.


    The start script before the printing is this:
    M280 PS3 ; set bitouch to probing position
    G28 ; home all axes
    G1 Z50 F25000 S2; lift nozzle by 50mm
    G30 Z0.8 ; set height that bitouch triggers
    M280 PS7 ; set bitouch to idle position
    G1 X0 Y0 Z100 S2; lift nozzle to 100mm


    This is the config.g that im using:
    Config.g
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R155 L397.19 B155 H525 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PTEVO Little Monster ; Set machine name
    M552 S1
    G4 P1000
    M587 S"-------" P"-------"
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives original ones with 1.8 degree
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E425 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 A5 R0.1 ; P9 for BLTouch, dive height 5mm, probe at 100mm/min, travel 6000mm/min, up to 5 probes, pause 0.1s
    G31 X0 Y20 Z0 P25 ; Set Z probe trigger value, offset and trigger height
    M557 R150 S45 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H0 T50 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M591 D0 C3 P2 E6.0

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory

    ;bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    M561 ; clear any bed transform
    G28 ; home all towers
    ;M280 P3 S160 I1 ; Clear any errors in BLTouch
    G0 Z400 ; Move while giving the BLTouch time to clear the error
    ;M98 Pdeployprobe.g ; deploy mechanical Z probe
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y132.28 H0 Z-99999
    G30 P1 X121 Y69.86 H0 Z-99999
    G30 P2 X129.9 Y-75 H0 Z-99999
    G30 P3 X0 Y-150 H0 Z-99999
    G30 P4 X-129.9 Y-75 H0 Z-99999
    G30 P5 X-121 Y69.86 H0 Z-99999
    G30 P6 X0 Y59.15 H0 Z-99999
    G30 P7 X56.09 Y32.38 H0 Z-99999
    G30 P8 X64.95 Y-37.5 H0 Z-99999
    G30 P9 X0 Y-75 H0 Z-99999
    G30 P10 X-64.95 Y-37.5 H0 Z-99999
    G30 P11 X-56.09 Y32.38 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    ;M98 Pretractprobe.g ; retract mechanical Z probe
    G29

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    ;M280 P3 S160 I1
    M280 P3 S10 I1

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    M280 P3 S90 I1

    Of course any help is appreciated !!

    0_1537371274780_20180919_162401.jpg



  • This error is given at any time the trigger is released during the calibration:
    Error: Z probe already triggered at start of probing move



  • Try increasing your dive height.


  • administrators

    The M280 PS3 and M280 PS7 commands in your slicer starts script are not right.

    I suggest you home the printer and then test the bltouch as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • Thanks for the support!!!
    I'll try all you suggestions 😉
    I changed the starting script with this, as in the guide conversion is suggested:
    G1 X0 Y0 Z100 ; lift nozzle to 100mm
    The ending script:
    G28 ; home all axes
    M106 S0 ; turn off cooling fan
    M104 S0 ; turn off extruder
    M140 S0 ; turn off bed
    M84 ; disable motors

    Now what I have noticed is , when I power on on the printer it star the calibration but of several point that it is suppose to touch just the first near 4 points use the trigger, that is released twice! Then the trigger stay released and the printer continue to move to all the other points.
    Im almost sure is just a question of settings.
    I read in other post that the new releases of firmware work slightly different and some Gcode have to be removed. Im trying to figure it out.
    Thanks again for your time!

    My bed.g:
    ;bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    M561 ; clear any bed transform
    G28 ; home all towers
    ;M280 P3 S160 I1 ; Clear any errors in BLTouch
    G0 Z400 ; Move while giving the BLTouch time to clear the error
    ;M98 Pdeployprobe.g ; deploy mechanical Z probe
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y132.28 H0 Z-99999
    G30 P1 X121 Y69.86 H0 Z-99999
    G30 P2 X129.9 Y-75 H0 Z-99999
    G30 P3 X0 Y-150 H0 Z-99999
    G30 P4 X-129.9 Y-75 H0 Z-99999
    G30 P5 X-121 Y69.86 H0 Z-99999
    G30 P6 X0 Y59.15 H0 Z-99999
    G30 P7 X56.09 Y32.38 H0 Z-99999
    G30 P8 X64.95 Y-37.5 H0 Z-99999
    G30 P9 X0 Y-75 H0 Z-99999
    G30 P10 X-64.95 Y-37.5 H0 Z-99999
    G30 P11 X-56.09 Y32.38 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    ;M98 Pretractprobe.g ; retract mechanical Z probe
    G29



  • Edit:
    Chronology with success for the calibration:
    If I run the G30 as suggested in the guide for the dynamic single probe the console return:
    G30
    Error: Z probe already triggered at start of probing move

    The light of the BLTouch is blinking.
    The trigger is released.
    And if I try to send M280 P3 S90 I1 (also without i1) nothing happen.
    Sending M280 P3 S160 I1 (clear the BLT errors) the trigger retract and the light stop blinking .
    Now the G30 work and slooooowly the head go to the bed with the trigger released and stop retracting the the trigger and turning on the light when it touch the bed.
    Ok, the head stop some mm before the bed so I sent M208 S1 Z-3 for make the nozzle touch the bed.
    I sent the G30 S-1 that report:
    Stopped at height 2.440 mm (I putted a pad near 1mm thick for avoid impact with the glass)
    Now in the config.g i wrote something like this:
    G31 X0 Y20 Z2.440 P25 ; Set Z probe trigger value, offset and trigger height.

    Well...after rebooting the printer calibration was different. The points checked was far more than before. For all points the trigger was released 2 times. The calibration end with the head on one side of the bed.



  • @phaedrux said in [help] Tevo Little Monster + DuetWiFi + DuetTouch7" errors:

    Try increasing your dive height.

    Do you mean what i have done or something else?
    Of course I beg your pardon for my incompetence.



  • @dc42 said in [help] Tevo Little Monster + DuetWiFi + DuetTouch7" errors:

    The M280 PS3 and M280 PS7 commands in your slicer starts script are not right.

    I suggest you home the printer and then test the bltouch as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    Fine , seems you were right for make a complete calibration to work.



  • Keep trying to solve all the issues:
    1)Now, After calibration the head stay on one side close to the bed.
    If i send a G28 for home all axis just the Z turn to home , the other 2 move just a little .
    G28 Error: G0/G1: insufficient axes homed
    In the WCC >>>Machine control>>> the home x and Home y are orange and I have to home twice for making finally home the other two axis.
    I have seen this : https://forum.duet3d.com/topic/4782/error-after-upgrade-to-1-21/2
    but i cant understand if this is the right direction to investigate..
    2)When I restart the printer the wifi give an error in the console of the touchscreen :
    Error : M587: Failed to add SSID to remembered list HTTP is enabled on port 80 FTP is disabled TELNET

    BUT after the calibration the wifi start to work properly.
    Is not a big deal, is just for understand...



  • Unfortunately I cant print a thing.
    All the file printed stay on printing continuously on the 1st layer.
    The gear of the extruder consume the filament in the same place because the filament cant be extruded.
    It seems that the printer is unable to rise on the Z axis during the print 😞
    The extruder seems to work properly. I can extrude and retract the filament. But when I print the head stay on the first layer 😞0_1537552075875_Tevo_LM_Duet_Adapter_v1.gcode



  • I know you've gone through a few guides but it kind of sounds like your motors aren't responding as expected.

    Can you take a look at this delta setup guide and compare it to what you have?

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareDeltaPrinter



  • Sure! I'll check your link and I will report here...
    Is my first printer and is all new. I'm glad to learn new stuffs .
    Could be as you suppose. All the guides are made for different motors from the original ones.
    I changed just this:
    M92 X80 Y80 Z80 E425 ; Set steps per mm , that were settled on x160 y160 z160 for the 0.9 motors.



  • Phaedrux ,
    I have read all the document you have linked. And for what i can see the data should be coherent.
    The section where with the G91 command (for allow to move independent axis) to check if the motor work properly , is executed without errors. The motors seems work all fine.
    If i move down the x axis G1 S2 X-10 it go down and vice-versa if I move up the x with G1 S2 X10 it go up. the other two axis go fine.

    I don't know if is a Slicer problem. Im using Simplify3D with settings i used with the original Tevo . I just changed the firmware section for add the RepRap configuration be loaded.

    Then....
    in the homedelta.g there is this line:
    ; Move all towers to the high end stopping at the endstops (first pass)
    G1 X505 Y505 Z505 F1800 S1
    and in the config.g there is this one:
    M665 R155 L397.19 B155 H525 ; Set delta radius, diagonal rod length, printable radius and homed height
    The 505 above should be far height than that?
    In the kossel example with an height of 240mm volume the G1 command is settled on 320. If my printer have an height of volume of 525 how much i should add to 505?

    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 22 2017 22:56:20 GMT-0400 (Eastern Daylight Time)

    ; Use relative positioning
    G91

    ; Move all towers to the high end stopping at the endstops (first pass)
    G1 X505 Y505 Z505 F1800 S1

    ; Go down a few mm
    G1 X-5 Y-5 Z-5 F1800 S2

    ; Move all towers up once more (second pass)
    G1 X10 Y10 Z10 F360 S1

    ; Move down a few mm so that the nozzle can be centred
    G1 Z-5 F6000

    ; Switch back to absolute positioning and go to the centre
    G90
    G1 X0 Y0 F6000



  • Nothing to do , also Cura (last version) produce the same thing.
    The printer dont rise during printing on the Z axis. Stay on the same level all the time and the gear of the extruder consume the filament in same place blocking further extrusions.

    Suggestions?

    tnx



  • It's just odd that the motors will move properly when commanded manually but not when printing. Can you verify the motor current while printing? Send M906 and then M913 without parameters in the console and it will report what the current is set to along with any percentage scaling. Maybe there is a rogue current reduction command happening somewhere.



  • M906
    Motor current (mA) - X:1800, Y:1800, Z:1800, E:1800:1800:1800:1800:1800:1800:1800:1800:1800, idle factor 30%
    M913
    Motor current % of normal - X:100, Y:100, Z:100, E💯100💯100💯100💯100:100

    I tried different voltages for the 4 motors. Are all identical and the default should be 1.8.
    I tried also 1200 and 1000. Nothing change.
    I tried also the firmware 2.0 but didnt work either. Exactly same attitude as the 2.01.
    The probe is settled well ,it perform a good calibration without errors reporting the graph of the surface. Of course not rising the z axis during the print generate a mess of plastic under the extruder.

    Im starting to feel a little sad...

    There is something that can inhibit the Z axis rising during the printing?



  • @giostark can you post the code file you are trying to print



  • 0_1537811866488_stab.gcode
    0_1537812126970_Tevo_LM_Duet_Adapter_v1.gcode
    Maybe those files and setting are not perfect but the first (stab) with the original motherboard was printed several time.
    Im able to perform a "good" calibration without errors. For this reason I dont think is something related to the hardware. I settled the zprobe and the first layer is printed well. the second one come printed on the 1st and so on generating a mess of plastic.
    0_1537812412280_calibration.jpg



  • This post is deleted!


  • Well I notice 2 things from your gcode file. First, you don't have a G28 in there to home the printer, so if it isnt already homed when you start the print it may cause problems. Second, your Z moves are all negative.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.