No Y Movement During Print



  • I'm in the process of commissioning a new D-Bot printer and I'm seeing strange behavior of the Y axis during my first test prints. The printer homes successfully then moves to the front center of the bed and starts to print but there is no Y movement once it reaches the starting location. So instead of a 20x20 cube I end up with a weird 20x1 tower. The printer never moves the Y axis after the print starts and the skirt doesn't print correctly either.

    When I test the X/Y axis motion manually everything seems to behave correctly.
    +X moves to the right / -X moves to the left
    +Y moves to the back / -Y moves toward the front

    The X endstop is at the low end and the Y endstop is at the high end.

    I also see the correct diagonal movement when I run the test commands on the CoreXY configuration page.

    I suspect I have some fundamental misconfiguration somewhere but I'm just not sure what I'm missing here. Any ideas would be appreciated.

    Duet 2 Wifi 2.0(RTOS)

    config.g
    homeall.g
    xyzCalibration_cube.gcode



  • How do you have your slicer configured? It sounds like the origin isn't set right in the slicer and its trying to print off the bed edge.



  • In Slic3r I have the bed size set to x300 y200 with the origin at x0 y200 (back left of the bed).

    0_1538161417450_slic3r.jpg



  • What @Phaedrux said. If you take a gander at the gcode file, you'll see that all the Y moves are to negative absolute positions. So the gcode file is telling the printer to move beyond the axis minimum which is set (correctly) to zero in your config.g. The firmware won't allow that to happen so the print head stay put - at least in the Y direction.

    In summary, its the gcode file that you are trying to print that is amiss - probably because of a slicer setting. Did you slice the file yourself or is it one you've downloaded from somewhere?



  • @skear Yup. Try origin zero zero, not zero 200.



  • Yeah there you go. 0,0 should be front left. The printer will still home to the back left because that's how the endstops and homing files are configured, but the origin of the coordinates system doesn't care about any of that.



  • @phaedrux @deckingman

    Yep, setting the origin to 0,0 did the trick! I was using 0,200 since that was what the D-Bot build guide showed. Thanks for the assistance.

    0_1538184344158_IMG_8846.JPG



  • Congrats on the DBot build.


Log in to reply