G0 Z0 change



  • I have a tevo little monster printer and would like to put a 3 mm glass plate over the previous plate.
    My problem is setting Z0.
    When I type the Gcode command g0 z0 the printer always moves to 3 mm above the print bed.
    If I now lay out the 3 mm plate it would touch the glass.
    How can I change the config from 3mm to 6mm?

    About :
    G31 P25 X0 Y20 Z1.16
    It doesn't work. This is only taken into account when printing via a start code.



  • Furthermore I have only noticed that the pressure level is correct if the Auto Calibration is done before.
    My start code in Simplify3D is :
    G28 ;Home
    G32
    ;G29 S1
    G92 E0 ; Set extruder to zero
    G1 E8 ; prime the nozzle
    So he just measured everything and then the distance was the value chosen in G31 P25 X0 Y20 Z1.16.
    If I use G32 comments and G29 S1 it doesn't work.
    Unfortunately I don't know much about Gcodes.
    Just did everything according to the following video:
    https://www.youtube.com/watch?v=BgkJVgFnPaE



  • Do you auto calibrate before each print? If so then reduce the overall height of the printer in M665 by around 3-4mm. When you next run calibration the probe should be clear of the 6mm bed, and G0 Z0 should work as expected.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M665_Set_delta_configuration

    if you are saving/restoring your calibration using M500/M501, remember to make the change in config-override.g as well as config.g

    If you don't calibrate every print, or if this is an infrequent requirement to use a 6mm bed, you could do something like the following, perhaps in a macro:

    G28          ; home all axes
    G0 X0 Y0 Z10 ; go to 10mm above the centre of the bed
    G30          ; probe bed and set Z position to the probe trigger height
    


  • Where is this 3 mm distance specified ?

    My procedure for determining Z0 is:

    home
    M564 S0
    G0 Z0
    G92 Z0
    G1 Z5
    G30 S-1 Zoffset see
    Enter in settings config.g

    I couldn't find config-override.g on the memory card.
    I didn't use M500 either. I did it like in the video.
    Just read it and entered it in the config.g under G31 P25 X0 Y20 Z1.16.



  • @roth

    Here is a good place to start:

    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Auto_calibration

    It will take you step-by-step through learning to calibrate your machine. Between that and the Tevo-specific information in the video, you will be up-and-running in no time.

    RepRapFirmware's use of "GCode everywhere", although daunting at first, is one of it's key features and makes for some amazing capabilities. @deckingman's recent thread showing off his CoreXYUV behemoth is testament to that!



  • What would a real start code look like where it doesn't miss the whole heating bed every time ?

    With the original MKS board it only goes down once and measures the height in the middle.



  • @roth

    From the docs:

    M665: Set delta configuration
    Parameters

    Lnnn Diagonal rod length
    Rnnn Delta radius
    Bnnn Safe printing radius
    Hnnn Nozzle height above the bed when homed after allowing for endstop corrections
    Xnnn X tower position correction1
    Ynnn Y tower position correction1
    Znnn Z tower position correction1

    The H parameter is the homed height of the nozzle tip above the bed. Reducing that by 3mm will make Z=0 3mm higher



  • @roth said in G0 Z0 change:

    With the original MKS board it only goes down once and measures the height in the middle.

    Those three lines I gave you earlier should achieve something similar.

    Again, best to familiarise yourself with the documentation and take small steps.



  • @roth said in G0 Z0 change:

    Where is this 3 mm distance specified ?

    My procedure for determining Z0 is:

    home
    M564 S0
    G0 Z0
    G92 Z0
    G1 Z5
    G30 S-1 Zoffset see
    Enter in settings config.g

    I couldn't find config-override.g on the memory card.
    I didn't use M500 either. I did it like in the video.
    Just read it and entered it in the config.g under G31 P25 X0 Y20 Z1.16.

    That sequence looks like a way of calibrating the Z offset between the probe and the nozzle tip. That won't help you to find z=0 in normal operation. You should only need to calibrate the Z offset in G31 once, unless you swap nozzles or probes.



  • Yes I have my problems with that because I don't understand everything because I have to translate it into German.
    I can translate some English but it is difficult to understand complicated texts.

    And I don't quite know how the firmware works. Why you always make +3 mm with g0 z0.
    Because normally it should still be at the value where you have determined 0 via the correction in G31 P25 X0 Y20 Z1.16..
    With the MKS board it is at least so.
    But there it was like this when an overdrive file was created which was ignored in the config.



  • @adavidm Yes the Offset is Z1.16. But he just ignores the input in the config without this G32 line in the start code.



  • @roth
    Ah. I did not realise you were translating into German! Entschuldige

    If you look in your config.g, you should see the following line:

    M665 R115 L397.19 B155 H520.

    The H520 is the vertical print height of your printer, with the same bed as in the video. Try changing this to H517. This will make the printer think that the height is 3mm smaller than before. You will need to reboot for this to take effect.

    Did you set up the beg.g and other files the same as in the video? If so then you do not need to have G28 or G29 S1 in your start code. The G32 command will run bed.g, which already contains a G28 (to Home) and a G29 (to make a new mesh for bed compensation).

    For now, after changing the height, try powering on your printer then running G32 from the console. The following should happen:

    1. The printer will home
    2. The probe will deploy
    3. The auto calibration will run, with 13 points tested
    4. The probe will retract
    5. The mesh compensation probe will run

    At that point you should be ready to print. You probably need to change your start code to include a bed and nozzle heating command early on. It is best practice to calibrate with heaters at normal operating temperature.



  • Yes i make all like the video.
    You don't have to apologize.
    I would have to work hard to improve my Englsch. I'm gonna grab a bite to eat.



  • @roth

    Ok, good. Try making the change and test as I have suggested. I have to leave now but will be back later today this evening if you are still having problems.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.