Duet Ethernet Won't Connect During Long Print Job



  • Hi,

    I am currently running a long print job on a Tevo Little Monster with a Duet 3D Ethernet controller. At some point during the print, my computer lost connectivity to the Duet 3D controller via ethernet and it now will not connect over ethernet. I am able to connect to the printer through the USB port and issue commands through YAT. The printer and computer are plugged directly into the same 4-port router / switch and I can connect to another printer on the same switch. I've tried a different ethernet cable as well as a different computer plugged into the same switch, all with the same results.

    What should I try next?

    Thanks,
    Kevin



  • I forgot to mention: I tried shutting off and restarting the network controller via the M552 command, however that did not resolve the issue.


  • administrators

    @kzamani you can reset the network interface through

    M552 S0
    M552 S1

    If you are not using DHCP then the second M552 command needs to have the IP address you use as well:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M552_Set_IP_address_enable_disable_network_interface

    Before you do that you can send M552 with no switches to see what IP adress the Duet has and confirm you are connecting to the right address (if using DHCP)

    Cheers

    Tony


  • administrators

    @kzamani said in Duet Ethernet Won't Connect During Long Print Job:

    I forgot to mention: I tried shutting off and restarting the network controller via the M552 command, however that did not resolve the issue.

    Ahh apologies. posts crossed



  • Is there a way to manually pause the print through the YAT terminal to allow for a filament change?


  • administrators

    @kzamani M25 will run "pause.g" and then pause the print

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M25_Pause_SD_print



  • Will the M25 command work if I am printing from a file uploaded through Duet Web Control?? I am unclear how the system differentiates between SD printing and files uploaded through DWC.


  • administrators

    @kzamani Yes, M25 works to pause a SD print weather it is sent from DWC, the PanelDue, or over the USB. Files uploaded over DWC are printed from the SD card so are SD prints. The Firmware does not distinguish between a file uploaded to the SD card or a file placed there by ejecting the card, adding the file and then re-inserting it.



  • That's really great news, thanks for the support!

    With regards to the network issue -- would you like any logs from this controller to see if it is failing?



  • Hello!

    You may be having the issue with the Ethernet port I came across very recently as the temperature and humidity drop in New York City.

    Static electricity.

    I built a large Delta Kossel this summer (1800mm x 700mm frame) out of 2020 and 2040 aluminum with corners of thick aluminum.

    My four-pin 0.9 42mm Nema 17 stepper motors are connected to the frame but there is a gap of rubber between the motor and aluminum corner for vibration and noise prevention.

    The motors do not have shielded cable and the aluminum isn’t a great conductor for a ground.

    During the summer and high humidity, I didn’t notice a problem.

    The other day during a 12 hour print, I lost any connectivity with the Ethernet port. Even the indicator light on the gigabit switch went out.

    The print worked out fine though but I was obviously puzzled as the Ethernet port issue didn’t happen right away.

    After some digging here, I found a conversation from 2017 that brought up some great points about grounding and how static electricity can really cause havoc.

    I’m removing my unshielded motor cables and using some 18/4 awg shielded cable in its place. I have just taken a break and noticed your message!

    You may want to check if your printer is using unshielded and/or ungrounded stepper motors.

    Apparently the static knocks the port right out.

    I don’t feel like taking the printer apart so I’m down on a yoga mat soldering. Ha!

    Good luck!

    Such a great forum!

    2_1540515060676_323D2942-BD39-48B4-AC44-5F4AAA70A823.jpeg 1_1540515060675_47866F3D-F34E-4499-8B24-BFAFDBB27FCE.jpeg 0_1540515060672_8A41F79F-886B-471C-ACAF-4E02458EB3CC.jpeg



  • @atfphoto That's a huge printer! I am using a Tevo Little Monster with stock motors, I'll look into whether or not the cables are shielded. Off the top of my head, I don't think they are.

    Thanks for the response, I hope this solves the issue!

    -Kevin


  • administrators

    @atfphoto great point, yes static build up may well be the cause of the issue.

    @kzamani if you can run M122 that would be helpful.


Log in to reply