Z Motor weak / one missing [solved for now]



  • System is 24 volts powered
    Core XY
    This is my Driver mapping. I am controlling 4 nema 23 motors
    M584 X0 Y1 Z2:4:5:6 ; Assign drivers to Z axis
    X and Y are fine

    • Z axis I have 3 turning and one that refuses to turn.
      I swapped motor between drive 4 and drive 2 to confirm motor is good (and it is). The drive 2 not turning.

    • The 3 that are turning i can easily stop the with my hand.
      I tried increasing the current with M906 X800.00 Y800.00 Z1200 E1200:1200:1200 I30.
      no luck


  • administrators

    Please post your config.g file.



  • ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Nov 13 2018 10:58:17 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PFraMal ; Set machine name
    M552 S1 ; Enable network
    M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M584 X0 Y1 Z2:4:5:6 ; Assing drivers to Z axis
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 E16 Z16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z200.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z1200 E1200:1200:1200 I30 ; Set motor currents (mA) and motor idle factor in per cent

    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X1200 Y1200 Z1000 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active low endstops

    ; Z-Probe
    M558 P5 H5 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:6 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • @buj said in Z Motor weak / one missing:

    System is 24 volts powered
    Core XY
    This is my Driver mapping. I am controlling 4 nema 23 motors
    M584 X0 Y1 Z2:4:5:6 ; Assign drivers to Z axis
    X and Y are fine

    Try

    M584 X0 Y1 Z2:4:5:6 E3 ; Assign drivers to Z axis, unassign 4 from E axis.
    

    If the motor on drive 2 isn't turning, check that the jumpers are on the second output of drive 2. If they aren't, then that motor will be open circuit, since the second motor boss is in series with the first one.



  • @supraguy said in Z Motor weak / one missing:

    then that motor will be open circuit, since the second motor boss is in series with the first one.

    Jumpers are present,and installed as per factory. could they be defective? i doubt but at this point... i'll check

    thanks



  • [Update] From what i hear from theZ axis motor is that the signal frequency is too high and motors start skipping assoonas they recieve a signal . going downward is easier...



  • Reduced the Z acceleration from 200 to 50. Now going up and down as expected.
    Still no output from drive 2 Z motor...



  • @Buj
    Z axis acceleration is probably too high, if there is no mechanical problem.



  • Mouvement out of 3 motors remapped as per config with low acceleration, still missing the 4th motor connected to Z output of DUET wifi


  • administrators

    Did you correct the M584 command as @SupraGuy suggested? That's very important, see the bold text at https://duet3d.dozuki.com/Wiki/GCode#Section_M584_Set_drive_mapping.



  • the assign beeing M584 X0 Y1 Z2:4:5:6 E3
    i understand that etruder is assign to 3? isnt it?
    how do i unassign a drive?


  • administrators

    @buj said in Z Motor weak / one missing:

    the assign beeing M584 X0 Y1 Z2:4:5:6 E3
    i understand that etruder is assign to 3? isnt it?
    how do i unassign a drive?

    Yes, that M584 command is correct. Do you still have the problem?

    It may help diagnose the problem if you upgrade to firmware 2.02RC3 because it has better stepper driver diagnostics.



  • The printer is on the move to the Maker Fair. will persue at a later date.

    Thanks#



  • The reason for explicitly assigning E to drive 3 is that by default it would be ... E3:4 -- with drive 4 also assigned as an E axis. (As per the bolded text in the article dc42 linked.)


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.