BL touch correct offset when homed...too high when printing



  • Hey everyone, I finally got my duet working on my upgraded ender 3 but I've been having the same issue for the past 3 days and just can't get it working.

    I have a duet 2 wifi with a BL touch sensor.

    I've set the Z offset following betrue3d's guide. When I home the Z axis then go to Z0, the nozzle is at the right height, but when I run the mesh grid compensation and then try to print something, the nozzle is always around 0.5mm too high off the bed.

    -Z babystepping won't work because the nozzle won't move past Z0.
    -Setting a negative Z offset in slic3r doesn't do anything.

    I'm completely lost and don't know whats causing this issue...
    Any help will be appreciated,
    Andrew


  • administrators

    1. How exactly are you homing the Z axis? Please post your homez.g and homeall.g files.

    2. To allow baby stepping below where the firmware thinks Z=0 is, change the Z parameter in the M208 S1 command in config.g to a value below 0, for example -1.0.



  • Use G31 in config.g. Measure the offset of the probe from the nozzle in both X and Y axis and the Z offset to compensate, in my case the probe is 0.7mm lower than the nozzle.

    G31 P500 X-4 Y-41 Z0.7 ; Set Z probe trigger value, offset and trigger height



  • Hey everyone, I have the same problem like this. Is there any solution?

    Thanks
    Tobias
    0_1554363558030_homez.g 0_1554363569640_homeall.g
    0_1554363607661_config.g


  • administrators

    @mrmo said in BL touch correct offset when homed...too high when printing:

    Hey everyone, I have the same problem like this. Is there any solution?

    1. Calibrate your Z probe trigger height as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height.

    2. In homeall.g and homez.g, move to the centre of the bed instead of to (15, 15) before the G30 command that probes the bed (I am assuming that your probe works anywhere on the bed).

    These two should ensure that the print head is at the correct height at the centre of the bed. If it isn't at the correct height away from the centre, first use the bed levelling screws to level it as far as possible (see https://duet3d.dozuki.com/Wiki/Using_the_manual_bed_levelling_assistant), then if necessary use mesh bed compensation (see https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation).



  • @mrmo Your z probe trigger height is negative (-0.7) in your config.g which isn't right. It should be positive, and if the BLTouch is installed correctly (The base of the probe body should be 8mm above the nozzle tip), it should be around 2mm when you measure it using the link DC42 provided above.

    Also, you can remove M98 Pdeployprobe.g ; deploy mechanical Z probe from your homing files because the G30 command will deploy and retract the pin as needed.

    And as DC42 said, the probe should be positioned close to the center of the bed for best results.



  • I too have been having this problem with the lack of 'squish' as Chep calls it!
    I bought a BL Touch to help me with my bed levelling, not to hinder it. Yes it is an official BL Touch as well as my Maestro.

    Started at 6am and had all the cabling wired and tested probe it would fire.
    All good. fitted it and by luck it was it was 8mm above the nozzle tip. Thanks Phaedrux, but did not find this post until 15:00.

    After following the info in here and all of the other good links, i was still getting nowhere, still no squish.
    I thought, back to basics.

    Wound all 4 bed level nuts tight and then backed of by a turn.
    Did the Z adjustment with a piece of paper in the centre of my bed.
    Reset Z to 0
    Homed all of my axis again. Jogged Z up 5, piece of paper under nozzle and jogged Z until it hit its max. Paper felt good.
    Disabled X and Y steppers and must of gone round the bed about 9 + times with the paper until it all felt good, adjusting the corners as i went.

    Did the suggestion @Phaedrux suggested, removing the M98's
    Then pressed the Auto Bed Compesation. All was shades of green when it had finished. Result.

    Skirt went down nicely and the mount I am printing is looking good also.
    There are other tweaks that need to be done, but am struggling to find a definitive guide on settings for Creality Printers.

    I am running a Creality Ender 3 Pro, if anyone wants my config as a base please let me know.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.