Duet Wifi - LED's Bedheating - flicker

  • Hi,

    I'm setting up my duet for the first time and I've got LED's on my machine however i'm noticing an issue with them once the bed is heated and the board is controlling the heat.
    The LED's flicker really fast for a few seconds then stop then it does it again over and over.
    If i look at the Duetboard - the LED for the bed heater is flicking at the same rate as my LED's
    I thought this was a PSU problem so i got a new Mean Well PSU with the issue so i disabled heater 2 in the config and configured heater 2 to be a fan that is always on on startup and i get the same issue as well.

    Can anyone assist with this problem - it obviously relates to the bed heating to keep it at temp

    thank you

  • administrators

  • the led should be on constantly if the bed heats up.
    As soon as it reaches the desired temperature it will pulse the power to keep the temperature constant.
    This will cause the led to turn on and off rapidly. This is normal.

  • administrators

    @aceycv8 said in Duet Wifi - LED's Bedheating - flicker:

    If i look at the Duetboard - the LED for the bed heater is flicking at the same rate as my LED's

    That sounds to me as though your PSU is not powerful enough to drive the bed heater. It's cutting out when you turn the bed heater on.

  • @T3P3Tony - Bed heating is set to PWM as B0 is set in my config should i be using bang bang?

    @dc42 - This is my third power supply i've tested now; first one was a desktop 700W PSU which i could see a lot of voltage drop when the bed was enabled so i went back to the original 12v 200w PSU that came with the system and the voltage is pretty solid - there is a small voltage drop when the bed is heating but then comes back to 12V once its at temp.
    So then i brought a Mean Well ERPF-400-12 and have the exact same issue.

    My LED light is perfectly fine while heating it's just once the bed is heated and it's trying to maintain temp it flickers like the bed heat status led does physically on the duet board.

  • administrators

    It's normal for the bed heater led to flicker when it is maintaining temperature. The other LEDs should not flicker.

  • Moderator

    You could try adjusting the PWM frequency of the bed heater. I had to do that when the bed heater was making some pot lights in my living room flicker. 😳

  • I've just done another PID tune with the new PSU, through the whole tuning process my external LED's are fine - i then set the temp of the bed quickly to 40deg - while it heats everything is fine and then when it's time to keep the temp of the bed stable i get the flickering LED's again even though my voltage is fine and happens on both " always on pins" and heater pins...

    0_1542503120603_bed tuning.PNG


    Would wiring the heatbed to the PSU with a SSR fix this issue?

  • administrators

    I think you are saying that you have connected external LEDs to the fan ports, and they flicker when the bed is maintaining temperature. Is that right?

    If so, it's cause by the voltage at the Duet VIN terminals dropping when the bed heater is on. This may because the PSU regulation isn't very good, or because the cable between the PSU and the Duet are too thin, or because you have a poor connection at one end of that cable. I suggest you measure the voltage with the bed heater on and with it off, both at the PSU output terminals and at the Duet VIN terminals. If turning the bed heater on causes the VIN voltage to drop but the PSU output voltage remains steady, then the problem is in the cable or its connections.

    Btw the M122 report will tell you the voltage measured at the VIN terminals. It may not be as accurate as a multimeter, but it will still show you the difference with the bed heater on/off.

    It may be impossible to eliminate completely the drop in voltage when the bed heater is turned on. If so, then you can increase the bed heater PWM frequency to e.g. 100Hz to make the flicker too fast to see. To do this, find the M307 command that resulted from tuning the bed heater and add parameter F100 to it.

  • probably best if you post a video to make your problem clearer

  • @dc42 - Adding the F100 fixed my issue ( i put it in config.override for the bed heater ) and it's perfect now

    Thankyou for your assistance much appreciated

  • Hi everyone, I've the same issue but now the M307 was remplace by M950 and I'll try Q100 for change the frenquency in config.g, and nothing change...
    I did the right way or not?

    (My problem here: https://forum.duet3d.com/topic/20539/duet2-wifi-sing-help/8)

  • @DIY-O-Sphere much better and I try with Q1 but not perfect...

Log in to reply