Configurator tool Bug?



  • Building my own version of E3D tool change machine
    Currently wiring and testing endstops/
    Using the 'https://configurator.reprapfirmware.org/Start' tool.

    Does not seem to set the Z endstop configuration having tried none, low and high?

    From config.g

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops



  • Hi.
    You probably told configurator, that you have Z probe. So look at ; Z Probe section of config file, there should be line someting like that : M574 Z1 S2



  • Thanks for reply,

    In Configurator I declared no Z probe. This is the line for Z probe...
    "M558 P0 H10 F120 T300 ; Disable Z probe but set dive height, probe speed and travel speed"

    The line
    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops

    is the only M574.


    I also tried setting X NONE, Y ACTIVE HIGH NC SW, Z ACTIVE LOW NC SWITCH and all active a low end of axis.
    I then get just
    M574 Y1 S1
    So seems pretty screwed up giving S1 rather than S0 and only one axis.

    So it looks like i'm going to have to do it manually 😞

    Question: If I want to define one axis at low end and one at high end do I use multiple M574 commands e.g.
    M574 X0 ; Disabled
    M574 Y1 S0 ; NC, Low axis
    M574 Z2 S1; NO, high axis.



  • You should tell configurator, that your Z probe type is switch, then you will have M574 line for Z endstop in config file.



  • Does not
    M574 Z2 S1;

    The 2 in Z2 mean active low NO switch, that is Normally Open and S1.

    This is what I chose in configurator but it does not produce these M codes.


  • administrators

    A agree, it looks like a bug in the configurator.

    Question: If I want to define one axis at low end and one at high end do I use multiple M574 commands e.g.
    M574 X0 ; Disabled
    M574 Y1 S0 ; NC, Low axis
    M574 Z2 S1; NO, high axis.

    If all the switches are NO or all NC, you need only one line. If you have a mixture of NO/NC/stall detect, you need 2 or more lines, one with each distinct value of the S parameter that you need. You can also use a separate line for each endstop if you wish.

    EDIT: I confirm, this is a configtool bug. The Z endstop type is not configured in M574 if the Z probe type is set to "No Z probe". We'll get it fixed. Thanks for reporting!



  • 2 in Z2 means, that switch is at high end of axes, not switch type. S parameter is for switch type. (NO or NC or probe or load detection).

    In configurator Endstop page i define : (from top of that page) Probe type - switch, and endstop configuration X - none, Y - Active high (NC) at low end, Z - Active low (NO) at high end - then i get in config file:

    ; Endstops
    M574 Z2 S0 ; Set active low endstops
    M574 Y1 S1 ; Set active high endstops



  • Thanks to dc42 for confirming I was not having a senior moment with config tool.

    Thanks to aidar for clarifying M574 command.


  • administrators

    This problem has been resolved, thank you for reporting it.



  • Still having trouble with this. I'm using
    https://configurator.reprapfirmware.org/Start
    It appears the current configurator tool does not remember setting Z endstop to Active high. I want to set all endstops to active high. Does not set an endstop for Z in config.g at all.
    get
    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    RE-loading from config.json shows it did not remember setting and defaults to set active low.

    Old configuration tool https://configurator.reprapfirmware.org/v1/ DOES set endstops
    get
    ; Endstops
    M574 X1 Y2 Z1 S1 ; Set active high endstops
    RE-loading old configuration config.json does remember the setting


  • administrators

    @st-taw said in Configurator tool Bug?:

    Still having trouble with this. I'm using
    https://configurator.reprapfirmware.org/Start
    It appears the current configurator tool does not remember setting Z endstop to Active high. I want to set all endstops to active high. Does not set an endstop for Z in config.g at all.
    get
    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    RE-loading from config.json shows it did not remember setting and defaults to set active low.

    Old configuration tool https://configurator.reprapfirmware.org/v1/ DOES set endstops
    get
    ; Endstops
    M574 X1 Y2 Z1 S1 ; Set active high endstops
    RE-loading old configuration config.json does remember the setting

    It's working for me now, except that if I try to download a JSON template, what it actually saves is a bunch of HTML.



  • The configuration is in the ZIP file as config.json.
    I don't know what the config.json file is that it offers in the interface. As you say appears as html


  • administrators

    @st-taw, I confirm the bug you reported: if the Z endstop type is set to "Active high switch" and a config zip bundle generated, when the config.json file is subsequently imported the endstop types is set to "Z probe". We will fix this.


  • administrators

    Thanks for your report, both issues have been fixed.



  • i definitely found a bug too with steps/mm for z-axis, was calling for like 8000 and it was more like 800....and i checked all the gearing and screw size.



  • @imrj Did you use the steps per mm calculator?



  • @phaedrux yes indeed


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.