DuetWIFI Web Interface will not connect, but did before



  • Already flashed latest firmware to 1.21.4(13b2) which was already installed. loaded latest www folder. sent M997 S0 to forget connection, then M587 with name/pw. Duet pings from PC, but still wont open web page.



  • If the PC can ping the Duet, that doesnt mean the Web Interface has access to do its work. It just means the network connection is made. Is there something in my PC causing the page to not load possibly. I have three PCs on the WIFI, and none of them work anymore. The problem seems to be on the Duet Hardware end. I am thinking there may be a hardware problem with these boards too. They are made in China, and changes are made frequently, so Its hard to feel like they are "rock solid" especially when they just stop working for no apparent reason.



  • If you purchased a genuine Duet3D board, they are not made in China.

    If you can ping the board but web pages don't load, I'd guess the web server files not he SD card (note, this is separate from the firmware) are corrupted/have been deleted.


  • administrators

    @henrydara said in DuetWIFI Web Interface will not connect, but did before:

    Already flashed latest firmware to 1.21.4(13b2) which was already installed. loaded latest www folder. sent M997 S0 to forget connection, then M587 with name/pw. Duet pings from PC, but still wont open web page.

    M997 is for upgrading the firmware, not for forgetting a connection.

    Latest stable firmware for Duet WiFi is not 1.21.4, it is 2.01.



  • @henrydara said in DuetWIFI Web Interface will not connect, but did before:

    Already flashed latest firmware to 1.21.4(13b2) which was already installed. loaded latest www folder. sent M997 S0 to forget connection, then M587 with name/pw. Duet pings from PC, but still wont open web page.

    Flush internet browser cache.
    It happens to me everyday or so on Mac with Safari with the same firmware.



  • This is from an M115 to the board...
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.02RC5(RTOS) ELECTRONICS: Duet WiFi 1.02 or later + DueX5 FIRMWARE_DATE: 2018-11-28b1<LF>ok<LF>

    Also M503 gave good response, telling me the SD card is working.

    I can ping the Duet at the reported IP, and confirmed no duplicates by turning power off, and then not getting a ping back from the Duet.

    For now I am just using a terminal for access to the Duet, but would like to get the wep page working again.



  • @v3dprinting I am using Mozilla Firefox in windows 10, and did try your suggestion, restarted browser, but still no go. This problem seemed to happen regardless of which PC I try. I was able to use other PC's to access the Duet, and they stopped talking about the same time, leading me to believe the problem is on the Duet end. Could be a 3 way coincidence i guess, but my gut says no.



  • @dc42 Sorry, I meant M588 Forget WiFi host network which reported back success.



  • @elmoret You are right, my bad. It was the PanelDue that had China on the board. Comfort level rising. 🙂


  • administrators

    1. What error message does your browser give when you enter the IP address of the Duet in the address bar?
    2. Please confirm that after you check you can ping the Duet, if you power down the Duet you can no longer ping it.
    3. Is the blue LED on the WiFi module lit?


  • @dc42 Im getting unable to connect messages from the browser. I tried Chrome, Firefox, and IE. I can open other pages on these browsers. I did already confirm by powering off and then NOT pinging, then powering on and being able to ping again. The blue light is on solid, and when I run a M552 S1 I get confirmation of connection to the same access point as the PC is currently on, as well as the IP address of the web server on the Duet.



  • @dc42 I think for now I just need a workaround for when the interface doesnt work. I was using it to edit the machine configuration, which modified the Config.g file seamlessly. Now I think I have to make edits manually to that file on my PC, and saving to the file on the SD card. Kinda scary, and cumbersome, but ive already wasted a day on this, and I dont seem to be getting anywhere.


  • administrators

    Are you running compatible versions of the main firmware and DuetWiFiServer? All recent main firmware versions work with DuetWiFiServer 1.20. You can run M122 to check the firmware versions.



  • @dc42 It returned...

    === Diagnostics ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC5(RTOS) running on Duet WiFi 1.02 or later + DueX5<LF>Board ID: 08DGM-9T6BU-FG3SN-6JTDG-3S06S-KBYVF......



  • @dc42 So it started working on all browsers, and connects instantly again. The only thing I did was re-write a new config.g file to the SD card with minor machine modifications (namely motor direction) Another difference was that I changed the machine name in the new Config.g file. If it happens again, I will try changing only the machine name to see if it has an affect.


Log in to reply