Fan 1 output broken

  • Hello,

    I have broken my fan 1 output. I have tested the fan on another output it is working and also the config.g was ok cause it worked yesterday. I think it is cause I unplugged the fan without switching off the power. I measured the voltage on the output it is about 11.98V so I think the voltage should be ok but there is not enough current on this output. Can it be that the mosfet is broken?

    So, for now, I connected the fan to an always-on fan. Cause this is the fan for the hotend. The other fan outputs I need for the printcooling.

    So can I use fan 3-7 for thermostatic control? And where can I find the Pins for the fans 3-7???



  • Pins for the fans 3-7 are all on the big expansion header. Note that on this header, you only get the direct pin from the processor, which is not yet run through a mosfet. You can make an expansion board that simply exposes these outputs to headers if you are familiar with pcb making; otherwise the expansion boards by Duet exposes these.

    The board diagram is at (here you can see the expansion header and where those pins are located).
    The Expansion boards have their diagrams at

  • Thank you for your awnser. Is Therme a schematic available that I can repair my fan 1 maybe I can make a little pcb with an new mosfet LG change the broken one.
    Or maybe there is an schematic for the duex Board that I can use one of these fan pin.

  • Looking back at your initial post, I am not sure the mosfet is actually broken. If it were, you would not read any voltage on the fan output. These mosfets are N-type, which practically means that it is a switch between the load and Ground (when it is off, there is no ground reference for the load, so voltage is at Vin on both sides and it is off; in the case of it being disconnected, the ground pin will be floating, and as soon as you connect it with a multimeter in voltage detection, it should go to Vin and read 0V).

    About not having enough current, no. Unless the trace between the fan output and the mosfet is very damaged, this is not possible.

    Before trying a repair, explained below, perhaps re-test everything and confirm that the mosfet is in fact not working as it should.

    The Repair:
    If you look close to the fan pin that broke (if the stepper drivers are towards the bottom), you will see a very small transistor/mosfet (Fan 1 and 2 have this almost touching the connector; fan 0 have this just other side of the fan voltage header).

    This transistor have 3 pins, 2 on one side and a 3rd on the other side. This is what needs to be replaced. The details of part numbers are at - the easiest would be to simply replace the faulty component, rather than making a separate board.

  • administrators

    It does sound to me that the Fan0 Fan1 mosfet has failed. If you are not using the E1 heater output, then in recent 2.02RC firmware versions you can redirect Fan0 Fan1 to the E1 heater output (heater 2) instead.

    Do you have a standard brushless DC fan connected to Fan0, or something bigger such as an air pump?

  • Thank for your answers!

    My fan0 is connected to tool0 (printcooler 12V DC fan 5015), fan1 to the hotend of tool0 and tool1 (two 12V DC fans 30x30 e3dv6 hotend fans) and fan2 to tool1 (printcooler 12V DC fan 5015).

    I have tried fan1 with M106 P1 T45 H0:1 and also M106 P1 H-1. But the fan is not working on fan1, if I connet the same fan to fan0 it is working so the fan is ok.

    My config.g looks like this:

    M106 P0 S0 H-1
    M106 P1 S0 H-1
    M106 P2 S0 H-1

    and with thermostatically controlled fan1

    M106 P0 S0 H-1
    M106 P1 S0 T45 H0:1
    M106 P2 S0 H-1

    In both cases fan1 is not working.

    I hope my config.g file is correct.

    I will meassure out the fan1 pin again for both cases (switched on and switched off and will post the voltages for both cases.

  • So I measured the voltage again. I plugged a connector with 2 cables at the fan1 pins and connected this to a multimeter.

    If I measure between VFAN and FAN1- I see 7.6V when the fan is at 0% on the web control and 12V when the fan is at 100%.