AM8 config issues - cannot home any axis



  • Hello guys.

    I just finished building my AM8. It is no Anet A8 anymore. All I took over is the heatbed and the motors.
    Extruder is a bondtec and the Board a Duetwifi.

    I just ried starting it up after wiring it up according to the guide. It is a dual Z motor Prusa-like cartesian printer.
    I wirded the to z motors in series according to the Duet Wifi Connections pic.

    When firing up after going through RRF Config tool I have two major issues.

    1. I cannot home any axis. I can move X and Y axis with commands just fine but when I home them the Za xis goes a bit up and then a bit down - in a very uncoordinated way. Same when I try to home Z. Basically no matter wich axis I send a home command it does this!
      I expected the axis to run into the limit switch that I configured.

    The other issue is that the thermistor shows a fault. I use a E3D V6. I suppose the default values of RRF Config tool are wrong for this thermistor?

    Any help would be apreciated. Are there any base configs for similar printers I could learn from?

    Thanks in advance for any help.



  • Can you post your config.g and homing files so we can actually see what it's trying to do?

    Have you tried to move each axis independently to test if they work the way you expect? As in, are the motors turning the right way?

    It's also possible the acceleration, jerk, or speed values for the Z axis are too high causing it to act in unexpected ways.

    Did you select the E3D semitek thermistor when you setup the heater in the configurator?

    Have you gone through the documentation at all?

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter



  • The X and Y motors move th right way when I give a +10 input or -10.
    Z does nothing at all.
    About thermistor: Where would I selecte asemitek thermistor in the configurator - I have no such option.
    I read through that guide but I thought I get something sort of workable to start with when going through the configurator.



  • I am a fool. I did not see I can clock on the config values and get new options to choose - this should solve the termstor. I'll keep on working through the wiki and report back. 🙂
    Thanks a lot.





  • It would help to see your config.g as well. Do you have a z probe? Or just an endstop?



  • Just endstop. I found another thread with exactly the same issue tho. His Z also went up and down erratically.
    Apparently two z motors in series on a 12v PSU are too much. That guy fixed it by using another stepper for Z 2. I will try this in the evening.


  • administrators

    Have you tested your endstop switches? It sounds to me that you have configured or wired them incorrectly.
    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Test_endstop_switches

    Two Z motors in series may be OK on 12V, depending on the type of motor.



  • @dc42 homing doesn'
    t even get to the endstops. The z motors run uneven. First one than the other with a horrible grinding noise because x axis gets uneven as result. It is not a mechanical issue though.


  • administrators

    Please post your config.g file as @Phaedrux requested.



  • I just got my Duet Wifi setup as a CoreXY and its doing the EXACT same thing! I can open Pronterface or Simplify 3D and move the axes in any direction, but when I home any of them it moves Z up and down and X or Y moves only a few millimeters...what is the issue?



  • And if I try to home Z it just goes up and down once or twice...



  • Ok. Z motors run ok now that they are not in series anymore.
    Homign does not work at all though. Homing X and Y moves Z axis still.
    Homing Z axis runs the axis down into the switch that does not work and it keeps on running intothe switch - the switch actually died broke this.0_1545766351395_config.g



  • thats why dc posted the link. use the m119 command to test each endstop manually first.



  • @veti
    Yeah makes sense. But can you see faults in the config.g?
    I am far from anything workable. The hotend throws out a fault. The fans have no power (allways on fans as well - 12V fans, 12V PSU).
    No endstops. A moving Z axis when tryign to home X or Y. I don't even know where to start really.

    I never had trouble with marlin but this leaves me puzzled.



  • So, unless you have also changed the lead screw then your steps/mm for Z are 10x too high. They should be set to 400.

    Also your steps/mm for X and Y are too low if you did not replace the pulleys by 20T versions. Original Anet A8 has 16T resulting in 100 steps/mm.

    Then there is no endstop for Z configured at all. And the one for Y is set to active high where default Anet wiring of the endstop is active low.

    The original Anet motors run on Z in series - that's how I had mine running for months also with the original 12V PSU.



  • M574 Y1 S1 ; Set active high endstops
    M574 X1 S3 ; Set endstops controlled by motor load detection

    Normally the a8 switches are NO if i remember correctly. You configured NC for Y.
    X is stall detection and not via switch. Is that correct?

    Check the wiring on the fans. if you swapped them the wrong way the fuse might be blown.
    See https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans
    . If you connect the fan the wrong way round, you may damage the fan, the Duet, or both.



  • @wilriker

    Thanks a lo. I will look into it. The Endstops were the wrong way round. Fault number one solved as well.
    Sorry for my stupid questions. I am new to this. I thought the basic config of RFF config tool will get me somewhere. I found no basic values to start with for the anet.

    X stall detection is because one switch died. I just fixed it though - back to endstop.



  • @thoemse The easiest way to get the correct values is the use Marlin's appropriate Configuration.h and Configuration_adv.h. These have all the working values in there.

    But this reminds me again that I wanted to create a template for Anet A8 in RRF Configurator. But that will probably only happen at the beginning of next year.



  • @wilriker
    Changed steps. Thank you.

    Edit: Fantastic. Making progress. All endstops working. Axis are homing.
    Now On to the hotend and the no power on fans issue. I shall read up on it first though. I went at this a bit to unprepared.

    Thanky ou very much btw. I am starting to get the hang of it.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.