Won't HOME after capacitive sensor installed



  • I'm sure I'm missing something very small and I know I will be kicking myself, but....

    I just installed a capacitive sensor on my Ender 3 by using 24v on "always on fans" and the signal in the "Z PROBE IN". I am running a Duet 2 wifi rev 1.04 with the latest 2.02RC7 but nothing I do can get the duet 2 wifi board to sense the new Z probe. I am sorry for the stupid mistake if I missed the obvious.

    Thanks in advance
    Eric



  • I was able to get the sensor working. It's not perfected just yet. Now I have to figure out offsets so Duet doesn't send the sensor off the build plate looking for -0.





  • Thank you for the reply. I do understand your links, kind of... I am still wanting to request home as normal as I want to use the full size of the bed but what I don't want is the nozzle to dip lower and beoynd the bed when trying to home Z because the sensor is hanging off the bed when all axes are homed.

    How can I define home as being able to use the full bed but offset X,Y at a particular time to home Z for a proper Z height?

    I sorry I question might have been misleading


  • administrators

    @excelon said in Won't HOME after capacitive sensor installed:

    How can I define home as being able to use the full bed but offset X,Y at a particular time to home Z for a proper Z height?

    Read the section about homing Z in the second link in @Phaedrux's post.



  • ...I have been doing my homework. I think I just about got it but stuck on this one part and only asking because I don't want to ruin my printer. When ever I homeall the the X axis doesn't register causing the stepper motor to keep going and the belt to skip.

    Initial problem was Z didn't home after removing physical endstop switch and installing a capacitive sensor. If I used the software and homed X and Y by themselves they would home as normal but when I tried to homeall or home Z alone the Z axis would only raise the parameter that's set in " Z Probe " in config.g (please correct me if I'm wrong ) which is H5 ; dive height 5mm. So, given that the Z axis was rising the specified 5mm I inverted the M558 command in config.g ( this took some time for me to figure out ). From there I edited the homez.g and homeall.g to allow the Z axis to have an offset so the probe can read the bed since the stock homing position would be full -235 X & Y making thee nozzle and probe also adding a G30 command once the nozzle arrived at the coordinance.

    Current issue -
    Homeall doesn't function but homing each axes by its self seems to be ok with some minor fine tuning, of course. I will post my config.g, homez.g and homeall.g files to make it easier.

    Thanking you in advance

    Merry Christmas eve!

    Eric





  • Your homeall.g file is still using a G1 S1 Z move to seek the Z end stop, but since you're now using a z probe, you'll need to change that to G30 which you've already done in homez.

    In homez, you have the G30 to probe, but then you also have a G92 Z0 after that which you should remove, since it would be over writing the Z height you just established by probing.

    Make sense?



  • Did you mean the G1 S2 Z-255 F1800 in homeall.g?

    Yes, makes perfect sense but still X is homing to the left and skipping the belt, even after changed. Am I missing something else? 1_1545680288012_homez.g 0_1545680288011_homeall.g

    Thanks you!



  • @excelon said in Won't HOME after capacitive sensor installed:

    Did you mean the G1 S2 Z-255 F1800 in homeall.g?

    Yes. Your homez looks correct now. Here's a cleaned up homeall for you:

    G91  ; relative positioning
    G1 Z5 F6000 S2  ; lift Z relative to current position
    G1 S1 X-235 Y-235 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000   ; go back a few mm
    G1 S2 X-235 Y-235 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90   ; absolute positioning
    G1 S2 X65 Y10 F2000   ; put head over the centre of the bed, or wherever you want to probe
    G30  ; lower head, stop when probe triggered and set Z to trigger height
    

    still X is homing to the left and skipping the belt

    That sounds like a separate issue. What direction should it move in X to get to the switch?

    First we need to verify that your endstop switches are working as expected. See the procedure here: https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Testing_endstop_switches_using_the_web_interface

    Then we need to verify that your endstop configuration matches the location of the end stops. If you are standing in front of your printer looking at it, where are the end stops located? Left, right, back, front? The 0,0 origin of the printer should be the front left. The printer can home in either direction, but +Y should be towards the back and +X should be to the right. If the endstop is on the 0 side, it's a low end endstop. If it's on the + side, it's a high end endstop. This will dictate the direction you need to move in your homing files so that it moves towards the endstop.

    See here for more detail: https://duet3d.dozuki.com/Wiki/Centering_the_bed_or_setting_the_bed_origin



  • @phaedrux said in Won't HOME after capacitive sensor installed:

    still X is homing to the left and skipping the belt

    That sounds like a separate issue. What direction should it move in X to get to the switch?
    First we need to verify that your endstop switches are working as expected. See the procedure here: https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Testing_endstop_switches_using_the_web_interface
    Then we need to verify that your endstop configuration matches the location of the end stops. If you are standing in front of your printer looking at it, where are the end stops located? Left, right, back, front? The 0,0 origin of the printer should be the front left. The printer can home in either direction, but +Y should be towards the back and +X should be to the right. See here for more detail: https://duet3d.dozuki.com/Wiki/Centering_the_bed_or_setting_the_bed_origin

    Thank you for the cleaned up homeall.g I replaced it and, yes, X is still grinding on home/endstop. The physical endstop switch is to the left if you are standing in front of the printer and looking forward, just like Y is away from you ( to the rear ). Funny thing is that homex.g is working properly.



  • edit: One more thing to note. One you home each axes by them selves they home just fine. So, you can home X and Y and the nozzle will endup in the far left and the bed to the rear, but when I home Z the X and Y axis move their specified offset which is fine, but if I home Z again the X and Y move the same amount of offset until the belts are skipping on the other side. It's almost as if Duet doesn't know the orientation



  • @excelon Can you post your homex and homey files as well?

    This may also help:
    https://duet3d.dozuki.com/Wiki/Test_homing_behaviour



  • @phaedrux

    Sure, here you go. I'm sure I am missing something small. In the mean while I will take a look at the link you sent me.

    1_1545682571033_homey.g 0_1545682571033_homex.g



  • I figured it out. I had to change from G1 S2 to G1 S1 in homeall.g. Now I have some fine tuning to do.



  • Glad you got it sorted out.



  • @phaedrux thank you and dc42 for all your help. I love the challenge. Once the homeall actually worked I have to admit it felt pretty satisfying.

    I had to run out of the house for a movie date but I tried to print something quickly just to see if all is working but..... homeall was fine. Start print position was even good but as soon as the X axis started its Jog to the right the nozzle started to lower and dug into the bed pretty aggressively. Can you give me some insight and/or links to research this issue please?

    Happy Holidays and Merry Christmas
    Thanks again for all your help.



  • Can you post the first 50 or so lines of the gcode file you tried to print?

    Have you calibrated your z probe trigger height?



  • @phaedrux said in Won't HOME after capacitive sensor installed:

    calibrated your z probe

    I'm not sure if I set z probe height or not, so I would probably say no.
    edit: Are you talking about G31 code in config.g?
    Can you send me another link on this please?

    50 lines of gcode


    ; G-Code generated by Simplify3D(R) Version 4.1.1
    ; Dec 24, 2018 at 10:50:20 AM
    ; Settings Summary
    ; processName,Process1
    ; applyToModels,raspberri_pi_camera_case_back_v0.4,raspberri_pi_camera_case_front_m3_bot_v0.4.2,raspberri_pi_camera_case_front_m3_top_v0.4.2,raspberri_pi_camera_case_front_v0.1r,raspberri_pi_camera_case_front_v0.4.2,raspberri_pi_camera_case_back_v0.1r
    ; profileName,Creality Ender 3
    ; profileVersion,2018-07-11 08:00:00
    ; baseProfile,
    ; printMaterial,PLA
    ; printQuality,Medium
    ; printExtruders,
    ; extruderName,Primary Extruder
    ; extruderToolheadNumber,0
    ; extruderDiameter,0.4
    ; extruderAutoWidth,0
    ; extruderWidth,0.4
    ; extrusionMultiplier,0.9
    ; extruderUseRetract,1
    ; extruderRetractionDistance,4
    ; extruderExtraRestartDistance,0
    ; extruderRetractionZLift,0
    ; extruderRetractionSpeed,2400
    ; extruderUseCoasting,0
    ; extruderCoastingDistance,0.2
    ; extruderUseWipe,0
    ; extruderWipeDistance,5
    ; primaryExtruder,0
    ; layerHeight,0.2
    ; topSolidLayers,3
    ; bottomSolidLayers,3
    ; perimeterOutlines,3
    ; printPerimetersInsideOut,1
    ; startPointOption,2
    ; startPointOriginX,0
    ; startPointOriginY,0
    ; sequentialIslands,0
    ; spiralVaseMode,0
    ; firstLayerHeightPercentage,100
    ; firstLayerWidthPercentage,150
    ; firstLayerUnderspeed,0.5
    ; useRaft,0
    ; raftExtruder,0
    ; raftTopLayers,3
    ; raftBaseLayers,2
    ; raftOffset,3
    ; raftSeparationDistance,0.14
    ; raftTopInfill,100
    ; aboveRaftSpeedMultiplier,0.3
    ; useSkirt,1
    ; skirtExtruder,0



  • https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe and then the trigger height section.

    You'll need to do this to get the z probe working accurately. That would explain the first layer digging into the bed since it doesn't actually know where z0 is until you tell it how far the nozzle is from the bed when the probe triggers.


Log in to reply