Got my paneldue... It says "connecting" and controls nothing...



  • I just got my brand new paneldue 7i from Filastruder today. I plugged it into my brand new Duet 2 wifi, and it lights up, gives me all of the menus, beeps, but controls nothing... it just says "connecting." I tested the cable with an RC cable tester, and it's got 100% continuity on all 4 leads. I followed your diagram, and the din, gnd, +5v, etc are connected the right way. Is there anywhwere in the firmware where we have to tell it that is using the paneldue or something??? I have read every page mentioning a paneldue, but instructions are sparse. This leads me to believe that it's as simple as hooking it to the cable Filastruder sent me, and it should connect. It does not however. I tried all baud rates, and reset in between... No Joy! Any ideas??? Thanks!



  • @steve-lynch It should just work.

    If you go to the setup page on the PanelDue, what firmware version does it show at the top?



  • The baudrate should be 57600. Try again. I have the same issue earlier.


  • administrators

    Check that the baud rates on both the PanelDue Setup page and in the M575 P1 command in config.g on the Duet are both set to 57600.



  • @phaedrux 1.21.2 (12b1) is what it says.



  • @steve-lynch If you've checked the commands as David says above and it's still not working, you can try flashing the latest firmware. Instructions here: https://miscsolutions.wordpress.com/paneldue/



  • Hello, Thanks for the reply..

    There was not an M575P1 command anywhere in my Config.g Perhaps the Paneldue instruction page should include this?

    The Paneldue instructions make no mention of this anywhere.

    So I searched the M Codes Until I found an explanation.. I set my board using this command: M575 P1 B57600 S1

    I reboot the Paneldue and the Duet.. Still nothing. Just "Connecting"

    Here's my complete Config.G do you see any problems? I've done everything every youtube tutorial, or forum post has suggested.. Thanks so much!

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Dec 20 2018 18:06:49 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M575 P1 B57600 S1 ;Set baud rate Duet Board.
    M575 P0 B57600 S1 ;Set baud rate USB
    ; Network
    M550 P"My Printer" ; Set machine name
    M552 S1 ; Enable network

    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    M564 H0
    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M584 X0 Y1:4 Z2 E3 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415.00 ; Set steps per mm
    M566 X480 Y480 Z12.00 E1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z250.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X290 Y290 Z360 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z0 S1 ; Set active high endstops

    ; ** BLTouch
    ;
    M307 H3 A-1 C-1 D-1 ; disable heater 3, BLTouch - servo pulse on heater 3 pin (expansion 😎
    M558 P5 X0 Y0 Z1 H5 F200 T5000 ; Type 5 for BLTouch (Normally closed switch on Z-probe inputs)
    G31 X33.00 Y0.39 Z2.74 P5 ; Z=trigger height, P=trigger value, not needed for contact probe, X/Y distance from nozzle
    ;

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 I0 S0 F500 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 F500 I0 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured
    G29 S1 ; load stored bed height map



  • @steve-lynch said in Got my paneldue... It says "connecting" and controls nothing...:

    There was not an M575P1 command anywhere in my Config.g Perhaps the Paneldue instruction page should include this?

    I think it's not mentioned because it's already the default.

    Did you try updating the PanelDue firmware?

    What firmware are you running on the Duet?

    Double check the cable continuity and that the pins are going to the right places? It's oftentimes a cabling issue of some sort.

    Otherwise I'm not sure what else to do or check.



  • This post is deleted!


  • This post is deleted!


  • Firmware on board is updated to 2.02 from 8 days ago.. Paneldue is updated to the latest firmware 1.22.1(28b1) The screen showed the firmware update progress, and said when it was rebooting and all, but it still says "connecting" after re-boot, and no control..

    Continuity confirmed... It's only 4 conductors.. not hard to keep straight.

    Hmmmm.



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3



  • Tried it with the ribbon cable interface as well.. it powers it, it shows firmware upgrade status, but it does not "connect".

    Everyone said "dude, they're more trouble than they're worth"... But I see a lot of folks using them successfully..

    I'm at a loss here.



  • @Steve-Lynch does the PanelDue tell you anything on the console tab?
    I used to see a few error messages when I set the wrong baud rate...

    Can you inspect the PCB, and verify that the connection headers are good? Maybe there is a bad solder joint or crack in the PCB? (high-def pictures maybe?)



  • 0_1546375287322_2019-01-01 15.38.09.jpg

    overall
    view



  • 0_1546375487216_2019-01-01 15.38.20.jpg

    connector closeup top



  • I don't see obvious problems on the PCB - but maybe @dc42 spots something...

    If you use the 4-pin connector, try switching the wires of the two data pins (DIN, DOUT).



  • I do PCB Repair, and under my scope, there is no break, or bad solder joint... Aside from that, both interfaces do not work.. (ribbon cable, or 4 pin) I have several of each, so it's not the cable, and I have continuity from the solder joint on the duet to the solder joint on the paneldue..



  • @Steve-Lynch whats the story with the lifted pad / pin in the top left corner, close to RA2/RA7?

    Since you seem to be familiar with the topic: do you have a scope? Can you probe the UART pins of the SAM4S directly? just to make sure the traces are all fine.



  • That connector, the (X4 connector) was broken off in shipping. While I did email filastruder, I've been told by others that the connector isn't used, so It should not be an issue. The traces leading to the pads are fine, but the pads themselves were ripped off it seems.

    I have a Microscope, not oscilloscope.. lol. I replace blown capacitors and power supplies and repair traces and stuff, I'm wasn't trying to be "mr. know it all", I just was establishing that I had checked beyond the obvious...

    And I tried swapping din dout, that didn't do anything as expected (rx to rx - Tx to Tx)


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.