Z Probe Sensor profile reading as 0



  • Hello, I have been trying to program my BL Touch for over a week now and when I run M558 it shows profile as 0. In the config though it is showing the correct profile, I have also noticed on the web interface that the sensor box under machine status is Vin 24.4 V and Z-Probe 0 and will not change from that.


  • administrators

    @jester, your config.g file may contain a typo, or there may be another M558 command somewhere. Please post your config.g file, also config-override.g if you have one.



  • Config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Jan 07 2019 13:59:59 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Jester3D" ; Set machine name
    M551 P"JOKER_ofshadows13!E3: ; Set password
    M552 S1 ; Enable network
    ;
    ** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E93.00 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z24.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E300.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X400.00 Y400.00 Z400.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Axis Limits
    M208 X-5.5 Y0 Z0 S1 ; Set axis minima
    M208 X235 Y235 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-31 Y0 Z0.6 ; Set Z probe trigger value, offset and trigger height
    M557 X20:215 Y20:215 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H0 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    Config-override.g

    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0



  • @jester said in Z Probe Sensor profile reading as 0:

    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0

    Remove that line in config-override.g



  • I removed that line and still getting the same issue. It is still coming up with the manual bed probing also



  • @jester
    This is what I have in my config.g file

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X31 Y-8 Z2.48 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20 ; Define mesh grid

    Try adding the M574 command and change the trigger value (P) in the G31 command to 25.

    Besides that, does the pin deploys, retract, selftest and resets when sending the following commands?

    Pin Down: M280 P3 S10 I1
    Pin Up: M280 P3 S90 I1
    Self-Test: M280 P3 S120 I1
    Reset BLTouch + Pin Up: M280 P3 S160 I1



  • @r3play said in Z Probe Sensor profile reading as 0:

    M574 Z1 S2 ; Set endstops controlled by probe

    I added the M574 command and changed the value to 25 and still no luck, it responds to the testing commands though.



  • @jester Then I would have no clue what else could be wrong.
    Going to leave this to the experts here. 🙂



  • Thanks for the help anyways 🙂



  • What do you have in your deployprobe and retractprobe macro files?

    Does the probe respond to M401 and M402?

    The zProbe box in the DWC is not an accurate way to test the BLTouch because of the way that it triggers and instantly resets. The display may briefly flash to 1000 and then immediately go back to 0.

    If the probe responds to M401 and M402, try doing a dynamic test by positioning the head far above the bed and issuing a G30 command to start a probe move. Trigger the probe pin by hand. If the movement stops, you're good to go. If it doesn't stop, kill the power to stop movement, and double check your wiring, because something isn't connected right.


  • administrators

    Let me confirm my understanding of the original problem:

    Hello, I have been trying to program my BL Touch for over a week now and when I run M558 it shows profile as 0

    I took this to mean that if you send M558 without parameters, it says the probe type is 0. Is that right?

    Which firmware version are you using? Probe type 9 was added several months ago, but if your firmware is very old then it won't support probe type 9.



  • @phaedrux said in Z Probe Sensor profile reading as 0:

    What do you have in your deployprobe and retractprobe macro files?

    Does the probe respond to M401 and M402?

    The zProbe box in the DWC is not an accurate way to test the BLTouch because of the way that it triggers and instantly resets. The display may briefly flash to 1000 and then immediately go back to 0.

    If the probe responds to M401 and M402, try doing a dynamic test by positioning the head far above the bed and issuing a G30 command to start a probe move. Trigger the probe pin by hand. If the movement stops, you're good to go. If it doesn't stop, kill the power to stop movement, and double check your wiring, because something isn't connected right.

    it does respond to M401 and M402 but when I do a G30 it will just bring up manual bed compensation pop up



  • @dc42 said in Z Probe Sensor profile reading as 0:

    Let me confirm my understanding of the original problem:

    Hello, I have been trying to program my BL Touch for over a week now and when I run M558 it shows profile as 0

    I took this to mean that if you send M558 without parameters, it says the probe type is 0. Is that right?

    Which firmware version are you using? Probe type 9 was added several months ago, but if your firmware is very old then it won't support probe type 9.

    I am currently on 1.21



  • @jester 1.21 RC2 and above should support the P9 probe type. 1.21 is quite old at this point though. I'd suggest looking into updating to 2.02.

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    Can you post your homing files as well? Do you happen to have an M558 command in them?

    What happens if you send your complete M558 command in the gcode console and then send M558 again with no parameters. Does it read back type 0, or type 9?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.