Duet Wifi connection issues (I will not update firmware)



  • So as my title states I am having difficulty connecting my wifi to my Duet board.

    I recently moved into a new home and decided to reset my wifi ssid and password as it wasn't the most appropriate name for this type of neighborhood.

    That being said I don't mean to be stubborn but I will not upgrade firmware as I am extremely close to changing over my electronics to a new build and then I will update firmwares but I have just a few more parts to print before I can begin the swap.

    I did a firmware update from 1.18.2 to 1.19.x forever ago and had nothing but issues and ultimately downgraded to keep my printer operational. So upgrading firmware is not an option, as stated in the wifi setup guides.

    Anywho, I do the standard m587 command but keep getting the "unsupported command" error in pronterface. my ssid does have an apostrophe, and I did add double apostrophes to be safe, neither way worked.

    I have manually added it to my config.g file before the m552 s1 command, as well as the m588 command to remove my old ssid and password, which is also placed before the m587 and m552.

    None of that worked, so I removed the m588 command and tried it all again without any luck.

    I also tried to put the duet into access point mode and connect via wifi and the configured ip address of 192.168.1.10 which didn't work. I also tried the actual ip address of 0.0.0.0 (both ip addresses were provided inside the pronterface terminal).

    Can anyone help me? I have literally 20hrs more worth of printing to begin the swap but cannot do it without these parts.

    Also sorry for sounding irritated, but I have been troubleshooting this for over 2 hours and I am very upset to see there is NO support for previous firmware versions in the guides. Some users do like to keep firmware at a point where it works. I go by the saying "Don't fix whats not broken", and the guides do nothing but promote upgrading the firmware, otherwise you're SOL.

    Thank you all.

    Regards,
    Dustin



  • Perhaps try using a very simple SSID for the time being. No capitals, no unique characters. Same for the password.

    You can clear all of the saved SSIDs to get a clean slate by editing your config.g file on your computer to have M588 "*" (That is, using an asterix for the network name) and no other network commands. Boot up once and let it sit for a moment. And then power down and edit the config.g once again to add your new SSID and password. Boot up once more to let it take effect. Check your router to see what IP address the Duet is using, or go to duet.local in your browser and then edit the config.g once more to remove your SSID and password adding command.

    I understand the frustration around firmware updates. Going from 1.18 to 1.19 was a big change since it required editing some homing files. However, those changes paved the way for making the process much easier. The firmware update process starting with 2.02 involves just uploading a single zip file. Everything gets updated automatically.


  • administrators

    The M587 command was introduced along with the new split between the WiFi and main firmware in the 1.19 firmware release. I'm sorry, but the only way we can support you is if you upgrade to more recent firmware. The current DuetWiFiServer firmware (version 1.21) may be more recent than the version(s) you tried, and there is a 1.22 beta release which I will turn into a full release soon.



  • @phaedrux Thank you, I will try the m588 command first then remove and do the ssid and password.

    Do you happen to know the command for 1.18.2 for setting the ssid and password?


  • administrators

    Prior to 1.19 there was no command for setting the SSID and password. You had to take the Duet WiFi out of range of the network that it connects to (or turn that network off if it is under your control), then the WiFi module started up in access point mode and you connected to it from a smartphone or tablet to set the SSID and password.

    BTW I've just released DuetWiFiServer 1.22 for use with more recent main firmware versions.



  • This post is deleted!


  • @dc42

    Oh okay now I remember that. I tried connecting with my smart phone but no luck there either. It would connect but not to the given ip address from pronterface.

    Now thinking about it, is it the standard 192.168.1.1? I was trying the 192.168.1.10 that was given in pronterface.


  • administrators

    Yes it's 192.168.1.1 when it's in access point mode.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.