Bl Touch not working



  • Hello,

    I am having hard time making BLTouch to work.

    I have connected it to Probe+PWM5.
    When connected it makes selft test and LED is ON (Pin UP)

    My deploy/retract looks right
    M280 P7 S90
    M280 P7 S10

    But with simple macros like M280 P7 S10 ; Send PWM channel 7 the s10 (angle) command its not working....

    config.g looks like
    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2 ; Define Z to use Probe. Home to Min
    M558 P9 H5 F500 T4000 X0 Y0 Z2 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves
    G31 P600 X-21 Y25 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X50:550 Y50:550 S20 ; Define mesh grid

    M307 H7 says it is dissabled...

    Where to look for a problem?



  • Search for a thread I started about a BLTouch not deploying. There is a lot of good information in there that may help you.


  • administrators

    Which firmware version are you using? Probe type P9 in the M558 command isn't support in old firmware versions.



  • I have tried also with P5, nothing changes...


  • administrators

    Does sending M401 cause the bltouch to deploy? Does sending M402 cause it to retract? If those don't work, yet M280 commands do work, then there is something wrong with your deployprobe.g and retractprobe.g files.



  • M280 commands dont work.
    I will test 401/402

    it only self test when I plug it on. Then Probe retracts/deploys few times.
    But I am not able to make deploy/retract with software...



  • You must be using 1.21 or above to use the P9 probe type.

    Can you post a photo of how you have it connected? Are you using Pin 5 or Pin 7?

    Check your wiring for continuity. Bad crimps or broken wires are very common source of problems.

    You must unbind the heater pin you are using
    M307 H7 A-1 C-1 D-1 ; Unbind heater 7 pins for probe use.

    You'll also need to remove any references to that heater pin from config-override.g

    Your deploy and retract servo commands may need to be inverted by adding I1

    You can remove X0 Y0 Z2 from your M558 command as they are no longer used.

    There's also a troubleshooting doc here: https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting



  • @dc42 @phaedrux thanks for support

    I have deleted relations from config-override.g
    I have double checked wires and even connected not re-soldered wires...
    Heater 7 is unbinded
    SW version 2.02RC6(RTOS)
    I have tried both with and without I1
    I have removed X0 Y0 Z2
    M401/402 commands are green and working but nothing happens

    Attached picture of wiring.
    0_1547032576394_906878b4-ca7b-4208-8023-f555c9dcb525-image.png



  • Ive got it working on P3.
    I used osciloscope to see what is happening on PWM channels and all channels are busy with something even though they are dissabled. Strange



  • Few head crashes, few more hours and height map is done 🙂
    I start to like coding :))
    0_1547054971566_20a143e6-42e7-456e-aaae-291c932bf52a-image.png



  • Why do I get homing failed?

    0_1547058196216_95a5a68e-ec9d-4ec1-98c4-da6ee0536f28-image.png



  • At what point did you get that error message?

    Have you seen this? https://duet3d.dozuki.com/Wiki/Test_homing_behaviour
    Or this? https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe


  • administrators

    @alishkus said in Bl Touch not working:

    Ive got it working on P3.
    I used osciloscope to see what is happening on PWM channels and all channels are busy with something even though they are dissabled. Strange

    Did you check that there were no M307 commands in config-override.g that re-enabled heaters that you thought you had disabled?



  • @dc42 Yes. I left only one (main head heater) working.
    I have double checked config. Really strange and I dont get it. Maybe will try to work it out later.

    @Phaedrux I get message after G32/HomeZ is finished.... It sends me corrections ant tells that homing failed.
    I have seen these troubleshootings. I really love googling before writing in forum.

    But I also love this forum 🙂 So much good info and people


  • administrators

    The "Homing failed" message indicates that the firmware received a G28 command, but after running the appropriate homing files, one or more axes were still not flagged as homed. Duet Web Control will indicate which one(s). As you send G28 Z, it must be the Z axis that failed.

    Please post your homez.g file. What happens when you press the Home Z button, or send G28 Z ?



  • @dc42
    My homeZ.g looks like
    G91 ; Relative Positioning
    G32 ; call bed.g
    G90 ; Absolute Positioning
    G1 Z2 F4000
    G1 XY0 F4000

    Bed.g looks like

    ; Clear any bed transform
    M561 ; clear any bed transform
    G29 S2; Clear bed height map
    ; Probe 2-point
    M401 ; Deploy probe - deployprobe.g
    G30 P0 X50 Y300 Z-9999 ; Left motor
    G30 P1 X550 Y300 Z-9999 S2 ; Right motor
    M402 ; Retract Probe - retractprobe.g



  • I might have found problem/solution.

    The thing is that I am using 2 independet motors for Z axis with two independed z-endstops (I split axis when homing z, so I am sure both axis are at home position)
    In this case I was trying to home z axis together with bed.g and it seems somehow software does not accept it.

    I went back to endstops and only after Z was homed I used G32. Works OK.

    Seems I am missing something in my code to get rid of these endstops and only use touch probe.



  • @dc42 Ok. 16hours of work per day does not lead anywhere.... stupid me.
    Now homes perfectly.

    G91 ; Relative Positioning
    G30 ;
    G32 ;
    G90 ; Absolute Positioning
    G1 Z2 F4000
    G1 XY0 F4000


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.