Z height when homed is always 206.18



  • No matter what i do, i can't figure out how to fix this issue. I have built a Kossel Mini and i know my homed height it actually 259mm. I bring the head down to within a piece of paper of the bed and set that as Z0. then when i hit home it doesn't go all the way up only part of the way. If i then hit home a second time it completely ruins my calibration. Please help! i have the homed height in my config.g file set to 259 currently


  • administrators

    Can you post your config.g and homedelta.g



  • ; Configuration file for Duet 0.8.5 (firmware version 1.16)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Feb 03 2017 10:52:12 GMT-0800 (PST)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R105.6 L215 B85 H259 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H10 F120 T2400 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X-18 Y-6 Z1 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M92 X80 Y80 Z80 E663 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X700 Y700 Z700 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S285 ; Set maximum heater temperature to 285C
    M305 P0 T100000 B3950 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4388 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PMiniKossel ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P192.168.1.14 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.1.254 ; Set gateway

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings
    M208 S1 Z-20 ; Set minimum Z

    ; Miscellaneous
    T0 ; Select first tool



  • ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Feb 03 2017 10:52:12 GMT-0800 (PST)

    ; Use relative positioning
    G91

    ; Move all towers to the high end stopping at the endstops (first pass)
    ;*** Slow homing has been configured. Change F240 to F2400 below when your configuration is working
    G1 X210 Y210 Z210 F2400 S1

    ; Go down a few mm
    G1 X-5 Y-5 Z-5 F2400 S2

    ; Move all towers up once more (second pass)
    G1 X10 Y10 Z10 F2400 S1

    ; Move down a few mm so that the nozzle can be centred
    G1 Z-5 F2400

    ; Switch back to absolute positioning and go to the centre
    G90
    G1 X0 Y0 F2400



  • i just noticed it says Duet firmware 0.8.5 but I'm on duet wifi does that matter?
    Also im using the 1.17 firmware for the wifi


  • administrators

    You need to change the line in homedelta.g

    G1 X210 Y210 Z210 F2400 S1

    To a value larger than the 259 your Z height is.

    Try

    G1 X265 Y265 Z265 F2400 S1



  • Okay now it goes all the way up with the first time hitting Home, but same issue it says my Z height is 206.18.


  • administrators

    How are you probing the bed?



  • i have the escher3D IR sensor but i am not even to the point of auto calibration yet


  • administrators

    If you run M665 with no parameters, what does it report?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.