Struggling with IR sensor Z offset



  • Hi everyone.

    I wave been struggling with getting my Z offset ok. Im using an IR probe fore my Z probing with a duet wifi running 1.21 firmware.
    The problem is that i have already calibrate the IR sensor but every time I start to print I need to lower the Z axis 1,2mm using baby steps.
    I have checked the config.g file and change my Z parameter on de G31 command many times but still having the same result.
    What its strange is that in the web control when i move the z axis 5mm from the bed i can clearly measure that it is 8 mm instead. ( i have already check the z motors steps/mm)
    Please can anyone tell me what im doing wrong??

    Thanks
    Octavio



  • @octatesta it would help if you posted your config and homing files.



  • @Phaedrux

    these are my config and homing files:

    Configuration file for Duet WiFi (firmware version 1.21)
    ;

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"My Hypercube" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M584 X0 Y1 E3 Z2:4
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E837.20 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z480.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y260 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z3.00 ; Set Z probe trigger value, offset and trigger height
    M557 X15:260 Y15:260 S25 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 T45 H1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"titan aero" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ;Automatic bed leveling
    M671 X10:290 Y130:130 S0.5

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    home all
    ; homeall.g
    ; called to home all axes
    ;

    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-335 Y-265 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-335 ; home X axis
    G1 S1 Y-265 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-335 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y-265 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X150 Y130 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    and bed probing file :
    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;

    G28 ; home
    G30 P0 X10 Y130 Z-99999 ; probe near a leadscrew
    G30 P1 X290 Y130 Z-99999 S2; probe near a leadscrew
    G28 Z

    ;M561 ; clear any bed transform
    ;G29 ; probe the bed and enable compensation

    i did manage to start a print but i had to put 0.8 mm of baby stepping just to get the right z offset

    many thanks for your help



  • Are you resetting baby stepping after each print? Also I thought i remember sometime ago that when you measured your Z offset, it would conflict with your old offset as well so you had to send a G code to basically tell it there was no offset. I think this has been fixed but maybe @dc42 can chime in?



  • What material is your bed made of? I a similar experience with a PEI bed with very inconsistent results.



  • @octatesta said in Struggling with IR sensor Z offset:

    What its strange is that in the web control when i move the z axis 5mm from the bed i can clearly measure that it is 8 mm instead. ( i have already check the z motors steps/mm)

    Double check your math on the steps per mm I guess. How are you measuring 8mm? From the bed? Was the nozzle touching the bed to start?

    How are you measuring the G31 Z trigger height?

    What do you have in your slicer start code?

    Is 0.8mm of baby stepping needed to get . first layer consistent? If it is, you can just apply that amount to your G31 value.

    What firmware version are you using?

    Are you using mesh bed compensation? It looks like you have G29 commented out, but is it loaded anywhere else? You can check by running M122 for a diagnostic read out.

    The config file looks ok. I assume you have two z motors? Are they synced up or at least manually leveled to start with?


  • administrators

    What is in your homez.g file?



  • I'm going to have to open one of these threads too, I'm having similar issues and the recommended fixes haven't helped.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.