Best settings for stepper motors ?



  • this stepper for towers : Nema 17 Schrittmotor Bipolar 2A 59Ncm 48mm Körper 4-Leiter.

    Manufacturer Part Number 17HS19-2004S1
    Step Angle 1.8°
    Step Accuracy 5%
    Holding Torque 59Ncm(83.6oz.in)
    Rated Current/phase 2.0A
    Phase Resistance 1.4ohms
    Voltage 2.8V
    Inductance 3.0mH±20%(1KHz)
    Weight 400g

    This one for extruder : 5:1 Planetary Gearbox High Torque Nema 17 Stepper Motor 1.68A DIY CNC.
    Manufacturer Part Number 17HS19-1684S-PG5
    Motor Type Bipolar Stepper
    Step Angle(W/O Gearbox) 1.8°
    Holding Torque 2Nm
    Rated Current/phase 1.68A
    Phase Resistance 1.65ohms
    Recommended Voltage 12-24V
    Inductance 2.8mH±20%(1KHz)
    Gearbox Type Planetary
    Gear Ratio(Exact Gear Ratio) 5 + 2/11
    Efficiency 90%
    Backlash at No-load <=1°
    Max.Permissible Torque 2Nm(283oz-in)
    Moment Permissible Torque 4Nm(566oz-in)
    Shaft Maximum Axial Load 50N
    Shaft Maximum Radial Load 100N


  • administrators

    And what motor currents have you set in your M906 command in config.g? I suggest between 1300 and 1600mA for those tower motors if you are using the Duet WiFi, and about 1000mA for the extruder.

    EDIT: I see you have 1000mA for the axis motors, so you should increase that.



  • Looks like quite a bit of over extrusion also, could be catching an edge.



  • M350 X16 Y16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X80 Y80 Z80 ; Set axis steps/mm
    M906 X1000 Y1000 Z1000 E800 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute



  • Do you have an E setting for M92 in your config file?



  • Ok I see you do further down. Scrap that!



  • Have you checked your esteps?



  • You don't appear to have set a Microstepping for your Z Axis in the M350 line not sure if this would cause it or not TBH but worth a try?



  • M350 what do i put in this line ? i did make not any changes here .


  • administrators

    If you don't have a M350 command then it defaults to 16x microstepping with interpolation to 256x, which is what most people use.

    I think it's a combination of over-extrusion as Tim pointed out, causing the nozzle to snag on the print, and insufficient motor current.

    You have your extruder steps/mm set to 663, which is about right for the RepRap Mini Geared Extruder (which has a gear ratio of around 5:1) but too high for most other extruders. So I repeat idevelo's question: have you calibrated your extruder steps/mm?

    Also I suggest you increase the XYZ motor current to 1300mA (M906 command in config.g).



  • ok i give a trie to change motors to 1300 and extruder to 663



  • I am manegd to print the lizard.gcode my tower are on 1000mA extruder 800mA
    extruder steps/mm set to 500 . printhead E3D volcano 0,8mm
    only issue i have was the temp. setting in the lizard gcode was set too low , i had continues put it back To 210° els it would not stick to my buildtac heatbed .

    see video :
    https://youtu.be/hFBDHyYQpVE


Log in to reply