Unable to connect to duet via Wifi



  • Hi Guys,

    I have been using my duet for a while and it has been working well,

    Today am just unable to connect to it, it has been a few weeks since I ran the machine.

    When I run the windows diagnostic it gives the following error0_1548832976669_Duet_wifi.JPG image url)

    Any suggestions ?


  • administrators

    Which firmware versions is your Duet using?

    Here are some possible reasons:

    • IP address conflict. Check that you can ping 192.168.1.11 when the Duet is powered, but not when it isn't powered.
    • SD card problem (although recent firmware versions will return an error page to the browser in this case)
    • Low WiFi signal strength. Check it by sending M122 from USB and looking at the report.


  • Hi,

    Sorry for a very late reply , was held up with other work.

    There doesn't seem to be an IP conflit, I checked with the router.

    And the SD happens to be relatively new.

    I tried the M122 command on YAT

    === Diagnostics ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC6(RTOS) running on Duet WiFi 1.02 or later<LF>Board ID: 08DGM-9T6BU-FG3S8-6J1FA-3SJ6Q-9BLZG<LF>Used output buffers: 1 of 20 (1 max)<LF>=== RTOS ===<LF>Static ram: 25524<LF>Dynamic ram: 98444 of which 0 recycled<LF>Exception stack ram used: 256<LF>Never used ram: 6848<LF>Tasks: NETWORK(ready,1444) HEAT(blocked,1232) MAIN(running,3860) IDLE(ready,200)<LF>Owned mutexes:<LF>=== Platform ===<LF>Last reset 00:04:50 ago, cause: power up<LF>Last software reset at 2019-01-02 11:37, reason: User, spinning module GCodes, available RAM 6548 bytes (slot 0)<LF>Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d<LF>Error status: 0<LF>Free file entries: 10<LF>SD card 0 detected, interface speed: 20.0MBytes/sec<LF>SD card longest block write time: 0.0ms, max retries 0<LF>MCU temperature: min 36.3, current 41.4, max 41.5<LF>Supply voltage: min 0.4, current 1.7, max 1.8, under voltage events: 0, over voltage events: 0, <Warning: Maximal number of bytes per line exceeded! Check the end-of-line settings or increase the limit in the advanced terminal settings.>

    I am not able to make complete sense of it.

    Any help is much appreciated.


  • administrators

    If in YAT you go to Settings/Text Settings and change the line ending to <LF>, it will be easier to read the output.



  • @dc42

    Thank you !!

    After reading the diagnostics from M122 I understood that the IP address has changed from.

    192.168.1.11 to 192.168.1.16
    Is there any way to stop that from happening ?.

    I am also planning to run a 1 week print for a client, would it be better to run via WiFi or USB?.



  • You can reserve the IP address on your router with a DHCP reservation preferably.

    Or you can use this https://duet3d.dozuki.com/Wiki/Gcode#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks



  • @hussainsail2002 said in Unable to connect to duet via Wifi:

    would it be better to run via WiFi or USB?

    The gcode file is copied to the SD card on the Duet and is printed from there. Wifi is only used to view the web control page. Don't use USB.



  • @Phaedrux

    Thanks !!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.