Can't upgrade past firmware 1.20



  • Hi guys, I'm having trouble upgrading my duet wifi. It's been sitting around for a year-ish as I get the rest of the machine ready, so I'm just now getting around to it. I was able to upgrade from 1.19 to 1.20, but now whenever I upload a firmware, it takes it, asks if I want to install, then seems to do something, but when it all comes back it's still at 1.20. Any tips?

    Thanks,
    Del



  • I don't have a Duet Wifi but I remember reading something about upgrading 1.19/1.20 that was different.

    Here it is:

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Updating_WiFi_firmware_or_DuetWebControl_files



  • Download this zip file: Duet2Firmware-2.02a.zip https://github.com/dc42/RepRapFirmware/releases/download/2.02/Duet2Firmware-2.02a.zip

    Extract it to a folder. Then use the DWC system tab to upload iap4e.bin and iap4s.bin, then upload Duet2CombinedFirmware.bin. It should prompt you to update the firmware. If not, you may need to rename the file to DuetWiFiFirmware.bin and upload it again.

    If that works properly, you can then uploadNow that you have the main firmware up to date you should be able to use the normal full update method. Take the full 2.02 zip file that I told you to extract above, but this time just upload the whole zip file without extracting it. It should update everything you need to the latest. Same procedure going forward.



  • @Phaedrux I tried your procedure and it did the same thing: prompt for update, do something? then come back as 1.20. Is an older duet wifi incompatible, perhaps? I can't tell from here.



  • Can you copy and paste the version information from the settings tab as well as the result of an M122 diagnostic in the console.



  • Software Information
    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.20 (2017-12-23)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3

    6:41:56 PM
    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (14 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4S4-6JKDA-3SD6T-K3SHW
    Static ram used: 15448
    Dynamic ram used: 99320
    Recycled dynamic ram: 4016
    Stack ram used: 1392 current, 4376 maximum
    Never used ram: 7912
    Last reset 01:23:39 ago, cause: software
    Last software reset details not available
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 24.0, current 29.7, max 29.9
    Supply voltage: min 1.6, current 1.7, max 1.8, under voltage events: 0, over voltage events: 0
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 2019-02-05 18:41:55
    Cache data hit count 4294967295
    Slowest main loop (seconds): 0.022647; fastest: 0.000034
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.22
    WiFi MAC address ec:fa:bc:0b:fa:34
    WiFi Vcc 3.38, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 27232
    WiFi IP address 192.168.2.97
    WiFi signal strength -52dBm, reconnections 0, sleep mode modem
    HTTP sessions: 1 of 8
    Socket states: 0 2 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)



  • Try updating to 1.21 first. If that doesn't work, try 2.0.



  • No luck on 1.21 or 2.0 using your previous technique 😞



  • Try going through the fallback procedures described here: https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware



  • @planeguy said in Can't upgrade past firmware 1.20:

    Supply voltage: min 1.6, current 1.7, max 1.8, under voltage events: 0, over voltage events: 0

    I just noticed your supply voltage is really low. How are you powering the Duet?



  • I'm just plugged into the computer via USB right now. More importantly the fallback method 1 worked and got up to 2.0! 2.02 worked fine via the "usual" method after that. Thanks so much @Phaedrux !



  • Glad it's working. Be sure to check out the version release notes. A lot of things have been fixed and new features added since 1.18. Be sure to test your homing and movement carefully.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.