EZABL z-probe wiring and configuration



  • Hi, does anyone installed the EZABL Z-probe with success? I think it is a capacitive sensor, sold by TH3D. I've been using it with my CR-10 S4 but I can't configure it right with the Duet WiFi board, I don't know what type of probe I have to select in the configurator tool nor if I need to connect it to the Z probe heater or to the E0 endstop. If anyone can help me I would really appreciate it, I saw some threads about this but none of them have a solution. I have the direct wire version of the sensor and here I leave some information distributed only to customers by the manufacturer:
    Wiring the sensor Connect power to the EZABL™ Module ○ If you are using the direct wire version then you will need to connect the module to the 12V OR 24V power that is on your printer. The top pin is positive (+) and bottom pin is negative (-). We recommend connecting direct to the power supply. Contact support with pictures if you are unsure if you wired it correctly. Click here for PSU wiring info. POLARITY MATTERS. BOARD WILL SHORT IF WIRED BACKWARDS ON V1 and V2 BOARDS. V3 BOARDS HAVE REVERSE VOLTAGE PROTECTION STANDARD. WIRING TO AC WILL KILL ALL KITS ○ If you are using the EZ-Connect version then simply plug in the power adapter and the other end into the DC jack on the EZABL™ module Connect your Z endstop to the EZABL™ Module ○ If you are using the direct wire version then cut the leads going to your current Z endstop switch and connect them to the EZABL™ port labeled ZMIN ○ If you have the EZ-Connect version then unplug the 2/3 pin connector from your Z endstop and plug it into the EZABL™ port labeled ZMIN – DO NOT USE JUMPER WIRES FOR THIS AS THEY DO NOT MAKE PROPER CONNECTION AND CAN DAMAGE OUR BOARD. If you printer has 3 wires going to the Z endstop connection, please contact our support BEFORE connecting. You can contact us at Support@TH3DStudio.com. For the Geeetech A10 with a 3 wire endstop see page 30 for wiring the Z endstop. Test the sensor for detection Power on your printer and verify that the sensor is working by touching the sensor with your finger. The LED light on the Sensor AND the module should light up. If they do not light up adjust the screw clockwise on the sensor (top on EZABL™, white on the side of the EZABL™ Mini) until it lights up when you touch it. V1.8.1 – 12/18/2018 Need help? Email: Support@TH3DStudio.com TH3D EZABL™ Installation Guide - Copyright © 2018 TH3D Studio LLC – ALL RIGHTS RESERVED 8 Firmware Setup – CLOSE ALL SLICERS BEFORE FLASHING If you have the CR-10 (all sizes), CR-10S (all sizes), Tornado, TAZ5, Anet (A2, A6, A8, E10 or E12), Ender 2, Ender 3, Wanhao (i3, i3 Mini, D6), Geeetech A10 we have already done all the firmware work for you. The pre-configured firmware is on our website here: https://www.th3dstudio.com/knowledge-base/th3d-unified-firmware/ If you have a printer that needs a bootloader this must be flashed. See the Unified Firmware page for details on this. Select Arduino as ISP for the programmer. In the Unified Firmware uncomment the printer model you have and the probe mount you are using. Probe mount STL files are included in the Unified Firmware package for every model we support. Set the EZABL_PROBE_EDGE setting to 45-50mm for larger printer beds (300mm+ size beds) and 10-20mm for smaller printer beds. Check to make sure the probe is not probing over any binder clips and/or screw heads in the bed as this can affect the reading. If you have a custom machine we can assist with setting up the firmware as long as you have the current firmware for the machine and it is working 100% without the EZABL™ installed already. We will need the full source code used to do these changes.

    Thank you in advance.



  • If anyone needs me to measure some voltage please let me know and explain me how to do it because I am not so experienced with electronics. Here I leave an image of the board between the sensor and the Duet also.alt text



  • Well, I changed the two cables from the E0 endstop to the Z probe header (Z PROBE IN and GND) and now the static test works, when I place my finger below the sensor it goes from 1000 to 0, but when I try to home all the axes the Z axis will not do it, and the DWC gives me a message saying the Z endstop is triggered. I try inverting the position of the two cables but the problem continues. Any idea? Thanks



  • I forgot to say that I am using the "switch" option in the probe type of the configurator tool, and the trigger value in 1000.



  • I solved it! I have to add I1 after the M558 in the config.g file. Thanks for the great documentation, I leave this thread here for helping people solve this. Bye!



  • Could you post a quick write up with your settings used and the wiring locations? I could add it to the documentation for others to find. I think you may be the first to get it working or already post about it.


  • administrators

    @_santiserrano said in EZABL z-probe wiring and configuration:

    I solved it! I have to add I1 after the M558 in the config.g file. Thanks for the great documentation, I leave this thread here for helping people solve this. Bye!

    I'm glad you got it working. For faster response I suggest you reduce the trigger threshold to 50 or 100.



  • @dc42 trigger threshold is the same as trigger value? Or what is it?



  • I think it is all explained in my comments. The settings on the configurator are "switch" and trigger value 1000. And the two cables connected to the Z probe header, on Z PROBE IN and GND pins. And finally, you will have to add "I1" after the M558 command in the config.g file.


  • administrators

    @_santiserrano said in EZABL z-probe wiring and configuration:

    @dc42 trigger threshold is the same as trigger value? Or what is it?

    Yes.



  • @dc42 Thanks! Love my duet, you make a great job. Continue like this, I will continue supporting you buying your products. When will the DUET 3 be available?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.