M588 doesn't work



  • Hi I've previously had a network set on my duetwifi and now that I have moved the card onto the system, it is very weak on this network and so I tried to connect it on another network.
    I have done M588 S"*" through YAT and Pronterface (I have no idea how all these stuff works so I'm just trying all possibilities.) and set up the new network.
    Now I can connect to the new network but the old network is still lurking around. When I upload config file and restart the board, sometimes it connects to the old network, sometimes it connects to the new network. At times I can get into the Web control, and get connection to the board, at times the Web control totally doesn't load. At times the Web control loads, but status is "Disconnected"

    Another qn, can I change the config file directly through the duet Web control? I am trying to change the max speed on my Y axis and I tried editing the config file. Then it had an error message and a config backup file was generated. subsequently it seemed to become corrupted and I couldn't connect anymore.

    Please help this very very lost sheep here.



  • It sounds like maybe M588 S"*" didn't get sent properly through the terminal. Are you using a Mac by chance? Sometimes on a Mac it will replace the double quote with a fancy smart quote character that doesn't get recognized by the Duet.

    If you have a PanelDue you can put the commands into macros and run the macros from the screen.

    You could try adding M588 S"ACTUALNETWORKNAME" with the name of the network you're trying to remove directly into your config.g which will then get run on boot up. You can then remove that line so it doesn't get run every time. But that should remove the network you don't want and leave the network you do want.

    You should be able to edit all the config files directly from the DWC interface. If it's not working properly it could be due to poor network connection.

    You don't mention what firmware version you're running, but if you're not running 2.02 you should consider upgrading. A lot of improvements have been made.



  • @phaedrux thank you for the reply! I'm on Windows 10. I will try out M588 in config file and see how it goes 🙂
    Im on 2.01 for now.. Found it a bit of a chore to upgrade firmware so I didn't do so. 😂 I shall get to the upgrading after I fix the network problem



  • M588 S"NETWORKNAME" actually works wonder! 😄 Thanks so so much^^ and I've upgraded all my firmware~



  • Glad it's working now.

    The firmware upgrade around 1.18 and 1.19 was quite involved, but it's now very simple and straightforward with only a single zip file to upload to update everything.



  • This post is deleted!

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.