Nozzle crashes during print start or stops too high



  • Disclaimer; I'm completely new to Reprap firmware, came from an old printrboard running marlin. I'm completely lost, everything seems to work fine, homes like it supposed to, heats, moves expectedly. every time I try to start a print Z homes via BL touch then either stops too high or digs into the bed. I've tried reading other posts, but I believe I'm just missing something obvious

    Heres the config.g
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 05 2019 20:31:22 GMT-0700 (MST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"pain in my Ass!" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Bellus" P"Elb44060" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X128 Y128 Z64 E32:32 I0 ; Configure microstepping without interpolation
    M92 X638.88 Y638.88 Z1600.00 E591.18:591.18 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z600.00 E1200.00:1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E100.00:100.00 ; Set accelerations (mm/s^2)
    M906 X1100.00 Y1100.00 Z1600.00 E1000.00:1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X260 Y220 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F240 T2400 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z4.0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:220 Y15:210 S15 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S110 ; Set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S250 ; Set temperature limit for heater 2 to 250C

    ; Fans
    M106 P0 S1 I0 F500 H1 T180 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H2 T180 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Right" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Left" D1 H2 ; Define tool 1
    G10 P1 X16 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool

    homeZ

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 05 2019 20:31:23 GMT-0700 (MST)
    G91 ; relative positioning
    G1 Z5 F2400 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y15 F2400 ; go to first probe point
    G30 S2 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F40 ; lift Z relative to current position
    ;G90 ; absolute positioning

    I have tried to change the probe offset, don't believe it helped.



  • @bellus said in Nozzle crashes during print start or stops too high:

    M558 P9 H5 F240 T2400 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z4.0 ; Set Z probe trigger value, offset and trigger height

    How did you measure your Z probe offset? 4mm would be abnormally large for the BLTouch. The guidelines for BLTouch install says the base of the probe body must be 8mm above the nozzle tip. This leads to a trigger height close to 2mm.

    M558 F240 is a bit fast for probing speed. Try half that for better reliability.
    G31 P500 could be reduced to P25 to make it more responsive.

    @bellus said in Nozzle crashes during print start or stops too high:

    M350 X128 Y128 Z64 E32:32 I0 ; Configure microstepping without interpolation
    M92 X638.88 Y638.88 Z1600.00 E591.18:591.18 ; Set steps per mm

    I'm also a little concerned that your high microstepping might be causing some missed steps. If you send a M122 in the console, check the diagnostics report for any reported hiccups.

    I would suggest that you use x16 microstepping with interpolation enabled to start with. You'll get the best performance and quietest operation. If you still want to play around with other microstepping once everything is running smoothly it'll be easier if you start with a base steps per mm calculation for x16 anyway because if you change the microstepping after it's already set for x16 the firmware will automatically calculate the new steps per mm for you.

    ex:

    M350 X16 Y16 Z16 E16 I1                           	; Configure microstepping
    M92 X200 Y200 Z6400 E805                           	; Set steps per mm 
    M350 E64 I0 ; higher extruder microstepping
    

    G30 S2 ; home Z by probing the bed

    Remove the S2 from that line in your homez



  • So I went through and implemented the suggested changes. I also ran M122, no hiccups or errors. It still does the same thing. Homes prior to print start perfectly, raises slightly then lowers to star printing with the nozzle contacting the bed. Enough that it compresses the bed springs.

    I was originally thinking it had something to do with the Zoffset so I tried a bunch of different settings from 0 to 4. It’s back at 2.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 05 2019 20:31:22 GMT-0700 (MST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"pain in my Ass!" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Bellus" P"Elb44060" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I0 ; Configure microstepping without interpolation
    M92 X79.86. Y79.86 Z400.0 E295.59:295.59. ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z600.00 E1200.00:1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E100.00:100.00 ; Set accelerations (mm/s^2)
    M906 X1100.00 Y1100.00 Z1600.00 E1000.00:1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X260 Y220 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T2400 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X0 Y0 Z2.0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:220 Y15:210 S15 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S110 ; Set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S250 ; Set temperature limit for heater 2 to 250C

    ; Fans
    M106 P0 S1 I0 F500 H1 T180 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H2 T180 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Right" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Left" D1 H2 ; Define tool 1
    G10 P1 X16 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool

    I really appreciate you taking the time to help me out, like I said I’m kind of lost. I’m sure it’s something simple, I’m just not 100% good with this new board.



  • @bellus

    please check if you have a "resurrect" file in the system folder.
    If yes, delete it and try again.

    I had issues when doing an emergency stop during a print. The resurrect file was created and this messed up while starting new prints causing the nozzle to have different heights...even after reboot.
    I know check the system folder for this file and delete it...

    Good luck.



  • As a way to eliminate the probe hardware from the equation entirely and to test the Z axis positioning specifically, you can switch over to use M558 P0probe type. That will use manual jogging whenever G30 is called. So you'll have to use the display to drop the nozzle down until it just touches the bed.

    https://duet3d.dozuki.com/Wiki/GCode#Section_M558_Set_Z_probe_type


  • administrators

    To find your Z probe trigger height (G31 Z parameter), see https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    Hint: if your printer digs into the bed when starting the print, your G31 Z parameter is too high.



  • @phaedrux said in Nozzle crashes during print start or stops too high:

    As a way to eliminate the probe hardware from the equation entirely and to test the Z axis positioning specifically, you can switch over to use M558 P0probe type. That will use manual jogging whenever G30 is called. So you'll have to use the display to drop the nozzle down until it just touches the bed.

    https://duet3d.dozuki.com/Wiki/GCode#Section_M558_Set_Z_probe_type

    So I tried this first, manually jogging this during homing works as advertised. BUT, when starting a print, X & Y home and then the pop up for Z comes up but it’s un-responsive. Clicking of the Z movements does nothing.



  • @dc42 said in Nozzle crashes during print start or stops too high:

    To find your Z probe trigger height (G31 Z parameter), see https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    Hint: if your printer digs into the bed when starting the print, your G31 Z parameter is too high.

    I think I understand the Z offset better now. I followed the calibration. I repeatdably got 2.053 about 6 times. But it still drives into the bed, granted not as bad though.


  • administrators

    Does this problem only occur when you start a print file, or does it also occur if you try to home the printer manually?

    If it only occurs when you try to print a file, please post the first 50 or so non-comment lines of the print file.

    You have your max Z speed set to 600mm/min in M203, which is quite high seeing that your Z steps/mm is 1600 in M92. You may be losing Z steps because of trying to move the Z axis too fast.



  • @dc42 said in Nozzle crashes during print start or stops too high:

    Does this problem only occur when you start a print file, or does it also occur if you try to home the printer manually?

    If it only occurs when you try to print a file, please post the first 50 or so non-comment lines of the print file.

    You have your max Z speed set to 600mm/min in M203, which is quite high seeing that your Z steps/mm is 1600 in M92. You may be losing Z steps because of trying to move the Z axis too fast.

    Correct, only while starting a print. All axises home correctly, then Z lifts approximately 10mm or so. when the print begins Z descend right into the bed. Every time I have initiated homing and even during mesh bed compensation it works flawlessly.

    *M107
    M190 S75 ; set bed temperature and wait for it to be reached
    M104 S215 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle
    ; Filament gcode

    M109 S215 ; set temperature and wait for it to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 E-2.00000 F120.00000
    G92 E0
    G1 Z0.400 F4800.000
    G1 X92.212 Y89.205 F4800.000
    G1 E2.00000 F120.00000
    G1 F1800
    G1 X92.637 Y88.772 E2.03205
    G1 X93.334 Y88.124 E2.08232
    G1 X94.213 Y87.375 E2.14338
    G1 X94.781 Y86.937 E2.18124
    G1 X95.550 Y86.380 E2.23146
    G1 X96.106 Y86.019 E2.26650
    G1 X96.726 Y85.657 E2.30444
    G1 X97.515 Y85.234 E2.35171
    G1 X98.203 Y84.918 E2.39175
    G1 X98.683 Y84.737 E2.41883
    G1 X99.722 Y84.395 E2.47665
    G1 X100.566 Y84.160 E2.52297
    G1 X101.231 Y83.990 E2.55923
    G1 X102.131 Y83.819 E2.60765
    G1 X103.208 Y83.738 E2.66472
    G1 X115.192 Y83.690 E3.29807
    G1 X115.923 Y83.724 E3.33670
    G1 X117.305 Y83.876 E3.41018
    G1 X118.207 Y84.029 E3.45857
    G1 X118.740 Y84.140 E3.48733
    G1 X119.694 Y84.389 E3.53943
    G1 X120.474 Y84.642 E3.58274
    G1 X121.308 Y84.964 E3.63003
    G1 X121.874 Y85.211 E3.66264
    G1 X122.669 Y85.599 E3.70938
    G1 X123.829 Y86.239 E3.77942
    G1 X124.366 Y86.575 E3.81288
    G1 X125.088 Y87.072 E3.85922
    G1 X125.606 Y87.463 E3.89348
    G1 X126.270 Y88.014 E3.93909
    G1 X127.206 Y88.867 E4.00600
    G1 X128.109 Y89.792 E4.07437
    G1 X128.509 Y90.248 E4.10639
    G1 X129.330 Y91.292 E4.17656

    I did go ahead and change M203 to 100mm to see if that made a difference and did not.



  • Can you post your homeall file?



  • @phaedrux

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 05 2019 20:31:22 GMT-0700 (MST)
    G91 ; relative positioning
    G1 Z5 F2400 S2 ; lift Z relative to current position
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    G1 S1 X-245 Y-225 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F2400 ; go back a few mm
    G1 S1 X-245 Y-225 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X15 Y15 F2400 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F40 ; lift Z relative to current position
    ;G90 ; absolute positioning

    M98 Pretractprobe.g ; retract mechanical Z probe



  • @bellus said in Nozzle crashes during print start or stops too high:

    M98 Pdeployprobe.g ; deploy mechanical Z probe
    M98 Pretractprobe.g ; retract mechanical Z probe

    Remove those from your homeall. The G30 command will deploy and retract as needed. This could be causing your issue.



  • ![alt text](image url)@phaedrux said in Nozzle crashes during print start or stops too high:

    @bellus said in Nozzle crashes during print start or stops too high:

    M98 Pdeployprobe.g ; deploy mechanical Z probe
    M98 Pretractprobe.g ; retract mechanical Z probe

    Remove those from your homeall. The G30 command will deploy and retract as needed. This could be causing your issue.

    Removed as suggested, no change. The only thing that seems to help is to Z offset. Running the calibration of the probe I would religiously get right around 2mm. I changed it to .75mm and it wasn’t as bad.



  • Here’s a quick video https://youtu.be/Jux1Wyts-B0



  • @bellus

    At 0 even it’s not crashing and actually attempting to print. Nozzles about .5mm to high.



  • @bellus said in Nozzle crashes during print start or stops too high:

    Here’s a quick video https://youtu.be/Jux1Wyts-B0

    So what command was running in that video? It probed once and then dropped the nozzle into the bed. Was that G28? G29? G30? G32?



  • @phaedrux

    It’s the G28 command, when it starts a print, probes once, then nose dives. I was actually able to get past that point by changing the Z offset to 0, but like I said it’s a bit high(roughly 1mm). I re-measured the Bl touch base from the nozzle tip, it’s almost exactly 8mms.



  • Can you post the contents of your config-override.g file?



  • @phaedrux

    As requested,

    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A66.5 C483.4 D6.2 S1.00 V12.1 B0
    M307 H1 A680.2 C325.1 D11.5 S1.00 V12.0 B0
    M307 H2 A633.9 C320.4 D13.3 S1.00 V12.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0

    I also was to able to set the trigger height to 0.500 with positive results. It’s printing, albeit a blobby mess, just needs a bit of tuning. Honestly don’t know why the trigger height is so low compared the calibration steps, but it’s working.

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I0 ; Configure microstepping without interpolation
    M92 X79.86. Y79.86 Z400.0 E390.12:390.12. ; Set steps per mm
    M566 X2000.00 Y2000.00 Z50.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z100.00 E200.00:200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z60.00 E100.00:100.00 ; Set accelerations (mm/s^2)
    M906 X1100.00 Y1100.00 Z1600.00 E1000.00:1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-130 Y-110 Z0 S1 ; Set axis minima
    M208 X130 Y110 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T2400 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X0 Y0 Z0.5000 ; Set Z probe trigger value, offset and trigger height
    M557 X15:220 Y15:210 S15 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S110 ; Set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S250 ; Set temperature limit for heater 2 to 250C

    ; Fans
    M106 P0 S1 I0 F500 H1 T180 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H2 T180 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Right" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Left" D1 H2 ; Define tool 1
    G10 P1 X16 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool


Log in to reply