Motors will not spin on Z and E



  • We are using two different kinds of motors, but for the Z and E we are using we are using Nema 23 bipolar 2.8 amps (JK57HS56-2804) with gear boxes for extra power. On the X and Y we are using iHSS57-36-10 closed loop.

    On other models of our printers we use iHSS57-36-10 for all motors which is working fine coming off of the expansion connector pins. They work Fine.

    We are now trying to use the main drives. (Drive 2 and Drive 3).

    Motors don't spin please help.

    Here is our config file:
    ;7 2/27/2019 3D Potter
    M111 S0 ; Debug off
    M550 Potterbot 7 ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)

    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits

    ;networking
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    M552 S1 ; start wifi S2 OR S1 network

    M555 P2 ; Set output to look like Marlin
    G21 ; Work in mm
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M584 X5 Y6 Z7 E9 ; Set drive mapping Axis and motor configuration
    M569 P5 S1 R0 T4 ; Drive 0 goes forwards X
    M569 P6 S1 R0 T4 ; Drive 1 goes forwards Y
    M569 P2 S0 R0 T4 D2 ; Drive 2 goes forwards Z
    M569 P3 S0 R0 T4 D2 ; Drive 6 goes forwards E

    M574 X1 Y2 Z2 S0 ; Endstop configuration

    M208 X420 Y370 Z550 ; set axis maxima and high homing switch positions (adjust to suit your machine)

    M208 X0 Y0 Z0 S1 ; set axis minima and low homing switch positions (adjust to make X=0 and Y=0 the edges of the bed)

    M92 X72.70 Y72.70 ; Set axis steps per unitX72.70 Y70.85
    M350 X16 Y16 Z16 E16 I1 ; Set 1x microstepping with interpolation
    M92 Z6359.75 E150 ; Steps/mm for Z and E WAS 8
    M906 X0 Y0 Z2000 E2000 I30 ; Set motor currents (mA) and increase idle current to 60%
    M201 X5000 Y5000 Z2000 E3000 ; Accelerations (mm/s^2)
    M203 X5000 Y5000 Z8000 E5000 ; Maximum speeds (mm/min)
    M566 X5000 Y5000 Z800 E5000 ; Maximum instant speed changes mm/minute

    M581 Z1 S1 C1 ;Configure external trigger

    ; Tool definitions
    M563 P0 D0 ;enable cold extrusion.M563 P0 D0 H1
    ;G10 P0 X0 Y0 Z0 ;Set tool 0 axis offsets
    G10 P1 ;Set initial tool 0 active and standby temperatures to 0C G10 P0 R00 S00
    T0
    M302 P1 ; cold extruder
    M140H-1 ; BED OFF

    ;*** If you are using axis compensation, put the figures in the following command
    ;M556 S78 X0 Y0 Z0 ; Axis compensation here

    ; Misc
    M83
    M302 P1

    ; Heaters
    ;M143 H1 S260 ; Maximum heater temperature
    ;M140 H-1 ; No bed heater
    ;M305 P1 T100000 B4138 C0 R4700 ; Thermistor parameters for heater 1
    ;M307 H1 A577.0 C199.0 D9.8 S1.00 B0


    Our heaters are turned off as we 3D print clay, there is no heater.


  • administrators

    @3dpotter said in Motors will not spin on Z and E:

    M584 X5 Y6 Z7 E9 ; Set drive mapping Axis and motor configuration
    M569 P5 S1 R0 T4 ; Drive 0 goes forwards X
    M569 P6 S1 R0 T4 ; Drive 1 goes forwards Y
    M569 P2 S0 R0 T4 D2 ; Drive 2 goes forwards Z
    M569 P3 S0 R0 T4 D2 ; Drive 6 goes forwards E

    Ho do you have the motors connected? the M584 command has them connected to Drive 7 (Z) and Drive 9 (E) so on the expansion header or Duex5. The M569 command imples you have them connected to Drive 2 and Drive 3...



  • That was it. Thank you.

    Staring me right in the face.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.