U3 Buck ruptured? Admin please advise~

  • administrators

    To any of you who have suffered a blown U3 and not yet returned your Duet, please can you attempt to read whatever markings are still visible on the chip, so that we can see if there is a correlation with batch number/date. The marking on the chip is usually of the following form:


    where xxxx and yyy are numbers.

    Thanks - David

  • @dc42

    Did you report the issue on this forum? if so, please point me to the thread.


    @nicolab28 said in How to extrude until trigger:

    That's what I felt, not yet looked at what it was ...
    I reconnect the new



    I had no answer

  • administrators

    @NicoLab28, in view of the spate of A4403 failures we have seen recently, I will approve a warranty replacement for your Duet.

  • Thank you DC42
    I can still read ?651 375L, she came from duet3d.com

    I have 2 others in 1651 375L, another bought directly at E3D which is not yet mounted, and the one that is mounted from also duet3d.com

    The problem is that of E3d, I did not plan to install it immediately. There is another test to do?

  • @dc42 So I received the 2nd board. It too is a 4403T if I'm seeing that correctly. Again, firmware 2.02, gcode setup via RepRap configurator stable version. I even went through today and verified the gcode necessary for the BLTouch.

    I hook up everything except the BLtouch, everything is good. Printer functions etc.

    I hooked up the BLtouch, and quickly turned the machine off because it seems to exhibit the same behavior.

    The sequence is:
    No BLTouch connected, power flips on, all power led's instantly light up, wifi led does it's thing.
    When BLTouch connected, power flips on, VIN led lights up, and other power led's don't light, or are dim.

    At this point I'm afraid it's going to fry U3 again, but I have it correctly hooked up according to the pictures.
    Zprobe= White|Black|blank|blank and then to the expansion port, pin1 red pin2 ground/brown pin8(or heater3) yellow/orange

    Now at first the BLTouch is set to 5.5v, it's the October 2017 BLTouch Smart 2.0 https://docs.wixstatic.com/ugd/f5a1c8_ae578955f18f4a02ba55fd1bc0d1fd7d.pdf

    I even scratched the back to separate logic and make it 3.3v, but it's still not working seems to power up now though.

    I ordered a new BLTouch that should be here tomorrow, but the one I have is genuine, and worked the morning of original installation.

    Please advise. Board seems fine, but I'm afraid to leave it on with power led's exhibiting the same behavior prior to the roast. I assume power led's should instantly light up with every power on?

  • @kungpaoshizi "I assume power led's should instantly light up with every power on?" - Yes

  • This post is deleted!

  • M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917DA-G4MSD-6J1F6-3S86P-99U7A
    Used output buffers: 3 of 20 (14 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98832 of which 0 recycled
    Exception stack ram used: 344
    Never used ram: 6372
    Tasks: NETWORK(ready,544) HEAT(blocked,1232) MAIN(running,3788) IDLE(ready,200)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:24:27 ago, cause: software
    Last software reset at 2019-03-09 04:31, reason: User, spinning module GCodes, available RAM 6332 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 29.7, current 30.3, max 31.1
    Supply voltage: min 11.8, current 12.2, max 12.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-03-09 04:55:43
    Cache data hit count 4294967295
    Slowest loop: 5.45ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 238, MaxWait: 1129814ms, Underruns: 0, 0
    Scheduled moves: 13, completed moves: 13
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.2
    Heater 1 is on, I-accum = 0.4
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 14.33ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi Vcc 3.34, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 14776
      WiFi IP address
      WiFi signal strength -48dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

  • @dc42 44031-1747-686L btw I think, hard to read, apologies for not posting earlier

  • administrators

    @kungpaoshizi said in U3 Buck ruptured? Admin please advise~:

    No BLTouch connected, power flips on, all power led's instantly light up, wifi led does it's thing.
    When BLTouch connected, power flips on, VIN led lights up, and other power led's don't light, or are dim.

    It sounds that your BLTouch is shorting out the 5V supply. This could either mean that it is faulty, or that then +5V and ground wires have been connected the wrong way round either now or in the past.

    My current theory about these U3 failures is that they are triggered by a combination of the Duet VIN being at or above the maximum allowed (25V) and the load on the 5V supply being abnormally high. So please don't power that BLTouch from the Duet using VIN power as long as it is shorting out the 5V rail.

  • @dc42 Well, here's a pickle for ya. After unplugging and plugging the bltouch to the board multiple times, everything started working.
    After receiving the new bltouch, everything worked for it too.
    My first thought was maybe the 5v pin on the expansion port was loose, but it's not turned off the bltouch at all since it started working.

    I've printed more than 20-30 hours so far, turned the unit on/off many times. The only thing I've not done yet is rehooked all the connections up. I'll be doing that soon though as I'm changing psu's and steppers.

    I'll update further if I have anything happen. I will say awesome work. Truly awesome. The experience connecting to WiFi and transitioning between machines via web page has been flawless. Thank you sir! 🙂

  • administrators

    I'm glad it's working. Is there any chance that a whisker from one of the BLTouch wires escaped the crimp and was shorting to the next pin? That's been known to happen before.

  • @dc42 I checked everything very thoroughly when it wasn't working. I was pretty disappointed.

    Even rechecked my crimps and that the contacts from the connectors were down inside the connectors enough.

Log in to reply