Parts Fan won't turn on during print



  • Hi All!
    CR-10S Maestro setup. My Hotend fan is on the "Always On" port and the parts fan on port 1, port 0 apparently is dead (separate post previously), so I have to skip port 0.

    I get the fan showing in DWC fine, and the slider controls it perfectly, even runs as low a 5%, very nice for a cheap blower fan. But when I print something it ignores my print fan settings, I have to catch the 3rd layer and set it by hand.

    Using Cura 3.6.0, but it also does it with Slic3rPE. I'm sure it's a mapping / naming issue between Cura and the Duet but I can't figure it out.

    Here's my Fans section:

    ; Fans
    M106 P0 S0.3 F500 H1 T45 C"Hotend Fan" ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 F100 H-1 C"Parts Fan" ; Set fan 2 value, PWM signal not inverted. Thermostatic control is turned off

    If you need a sample print file I'll post a small one. Any ideas?



  • @puterpro Usually, P0 is the part cooling fan and P1 is the hot end (always on) fan. So if you swap P0 and P1 in those statements it ought to work I'd have thought (at least it does on my machine).

    Edit. See @wilriker's post - it's a better answer than mine ☺



  • @puterpro RRF assumes fan 0 if nothing else is configured and a M106 Snnn command with no Pnnn parameter to define which fan (which is the way most slicer's do it - but I think you can even configure it it Cura).

    You need to extend your M563 tool definition command with F1 which tells it that whenever this tool is active and M106 without Pnnn parameter is encountered use fan 1.

    P.S.: If you only want to fix the GCode that Cura outputs then in Cura go to

    Settings -> Printer -> Manage Printer -> Machine Settings -> Extruder 1 -> Cooling Fan Number
    

    Change the value from 0 to 1. After that Cura should create M106 P1 Snnn commands.



  • @deckingman - Thx! 😀

    @wilriker - Also a big TU! So simply change my M563 P0 S"Extruder" D0 H1
    to:
    M563 P0 S"Extruder" D0 H1 F1

    Points the system to fan 1? Seems better than tweaking Cura ... I like to fix problems not symptoms when I can ... LOL!

    Appreciate the fast answers guys! I'm almost dialed in with this thing, updating my bed mesh now, then I should be good, it's been an adventure.



  • @puterpro said in Parts Fan won't turn on during print:

    ... I like to fix problems not symptoms when I can ... LOL!

    👍 on that attitude. 🙂



  • @wilriker - LOL! Indeed.

    Hey - reopened this because I've got a related "bug"...

    Putting F1 in the tool definition fixed it, but now I get TWO fans listed in DWC, like this:
    0_1551981422920_Fan Control.JPG

    BOTH control the parts fan! Huh??! (He says in his BRIGHTEST voice)

    In a somewhat related Q, does the always on (hotend) fan change speed with temp of the hotend with how I've got it configured? I'd like it @ 30% minimum, but run up as the temp goes up, is that possible?

    I plan on doing some higher temp stuff. It's a 40mm Noctua cooling a E3D v6 Gold (copper plated block), so for PLA and such 30% is probably fine, but when I get up over 280°C ... 😁



  • As far as i know (and how it works for me) that is normal, tool fan and part fan are same in DWC. According to settings for termostatically controlled fans, look at https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On , specially T parameter.



  • @aidar said in Parts Fan won't turn on during print:

    As far as i know (and how it works for me) that is normal, tool fan and part fan are same in DWC.

    Normal, eh? Seems odd to have two controls for one fan ... any way to hide one?

    According to settings for termostatically controlled fans, look at https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On , specially T parameter.

    Yep, read that, and my hotend fan is set for it, guess I wasn't clear in what I was asking ... Does the fan ramp up and down with the HE temp or just come on at the trigger temp?



  • @puterpro said in Parts Fan won't turn on during print:

    Yep, read that, and my hotend fan is set for it, guess I wasn't clear in what I was asking ... Does the fan ramp up and down with the HE temp or just come on at the trigger temp?

    Depends how you configure it. Look at examples on that link above. My understanding is, it you specify T parameter like T60:100, then fan will "wake up" at 60 and will run in full at 100. Between probably speeding up proportionally, but i am not sure about that.



  • @aidar said in Parts Fan won't turn on during print:

    .......... My understanding is, it you specify T parameter like T60:100, then fan will "wake up" at 60 and will run in full at 100. Between probably speeding up proportionally, but i am not sure about that.

    Yes that's exactly right. Effectively the PWM is ramped from zero to max (255) over the temperature range in this case 60 to 100. At any temperature below 60, the fan will be off, and at any temperature above 100 it will be fully on. At mid temperature (80 in this case) the fan will be "fed" a PWM value of 128 (ish) so should run at half speed.



  • Re-Re-Re-read it and found this:
    "In firmware 1.19 and later, the T parameter may be of the form Taaa:bbb where aaa is the temperature at/below which the fan should be fully off and bbb is the temperature at which the fan should be fully on. The PWM will be set proportionally if the temperature is between these limits."

    So that's what I'm after - set it to trigger at 45 then full speed by 250.

    I'll change it to this:
    M106 P0 S0.3 F500 H1 T45**:250** C"Hotend Fan"

    Sometimes you read this stuff 10 times and it eludes you until someone smacks you with an example ... LOL! I'm a fairly bright guy but sometime feel like I've got rocks ... No idea how I missed this. Thx again.

    Anyone want to take a stab at the hide the second fan control??



  • @deckingman - Cross posting, LOL! Thx! Makes sense now.



  • @puterpro No worries. In your example, leave out the asterixs and also the S0.3. The "S" parameter would normally fix the speed but I'm unsure how it would interact with the T parameters.

    So M106 P0 F500 H1 T45:250 C"Hotend Fan"



  • @deckingman - Formatting error strikes again! I had BOLDED it and forgot that it doesn't work right sometimes ... like after a colon. I wrote what you wrote. Thx!

    Who knows what THAT command would do. Detach second stage or something... (Hotend flies across room ... Zing ...)

    Edit: the S parameter was configured by RRF Config Tool. I agree and will remove it.

    I'm marking this solved, will post separately about hiding the second fan control. Thanks to all!! ☺



  • @puterpro Ah yes. Seems these forums sometimes work like predictive text or auto correct and change something that is perfectly legitimate into something that isn't. I think it's some sort of artificial intelligence that gets bored and just tries to introduce typo's in order to pass the time. I have a theory that "smart phones" deliberately do things like that in order to make users look stupid. That's my excuse anyway......☺



  • @deckingman said in Parts Fan won't turn on during print:

    The "S" parameter would normally fix the speed but I'm unsure how it would interact with the T parameters.

    If a temperature range is specified via Taaa:bbb then Snnn acts as the speed it starts with at temperature aaa, i.e. in the above configuration that means that at 45°C the fan will start at 30% speed and ramp up to 100% on its way to 250°C. is ignored.



  • @wilriker said in Parts Fan won't turn on during print:

    If a temperature range is specified via Taaa:bbb then Snnn ................. is ignored.

    That's what I assumed and hoped would be the case.



  • @deckingman I had to check in the source code after I wrote it. 😁

    But any Lnnn parameter (default 10%) is still honored. So if you want your fan to turn on with a specific speed at the lower end of the temperature range use Lnnn to achieve that.



  • @wilriker said in Parts Fan won't turn on during print:

    @deckingman I had to check in the source code after I wrote it. 😁

    But any Lnnn parameter (default 10%) is still honored. So if you want your fan to turn on with a specific speed at the lower end of the temperature range use Lnnn to achieve that.

    Which is in fact exactly what I do with my hot end fan.

    M106 P1 S255 I0 F250 L125 H1 T60:140

    It's mostly for when the hot end cools down which takes a lot longer than when it is heating. Without the "L" parameter, the fan runs slower and slower and slower as the temperature drops but the slower it runs, the longer it takes the hot end to cool. So it seems to take forever before the fan actually turns off completely and at low PWM values, it makes an annoying buzzing noise. With the "L" parameter, the fan speed drops to about 50% at around 100 deg C but maintains that speed until the hot end cools below 60, at which point it turns off completely. The net result is that the hot end cools faster and the (annoying) fan turns off sooner.

    It works well for me anyway.



  • @deckingman said in Parts Fan won't turn on during print:

    The net result is that the hot end cools faster and the (annoying) fan turns off sooner.

    That's the reason why I only use the most silent fans I can find. I remember the original Anet A8 hotend cooling fan. It was always on when the machine was powered with no way to turn it off - and it was ridiculously loud and noisy. Seriously it was not possible to talk with normal voice next to it. Replaced it as soon as possible with an inaudible fan and it was so... silent. Turning at 100% all the time and I was only able to hear it with my ear about 5cm away from it. Wonderful. 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.