Why two fan controls in DWC?



  • This is a continuation of another post "Parts Fan won't turn on during print". That issue was solved so I closed it, but i still don't get why Duet Web Control shows TWO fan controls.

    BOTH control the parts fan.

    Is there a way to hide the second control?

    Looks like this:

    0_1551985424677_Fan Control.JPG

    Here's my modifications (after previous post):

    Tools:
    M563 P0 S"Extruder" D0 H1 F1 ; F1 to redirect for Slicer to control parts fan properly

    ; Fans
    M106 P0 F500 H1 T45:250 C"Hotend Fan" ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 F100 H-1 C"Parts Fan" ; Set fan 2 value, PWM signal not inverted. Thermostatic control is turned off

    It WORKS but has the two fan controls in DWC. Not the end of the world but it's silly and bugs me (my OCD is showing!).

    Any ideas of how to fix that?



  • This makes more sense for printers with multiple tools, each with their own fan. Tool Fan will control the currently selected tool, whereas parts fan is just a label on a fan, which may or may not be currently active.

    There's no way to hide it currently.


  • administrators

    as @Phaedrux says the tool fan is for the currently selected tool, the other fan(s) are for specific tools so if you have three tools you get 4 fan sliders.

    I think it would make sense to have an option to hide on in single extruder printers so I am moving this to the DWC section as a wishlist item.



  • @Phaedrux
    Thx! Made it clearer. I have to keep reminding myself the Duet community is way more than one extruder printers; laser, CNC, and some pretty odd other projects ...

    @T3P3Tony
    Thank you Tony, certainly not a priority but would make it look cleaner. ☺



  • OK.. it´s old.. but...

    A workaround ist.. define the 2. FAN.. as Thermostatic controled.. and it´s gone in WBC.
    Reason.. you can´t control a thermostatic controlled FAN


Log in to reply