Delta FSR G32 Calibration Not Converging



  • I have an Ultibots D300vs delta with fsr’s. I recently put a magnetic base plate on it and have been facing difficulties with autocal. Doing say 5 or 6 g32’s, I get the After values between .020 and .022 but Before values between .40 and .44. So both Before and After converge but not to the same number. Does this provide a clue as to what might be wrong? Thx for any help.


  • administrators

    That suggests inconsistent probe readings. I'm out of the office right now but I recall a couple of threads on this forum giving macro files to do probe repeatability tests. You could also look at the M558 options for probing each point more than once.



  • I have my printed be set to .015 tolerance and up to 5 retries. I’ve done repeatability tests.
    The first pic is 2 g30 s-1 at each of 10 points.
    The second is multiple bed probes with s-1.
    The 3rd pic is multiple g32’s with no homing in between.
    0_1552097831703_5D26F98D-AF26-402C-AC44-1F71078E1A90.jpeg



  • 0_1552098096772_8EA3A3CD-2B36-440C-AC83-73AC46E83C6D.jpeg 0_1552098052956_729EA469-7347-4850-80D8-2201EA1B998C.jpeg



  • Sorry to chime in again but I realized pic 2 and 3 are reversed from my description. The max deviation at a given point across the g30 s-1’s in pic 3 is .023 but most are much smaller. @dc42 I think I read anothe rpost of yours saying that with .9 steppers that I should be at .01 repeatability. Are the few that are over that a potential cause for the Before and After not converging with g32’s?



  • Tried more mechanics, new wheels and bearings, belts, tightened everything. This .02 tolerance on z probe with up to 3 tries at each point. No g28 between g32’s. Anyone have any ideas?
    0_1552336588726_D392E9B8-F716-41F6-B350-78A52129A693.jpeg



  • How tight is the bed in the bed clamps? On my Ultibots K250 when I had FSR's there was a very narrow range of tightness that they worked good but didn't allow layer shift.



  • Also changed the jumpers on the board for full sensitivity



  • I have printed different brackets than stock because of new magnetic bed. There is plenty of gap there. I never experience any layer shift. I’ve tried with sensitivity on the fsr’s all the way down to 25 and up to 500.
    The After value always stabilizes but the Before cycles. It must have to do with the algorithm .



  • I went to look for the jumper settings I mentioned that affect sensitive and it appears the newer JohnSL boards don't have them.



  • I think sensitivity is all in doftware now. I just replaced the fsr’s to see if that was it but still the same. I’m at wit’s end unless someone sees a pattern in these numbers that gives me a clue what to look for.



  • Are you sure the towers aren't out of alignment slightly?



  • Checked with machinist’s square.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.