M221 not doing anything or?



  • Im trying to make an extrusion tuning tower, and I can see that there is an duet commando called "M221: Set extrude factor override percentage"

    For each mm I move up, I try to reduce 1% extrusion, and my first layer was 120% so I gave it the commando:
    "M221 S120 D0:1:4;"

    at the layer 5 (z = 1mm)

    M221 S119 D0:1:4;

    and so on down to S80 at 40mm high.

    But tower looks just the same:
    0_1552496274001_IMG_1248.JPG

    The reason why I do both D0, D1 and D4 is, that I suspected it to be tied to the stepper driver -
    0_1552496377165_IMG_1249.JPG
    As you can see on the panel due (look at the temperature) my extruder 0 is the 4th extruder on the due, so that's why I also do for D4 - also tried D3, same with no effect.

    So why does my tower not change even with 40% change in extrusion?

    EDIT: also the reason why it says 120 on the panel due, is I tried to set it manually on the paneldue to 120, but it did not change throughout the code

    I can also see it on the webinterface that it goes from 120 down to 80, but there is no diffrence on the print



  • @martin1454 I'm not to sure that you can set the extrusion override percentage for all extruders "en bloc" using colon separators between each drive. How many extruder drives do you have and are you using multiple drives together as in a mixing hot end? If you look at the web interface, you'll see sliders for extrusion factor on the job status page. There is one for each extruder. If you move a slider for say extruder 0, then look at the console page, you'll see that the command M221 D0 Snnn was generated.

    So I think if you are using a mixing hot end with extruder drives 0, 1 and 4 and you want to change the overall extrusion amount to say 90%, then you need to alter the extrusion percentage override to 90% for each extruder. If you don't have a mixing hot end, and only use one extruder at a time, then you only need specify the extruder drive that s being used (the default is drive 0).



  • @deckingman Its not a mixing hot end - it is just to force all hot ends to a ceartin % to be sure they are extruding x% instead of 100%



  • @martin1454 I've just tried on my machine. Entering M221 D0:1:2 Snnn only affects drive 0 - the other drives remain unchanged. So that confirms my thought that you have can't do all drives "en-bloc" and have to use separate M221 commands for each extruder.

    When you printed your tower, were you using drive 1 or 4 rather than drive 0? If so, that would explain why you didn't see any change because using M221 D0:1:4 would only change the extrusion percentage for drive 0.

    Edit. If you print another tower, it's a lot easier to use the sliders than inputting M221 commands each time. The result is the same. i.e. M221 Dn Snn will be sent whichever way you do it.



  • @deckingman said in M221 not doing anything or?:

    Edit. If you print another tower, it's a lot easier to use the sliders than inputting M221 commands each time. The result is the same. i.e. M221 Dn Snn will be sent whichever way you do it.

    Well, I don't wanna move the slider 1% each mm 🙂 but will try with seperate M221 - My extruder was "#0" but on my panel due, it is the #4 extruder (as you can see on the picture). -



  • @martin1454 said in M221 not doing anything or?:

    @deckingman said in M221 not doing anything or?:

    Edit. If you print another tower, it's a lot easier to use the sliders than inputting M221 commands each time. The result is the same. i.e. M221 Dn Snn will be sent whichever way you do it.

    Well, I don't wanna move the slider 1% each mm 🙂 but will try with seperate M221 - My extruder was "#0" but on my panel due, it is the #4 extruder (as you can see on the picture). -

    Fair enough - trying to adjust the slider in 1% increments is a bit of a pain.

    However, I'm confused by your extruder numbering. Can you post your config.g file - or at least the sections that show the drives and the tool definitions.



  • @deckingman for that tool:
    M563 P0 D1 H4 F4 ; Define tool 0
    G10 P0 X-10 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ;

    I could see the web interface slider go down from 120 to 80 for tool 0 when it was running, but it didn't do anything to the print



  • Is your extruder motor capped at a low speed?



  • @martin1454 said in M221 not doing anything or?:

    @deckingman for that tool:
    M563 P0 D1 H4 F4 ; Define tool 0
    G10 P0 X-10 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ;

    I could see the web interface slider go down from 120 to 80 for tool 0 when it was running, but it didn't do anything to the print

    I could really do with seeing all your tool definitions and drive mapping. However, according to the above, tool 0 uses extruder drive 1. So changing drive 0 won't do anything. If you are using M221 D0 Snn then try M221 D1 Snn.



  • @deckingman said in M221 not doing anything or?:

    I could really do with seeing all your tool definitions and drive mapping. However, according to the above, tool 0 uses extruder drive 1. So changing drive 0 won't do anything. If you are using M221 D0 Snn then try M221 D1 Snn.

    That was what I was wondering - Does M221 "D#" goes with your tool number, your heater number or stepper drive number? - My initial guess would be tool number, but will try with drive number #1 and only #1.


  • administrators

    The M221 D parameter is the extruder drive number, as documented at https://duet3d.dozuki.com/Wiki/Gcode#Section_M221_Set_extrude_factor_override_percentage.



  • @dc42 said in M221 not doing anything or?:

    The M221 D parameter is the extruder drive number, as documented at https://duet3d.dozuki.com/Wiki/Gcode#Section_M221_Set_extrude_factor_override_percentage.

    Okay, so for my tool 0, the drive number is 1 right?



  • @martin1454 said in M221 not doing anything or?:

    @dc42 said in M221 not doing anything or?:

    The M221 D parameter is the extruder drive number, as documented at https://duet3d.dozuki.com/Wiki/Gcode#Section_M221_Set_extrude_factor_override_percentage.

    Okay, so for my tool 0, the drive number is 1 right?

    Yes. But the extruder drive number isn't the same as the physical drive that the extruder drive is connected to. Confusing isn't it? The following might help to cut through the fog a little.

    In my case, I use a mixing hot end which has multiple extruders feeding in to a common nozzle. So I have a number of tools which all use the same extruder drives like this:

    M563 P0 D0:1:2:3:4:5 H1
    M563 P1 D0:1:2:3:4:5 H1
    etc.

    In above "P" denotes the tool number which thereafter is referenced by using "T".

    To use one particular filament, I have a different mixing ratio e.g.
    M567 P0 E1.00:0.00:0.00:0.00:0.00 .
    This will use 100% off the the first extruder (D0) and zero % of the rest.

    The motor drives are physically mapped to extruders using the M584 parameter. In my case..
    M584 X0:3 Y1:4 Z2 U10 V11 E5:6:7:8:9

    So the first extruder is D0 but this is mapped to drive 5, the second is D1 which is mapped to drive 6 etc etc.

    If you have M584 Xn Yn Zn E1:2:4, then your 3 extruder drives will be D0, D1 and D2 but mapped to physical drives 1,2 and 4. You can re-map the drivers associated with extruders but they will always be referred to as extruder D0, D1 and D2.

    In summary, the extruder drive number used in M221 refers to the order that extruder drives are defined in M584. If there are only two extruders, the default (on a Duet Ethernet or WiFi) is D0 and D1.

    TBH, I think the Wiki should be amended to clarify this. Try it first to make sure that what I've said is correct, then we'll look at getting that clarification put in the Wiki.



  • @deckingman Perfect thanks! - Will try a new Gcode tower when I get home.

    And yes, a bit more clarification on the Wiki could be good -

    How is it going with your everlasting project of a printer? Been some time since I saw a new post on your blog 🙂



  • @martin1454 said in M221 not doing anything or?:

    How is it going with your everlasting project of a printer? Been some time since I saw a new post on your blog 🙂

    I'm working on something that has got beyond the initial design stage and now requires parts making from metal. This is proving to be much more of a pain than I ever thought it would be. I've decided that the best way forward is to actually buy a small milling machine and maybe a lathe so that I can make the parts myself. That requires turning my garage from a wood working shop into a metal working shop. The wood lathe has gone, and a new insulated garage door is on order but there is a lot more to do (and a fair bit of money to spend).



  • @deckingman Funny how these "small" projects always evolve into something much larger 😛



  • It worked - My tool 0 needed only the "D1" parameter alone.

    Thanks for the help!



  • @martin1454 No worries - glad it's working for you.


Log in to reply