No response from YAT after sending command



  • I have been configuring my Duet 2 Ethernet and did the s/w updating through YAT and USB from my PC, all worked well.

    I now have the printer (BigBox) in a different room to the PC so am unable to connect via USB but I do have a successful connection through ethernet. My problem is that when I send M552 S1 to the Duet to get the address for Duet Web Control there is no response on YAT or rather YAT doesn't put it on the screen. It certainly appears to process the command. YAT is connected successfully to COM port 1 at 9600, 8-0-1. I was able to get the address via YAT when using the USB port, this only occurs on ethernet.

    I'm guessing this is simply a setting I've missed but I can't find anything for the life of me !

    Keith



  • Sorry, I omitted to say I was sending M115 to get the address. The same response results as with M552. There is also no OK response from YAT.

    Just to add, I'm using the very latest s/w for all. I'm running Duet 2 ethernet and the printer is the BigBox from E3D which is a cartesian


  • administrators

    COM1 on your PC is not the Duet. Here are 4 ways of finding the IP address:

    1. Connect a PC or laptop to the Duet USB port and use YAT.

    2. If you have a PanelDue, send M552 from that.

    3. Log on to the admin page of your router and go to the list of devices on the local network.

    4. With the Duet turned off or disconnected, go to a command prompt and enter "arp -a". Then turn the Duet on, give it time to connect to your router, and repeat. The new IP address in the list is the Duet.



  • @dc42 Thank you David, I now have 192.168.1.14 and a connection in Web Control. I have another query though.

    I changed the config.g to show M552 P0.0.0.0 to enable DHCP but the browser just times out, I can only get a connection using 192.168.1.14. How do I enable DHCP?

    Keith


  • administrators

    If you enable DHCP then the router will assign the IP address (that's what DHCP is for). So you will need to find out the IP address again, because it will probably have changed.



  • @dc42 I'm a little puzzled, the comments in config.g say to enter 0.0.0.0 to enable the DHCP but when I enter that data the browser times out. What settings do I use to enable DHCP in config.g so it will find the address itself ?

    Keith



  • 0.0.0.0 will enable DHCP. DHCP means that the router will pick an IP address from it's range and assign it to the Duet. So 0.0.0.0 isn't the IP you go to, it's just a placeholder.

    To find the actual IP you can connect to your router and see what it was assigned. You can probably also reserve that address for the duet in your router control panel so that it doesn't change.

    You could also find the IP address through USB again, but without a reservation at the router side, the IP may change again in the future.


  • administrators

    By setting the IP address to 0.0.0.0 in the M552 command in config.g on a Duet Ethernet, you are instructing the Duet to ask your router to allocate it an IP address. This helps to make sure that you don't give the Duet an IP address that is already in use on our network. Your router will then tell the Duet what IP address to use. In your case it will probably be 192.168.1.something and that is the address you need to enter in your browser. The address 0.0.0.0 is not a valid IP address, that's why we use it to signal that DHCP should be used.

    HTH David



  • @dc42 Thanks David, that's actually confirmed that I understood how it worked apart from how to enable DHCP, which again is actually what I thought it was. So here is my problem still -

    I enter 0.0.0.0 into config.g instead of the real IP address, I then try to connect but the browser just times out. Would this be a problem with my router, perhaps that isn't set for DHCP. I'll check out the admin page on my router, in the meantime could you give me your thoughts on my thoughts 🙂

    Keith



  • @kayjay said in No response from YAT after sending command:

    I then try to connect

    What are you trying to connect to though?


  • administrators

    @kayjay said in No response from YAT after sending command:

    I then try to connect but the browser just times out.

    What IP address did you enter in the browser, and where did you get that IP address from?



  • @phaedrux The duet web control. It works fine if I have 192.168.1.14 in config.g and I enter that in the browser, all is ok but I wanted to change it over so that DHCP is in control of the IP.



  • @dc42 I entered 192.168.1.14 and I got it from YAT when I connected to the board with USB during initial setting up, I had the board on my desk next to my PC. Now I can't connect via USB coz the printer is in a different room to my PC.


  • administrators

    @kayjay said in No response from YAT after sending command:

    @dc42 I entered 192.168.1.14 and I got it from YAT when I connected to the board with USB during initial setting up, I had the board on my desk next to my PC. Now I can't connect via USB coz the printer is in a different room to my PC.

    Like I said, your router will almost certain allocate a different IP address via DHCP.



  • @dc42 I undestand that, perhaps I'm missing something somewhere. I put 0.0.0.0 into config.g for the IP address to enable DHCP. Isn't the s/w and the router supposed to take over now with no more input from me? so the IP is irrelevant, to me it's invisible when DHCP is working correctly. I'm only entering 192.168.1.14 to get a connection manually because DHCP won't do it, the browser just times out.

    I'll check through the router settings again in case I don't have DHCP activated in there.

    Keith



  • @kayjay said in No response from YAT after sending command:

    so the IP is irrelevant,

    The IP is still very much relevant. DHCP will have assigned a new IP to the Duet. You will still need to know what it is to connect to it. And the router will need to be configured to reserve that new IP address for the Duet, otherwise it may change again in the future if the lease expires and isn't renewed. (for example, if the duet is left powered off for a while.)

    In your case, if you can't arrange a DHCP reservation, it may be best to specify a static IP for the Duet using an IP either outside the DCHP range while still in the same subnet, or in the upper end of the DCHP range to hopefully avoid a potential conflict in the future where the router assigns the same IP you are using.



  • @phaedrux Sorry, I didn't mean that the IP wasn't relevant at all, I just meant it wasn't relevant when in DHCP because I don't need to enter it. Isn't DHCP supposed to do all that and make it invisible to me?

    Your other suggestion sounds a better option for me, as you say making sure the IP is away from the ones that may be possible used by DHCP, I'll try that.

    Incidentally, my router admin pages reports the IP for Duettest as 192.168.1.95 but if I enter that into the browser it times out. I can still connct successfully with 192.168.1.14. I can control the printer on that IP, turn heaters on and off, move motors etc etc...... wierd or what !

    Keith



  • @kayjay said in No response from YAT after sending command:

    sn't DHCP supposed to do all that and make it invisible to me?

    Only if you're using a mDNS name to access the IP, like http://duet.local which I don't think works with the Duet Ethernet



  • @phaedrux OK, I think you're right there.

    So, let me see if I have this right. I enable DHCP in config.g by creating a line that says

    M552 P0.0.0.0

    then I discover the IP either through my router or YAT, I the enter that IP into the browser address bar and it should stay the same all the time. Is that how DHCP works when done properly?

    Keith



  • @kayjay said in No response from YAT after sending command:

    Is that how DHCP works when done properly?

    Yes, provided there is a DHCP reservation in the router for that IP, it should stay the same.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.