Panel due with 4x heaters on duex5



  • Hi,

    I have a duet wifi + duex5 setup, 4 extruders.
    Because wiring was easier i used heaters 3,4,5,6 (E2 to E5) for the tools T0, T1, T2 and T3.

    So heaters E0 and E1 are unused.
    On the PanelDue the informations get "misaligned", when i activate Tool 0, since heaters E0 and E1 are displayed, the active heater is not just under the related tool.

    Is there a way to disable heaters E0 and E1 so they don't appear on the panel due ?

    I also remapped the drives like this : XYZ on the duet, and every extruder drive on the duex (though i don't think it's related).


  • administrators

    Currently, PanelDue doesn't have access to the mapping between tools and heaters, so it uses a fixed mapping. I've had it on my list for a long tie to fix this.

    In the next 2.03beta release you will be able to map heaters to different ports (eg heater 1 to the E3 Heat output), which will allow you to work around the problem.



  • Thanks dc42, the workaround is perfect (even better, actually 🙂 ). I wondered why it was possible to remap the drives and not the heaters.

    Very impressed with all the work you put into this firmware and your commitment to support users, it's really a great job, thanks a lot !



  • @dc42 said in Panel due with 4x heaters on duex5:

    In the next 2.03beta release you will be able to map heaters to different ports (eg heater 1 to the E3 Heat output), which will allow you to work around the problem.

    Awsome! have been looking foward to a fix!



  • @kraegar I think this may explain your odd tool heater mapping on your Railcore.



  • @Phaedrux Indeed, this would explain the weirdness!


Log in to reply