Homing problems on X and Y



  • I hope this is posted in the right category, sorry if it isn't.

    I have a Bigbox with single extruder, it's fitted with Duet Ethernet and PT100 on the hot end and connected to the correct daughterboard on the Duet. I also have the 7" Panel Due but I haven't tried to connect that yet given the problems I'm facing.

    I'm having a nightmare trying to configure the X and Y drives, probably having the same problem with Z too but I haven't tried that yet.

    Firstly I use M546 S0 H0 to allow free movement of the drives, then I attempt to home drive X, it travels in the wrong direction and for about 30mm and then stops. I have monitored the driver temp and there is no change at all, it stays at room temp, I'm using a temp probe on my multimeter to do this. Because the drive was travelling in the wrong direction I altered M569 P0 S0 to make drive X travel the other way except it doesn't, it makes no difference.

    Now here's a real oddball, attempts to home Y result in X moving approx 30mm and then reversing and running the same distance back again, yes, this is X not Y. I have configured the drives with M584 X0 Y1 Z2 E3 I have only one extruder.

    Finally when the drives stop travelling or part way through the travel error messages are transmitted, 'Short to ground' on any random drive number not normally the drive that is running but sometimes it is. I also randomly get a message that the drive windings may be disconnected again on random motor numbers. There appears to be no recognisable pattern to these error messages.

    I've done a lot of trials with different motors to try to nail this but can't get anything conclusive. I have a good motor and harness I've been using which give results that follow those given by the motors fitted to the printer.

    I'm puzzled regarding the incorrect direction of travel, the motors I have installed on the Bigbox were purchased from T3DP3D along with the cables and about the same time as I purchased the Duet. I'm assuming the cable harnesses are wired correctly to make the motors rotate in the correct direction when using M569 P0 S1 etc

    Help anyone before I have a nervous breakdown 🙂

    Keith



  • My apologies, I meant to attach the config.g

    file0_1554066395049_config.g



  • I'm not familiar with that - is it a corexy or standard cartesian printer?

    First you have to select the location of the printer's origin. It's often set to be the front left corner of the bed or the right rear to ensure right hand rule coordinates. A better alternative is to set it at the center of the bed.

    The config file has to match the switch locations, either at the low end or high end of each axis. It doesn't matter where you put the switches as long as your config file matches their locations. Your config file has the switches at x=0 and y=0. Is that where the switches are?

    Once the config file matches the switch locations, you can try homing each axis. When you home, the motor should drive the extruder toward the switch in each axis. If it goes the wrong way, reverse the motor in the config file.

    I don't know why you'd get error messages unless there's a problem with the cables/connectors or something else going on. An intermittent motor cable or connector can damage or destroy a motor driver chip, the same as connecting or disconnecting a motor while the machine is powered up.


  • administrators

    The BigBox is a Cartesian printer.

    To check the motors are moving in the correct directions, first send G91 to select relative movement, then send G1 S2 commands for each axis. For example, G1 S2 X20 should move 20mm in the +X direction, which on a BigBox is to the right. G1 S2 X-20 should move 20mm to the left. G1 S2 Y20 should move 20mm towards +Y, which is to the rear; and G1 S2 Y-20 should move 20mm towards the front.

    If either X or Y is moving the wrong way, use the M569 command to correct it (change S0 to S1, or vice versa).

    After that, if the motors move the wrong way when you attempt to home, see https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_files.



  • @dc42 Thank you David, that's been a great help. I also spotted something I was doing that was so stupid I should be put up against the wall at dawn 🙂 I was counting the axes from 1 rather than 0 and although it would work it was throwing everything out, why Y was working instead of X etc. I also found a faulty stepper cable. So all in all I've learnt a lot from such a short email.

    Thank you again, much appreciated indeed.



  • @mrehorstdmd Thanks for your advice.

    The Bigbox is a cartesian as David mentioned. The switches are configured correctly but you mentioned some interesting points, thank you. I will bear it in mind for the future.


Log in to reply