Disengage the steppers to level manually



  • I sure hope this is not too embarrassingly stoopid!

    Everything seems to work. Steppers all move correct.
    Limits work right. Hotend is good. Fans are good. Heaters tuned.

    Almost time for that first calibration cube... but. ???????
    I want to manually level my bed. I want to home the bed and disengage the X and Y steppers... But the steppers are engaged! I do not see a disengage steppers on-screen button.
    Do I need to send Gcode to disengage them?



  • M18 disables all steppers
    M18 X Y will do those axis only
    P.



  • Keep in mind that once the steppers are disabled the firmware will consider the machine unhomed, so you'll have to rehome again after.



  • I setup a macro for it, just a simple M18.

    One thing I have to be careful of is my dual Z get a hair off each other when I do it, a known problem with dual Z axis CR-10S machines. My homing routine realigns them, but while the steppers are off, the right side of my bed is a bit low ... I've learned to compensate a bit with the mechanical bed level.



  • @phaedrux said in Disengage the steppers to level manually:

    Keep in mind that once the steppers are disabled the firmware will consider the machine unhomed, so you'll have to rehome again after.

    G92 Z0 should take care of that. However, the steppers might jump a certain number of steps when re-energized.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.