Extruder Motor Stuttering



  • I am having an issue with my extruder motor.
    It appears to be rapidly moving back and forth (or stuttering) for no reason.
    Below is a video link showing the stuttering.

    https://www.dropbox.com/s/stlf1lglxtwdj8e/Extruder1.mp4?dl=0

    The extruder is an e3D Titan.
    The motor has a 0.90 step angle.

    I believe it may be due to my settings.
    Below are the relevant settings.

    M906 X1000 Y1000 Z1000 E800 (set motor amps (mA))
    M201 X3000 Y3000 Z3000 E1000 (Accelerations (mm/s 2))
    M92 E837 (steps/mm)

    Any advise would be greatly appreciated.



    1. Check to make sure the hotend isn't blocked/jambed.

    2. Make sure the temp is right for the filament you are using. Not set too low.

    3.Make sure the "Titan bearing" hasn't gone bad.

    FYI, I wasn't able to watch your video due to firewall setting here at my work.



  • was it working before?
    what did you change?
    did you enable pressure advance?



  • @timcurtis67

    Thanks for your reply.

    I don't think that the temperature is an issue, as It's set at 220°C for PLA.
    I don't think the hotend is jammed because if I extrude 100mm @ 5mm/sec (220°C) in DWC the extruder seems to work smoothly without stuttering.

    It actually prints ok.
    I have printed several test cubes and retraction tests since I changed the extruder motor.
    I noticed the stuttering during a test print and am worried the motor may be skipping steps (but I really don't know).



  • @veti

    Thanks for your reply.

    The extruder was working ok before and it is still working ok. It just appears to be stuttering for no reason.
    I am attempting to determine if this is caused by incorrect settings or hardware issues.
    I'm concerned that the motor may be skipping steps which may lead to under extrusion.
    I was hoping the video link I posted would help somebodu isolate the problem.

    I changed the extruder motor.
    The old motor had a 1.8° step angle and the new motor has a 0.9° step angle.
    The old motor was also smaller.
    Due to this I also changed the amps in my M906 command fro E800 to E1000 (sorry, I just noticed I entered the old amps in my original post).



  • @vacalos

    did you change the cable as well?
    most of the time the pinout of the motors are not the same.



  • @veti

    I purchased both of the motors (old and new) from "StepperOnline".
    Both are wired (pined) the same.



  • That looks and sounds like pressure advance to me. What does M572 output during printing?



  • also there are only 1.68A and 2A bipolar 0.9 stepper motors from steppersonline.
    75% of those does not equal the 1A you configured.

    which one did you purchase.



  • @veti

    Thanks again for your reply.

    I purchased stepper Part # 17HM19-2004S.
    2.80 VOC
    2.00A
    0.90 Step Angle

    Do I have an incorrect setting in my config.g's M906?



  • @edgars-batna

    On the reprap G-code wiki M574 is the command used to set endstop configuration?



  • @vacalos M572, corrected



  • @edgars-batna

    The pressure advance while printing is:

    0_1557253378324_Pressure Advance.JPG



  • @edgars-batna

    I think you are correct.

    After watching the printer closely during a print, I can see that the 'stutters" coincide with a change in direction in the X-Y plane. This motion is obviously intentional and probably due to pressure advance as you suggested. I guess I never watched the extruder gears closely enough to have noticed that motion before. Thanks for the advise.

    What would you suggest an acceptable Pressure Advance setting is for a bowden tube approximately 500mm long?



  • you will have to measure the pressure advance for your printer yourself. As each setup is different.
    There are threads on this forum about pa calibration.



  • As already suggested, it very much depends on the machine. It could be anywhere from 0.1 to 1.0. After running some calibration from these forums, pay attention to your prints. Blobby corners -> increase PA. Rounded corners -> decrease PA. Make sure the Bowden tube sits as firmly as possible.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.