2.03RC2 leveling issue

  • administrators

    @Caveman, I have tried to reproduce this issue, but failed. I have done multiple G29 bed probes, with or without homing between then, with or without a deliberate height error in the M665 command. The height map comes out the same every time I probe, apart from an offset equal to any deliberate height error I set.

  • administrators

    @paulhew said in 2.03RC2 leveling issue:

    I must admit I am having levelling issues also.
    Cartesian Printer. BL Touch v2, glass bed, locked bed nuts.

    I knew something was not right so I dropped the Z axis to 0 using paneldue and could get a number of sheets of paper between the nozzle and the bed.
    Went throught this procedure again. https://forum.duet3d.com/topic/10017/bl-touch-issues where I thought I had nailed the process.
    Changed the G31 P500 X-48 Y-10 Z1.28 to my new value, rebooted.
    Ran mesh level, waited for it to finish, piece of paper under the nozzle, Z axis to 0 and still a large gap.
    Re did it all again and it was still off.
    And again and it worked, maybe a little close but at least the filament is sticking!

    Was going to write a post whether it is possible to keep the BL touch as my Z but using manual bed levelling instead.

    Is this behaviour consistent when you use 2.03RC2, and absent when you revert to 2.02?

  • @dc42 You asked me to use 2.03 RC1last week because of another problem.

    It has happened again, I put my borosilicate glass back on, piece of paper, jog Z to lightly grip paper, reset Z, test probing to configure G31. etc, reboot.
    Home all, move to centre, piece of paper, jog to Z0 and there is a gap again. Grrr!!
    Did not run mesh bed levelling.
    Does not seem to take on 1st second or 3rd tries.
    Rebooted everything and started afresh.

  • @paulhew Are you using config.override.g by any chance? It sounds to me a bit like you have a G31 or something in there that is overriding what is in config.g.

  • @deckingman said in 2.03RC2 leveling issue:

    @paulhew Are you using config.override.g by any chance? It sounds to me a bit like you have a G31 or something in there that is overriding what is in config.g.

    I have checked that file multiple times. I also just realised I am running RC1.
    This is contents of my config.overide.g
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0

    Also it is not just once or twice I have had this problem, but I perfected my routine when I had the problem a few weeks ago.
    The amount of post its with 10 sets of probe numbers is unreal!!!

  • @paulhew Ahh, OK - there is nothing sinister in your config-override that might cause the issue. I suspect it must be something to do with levelliing or mesh compensation in that case, but I don't use either so can't advise. I just happened across this thread and had an idea but it isn't that.

  • Not a problem, anything to get to the bottom of this issue will be good!
    Tempted to scrap the BL Touch and go back to Manual Mesh Bed Levelling!

  • @paulhew said in 2.03RC2 leveling issue:

    Tempted to scrap the BL Touch and go back to Manual Mesh Bed Levelling!

    have a look at a Film Pressure Probe. they can be bought for 2 euros.

  • @veti Thats what the Two Trees Saphire uses, I think. DPT did a review and I quite like it, the printer that is. (Your not the guy behind DPT are you?)
    Overnight I was thinking about my issue, I am pretty sure it is not the Bed Levelling routine, as I have not even got to that stage.
    It is something in the initial setup when setting up the probe height.
    Piece of paper etc etc, set height in the G31 command, reboot and drop nozzle to bed with paper under and at Z0 it was 0.2 - 0.3 higher. I had to disable axis limits to get it to go down.
    Eventually it goes to where it should be after a couple of tries.

    I do not know everything, but from your and others help I have this routine down to an art and have questioned myself if I had done it right many a time.
    Maybe it is something to do with the BL Touch.
    Tempted to order another BLT and see if it is that, but I am off to France on Monday for a week to sort a network out so will prob order another end of week ready for me at the weekend to try again.

  • administrators

    @PaulHew, do you home Z using the BLTouch or using an endstop switch?

  • @dc42 Morning David, I use the BL Touch.

  • This might give you an idea how many times I tried to setup!

  • To me this started happening since 2.03 rc1

  • administrators

    Do you use babystepping? I fixed a bug relating to babystepping and the Z offset in 2.03RC3.

Log in to reply