Ender 3 Pro RepRap config.g



  • I'm getting nowhere with the configuration of Duet2Wifi for an Ender 3 Pro. Both the bed and hotend show 2000c, as if it is an open circuit, even though they are connected properly. Endstops aren't working properly, so it can't home.

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes backwards
    M569 P1 S1 ; Physical drive 1 goes backwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415.00 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z24.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X400.00 Y400.00 Z400.00 E500.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-5.5 Y-10 Z0 S1 ; Set axis minima
    M208 X258.5 Y246 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S3 ; Set endstops controlled by motor load detection

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-10 Y0 Z0.6 ; Set Z probe trigger value, offset and trigger height
    M557 X20:215 Y20:215 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T4700 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T4700 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured



  • Morning.
    Have you seen this? https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+2:+Configuration/38
    This has helped me lots and still does with my Ender3 Pro, it was written for the Maestro.

    Is it a stock Ender3 Pro with no mods other than the Duet WiFi?
    This is my config for the bed
    M305 P0 T98801 B4185 R2200
    Make sure you change the 'R' value to 4700 for the Duet2

    If that does not work, use a ohm meter to make sure there is a resistance to prove that the cables are crimped and in contact.
    HTH
    Paul


  • administrators

    The T values in your M305 commands are wrong. They should both be 100000 or close to that value. That is why you are not getting readings from the thermistors.

    The R values in those commands ate not needed because the firmware knows the correct value.

    See the link in the post above by @PaulHew for detailed instructions.



  • @dc42
    The config.g is what the RepRap Configuration website gave me. So I should change all the T values to 100000 in the config.g file?

    I changed the endstops to S1 and finally got the endstops to work.


  • administrators

    @keith said in Ender 3 Pro RepRap config.g:

    @dc42
    The config.g is what the RepRap Configuration website gave me. So I should change all the T values to 100000 in the config.g file?

    I changed the endstops to S1 and finally got the endstops to work.

    I suggest you follow the link in the earlier post, because that will show you the correct values to use in the configurator.



  • @dc42

    Had a couple of issues with that links configuration. The Bed heater is now working but the hotend is still reading 2000.


  • administrators

    @keith said in Ender 3 Pro RepRap config.g:

    @dc42

    Had a couple of issues with that links configuration. The Bed heater is now working but the hotend is still reading 2000.

    Please tell us what the issues were (so that we can improve that wiki page), and post your config.g file as it now is.



  • @dc42

    The x motor homed to the right instead of the left.
    The z motor homed up instead of down.
    I switched those from S1 or S0 to S0 or S1 in the config.g

    Can't figure out why the hotend is still reading 2000c.

    I have a Micro-Swiss hotend and Bondtech extruder setup in direct drive configuration, with a BLTouch.

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes forwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S0 ; Physical drive 3 goes backwards
    M350 E16 I0 ; Configure microstepping without interpolation
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E500.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X235 Y235 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-28 Y10 Z0.6 ; Set Z probe trigger value, offset and trigger height
    M557 X10:220 Y10:220 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T98801 B4185 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T98801 B4185 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F20 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F20 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F20 H1:0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M918 P1 E4 ; Enable 12864 LCD with 1 menu item per encoder click

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool


  • administrators

    Check that you have the hot end thermistor plugged into the correct connector, the E0_THERM connector. See https://duet3d.dozuki.com/Wiki/Duet_2_Maestro_Wiring_Diagram. If it's definitely in the right connector, it's probably a bad crimp connection or a break in the thermistor cable. You can temporarily plug the bed thermistor wire into E0_THERM to check that the thermistor port is working.



  • @dc42

    . Ok, had a bad crimp. The hotend temp is now working. I have a Duet2Wifi those instructions are for a Maestro, are they the same config wise?


  • administrators

    @keith said in Ender 3 Pro RepRap config.g:

    @dc42

    . Ok, had a bad crimp. The hotend temp is now working. I have a Duet2Wifi those instructions are for a Maestro, are they the same config wise?

    They are almost the same, except for the R value in the M305 command, if you have one. R4700 is correct for the Duet WiFi.



  • Now I just need to get the BLTouch working properly. It seems to home ok, but the BLTouch alarm comes on every time I home, and the M280 P0 S160 Alarm release isn't working.


  • administrators

    @keith said in Ender 3 Pro RepRap config.g:

    M280 P0 S160

    That implies that you have the BLTouch connected to the Heater 0 output, which isn't right. Use the same P value in that command that you do in the deployprobe.g and retractprobe.g commands (usually P3 or P7).

    I am not an expert on BLTouch, but I think it may help to add parameter R0.2 to your M558 command in config.g.



  • @dc42

    None of that worked.
    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jul 16 2019 01:25:02 GMT-0600 (Mountain Daylight Time)
    M280 P3 S90 I1


  • administrators

    Are saying that M280 P3 S160 doesn't reset the BLTouch error?

    Do M401 and M402 commands work (they should deploy and retract the probe)?

    Please post your homeall.g and homez.g files.



  • @dc42
    M280 P3 S160 does not reset the BLTouch error.

    M401 works M402 retracts but the alarm comes on.
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jul 16 2019 01:25:02 GMT-0600 (Mountain Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-240 Y-240 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-240 Y-240 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X38 Y20 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jul 16 2019 01:25:03 GMT-0600 (Mountain Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X38 Y20 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @keith said in Ender 3 Pro RepRap config.g:

    M402 retracts but the alarm comes on.

    I think you may have a damaged probe, or the pin may be bent. There is a set screw at the top of the probe body that you can remove to get the pin out and check it.

    You need the I1 at the end of the command to release the alarm. M280 P3 S160 I1

    What happens if you put the probe into self test mode using M280 P3 S120 I1



  • @phaedrux
    All the other BLTouch commands work fine. Self test, retract, deploy, etc... It's just the M280 P3 S160 I1 that doesn't work.



  • Could it be the command actually works but the sensor goes back into alarm straight away? Seems odds only S160 wouldn't work if the probe is working properly.



  • Recreate the retract probe file from scratch just to be on the safe side.

    When it's doing the self test the probe goes in and out repeatedly no problem?


Log in to reply