Z axis "blocked"



  • and config-override.g please



  • Here is the config file

    And the duetwebcontrol shows Z200, I can still use it perfectly !

    Thanks !

    PS : is there a better way to display enormous file like this ?

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 25 2018 10:06:03 GMT+0100 (heure normale d’Europe centrale)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M581 T2 E1 S1 C0

    ; Network
    M550 P"BIG P" ; Set machine name
    M552 S1 ; Enable network
    M587 S"FREEBOXCDC" P"carlito2002" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M584 X6 Y7 Z5 E3:4
    M569 P6 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P5 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X106.67 Y106.67 Z800.00 E420.00:420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z60.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z600.00 E1200.00:1200.00 ; Set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z100.00 E250.00:250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E1680.00:1680.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z585.70 S1 ; Set axis minima
    M208 X580 Y580 Z0 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 F100 H5 R0.2 T6000 A5 B1 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X108 Y10 Z2.55 ; Set Z probe trigger value, offset and trigger height
    M557 X15:565 Y15:565 S100 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"E0" D0 H1 ; Define tool 0
    G10 P0 X50 Y10 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"E1" D1 H2 ; Define tool 1
    G10 P1 X68 Y10 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S22 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured



  • And I don't have a config-override.g file... is it a problem ?



  • @carlitototo I'm surprised it moves at all - you have the Z minimum set to 585.7.

    M208 X0 Y0 Z585.70 S1 ; Set axis minima

    Changing that to Z0 will likely fix it.



  • @carlitototo said in Z axis "blocked":

    And I don't have a config-override.g file... is it a problem ?

    nah, but if you had one, then it would be one of those places a config command that tricks us all is hiding. So no file, no problem.



  • @carlitototo said in Z axis "blocked":

    ; Axis Limits
    M208 X0 Y0 Z585.70 S1 ; Set axis minima
    M208 X580 Y580 Z0 S0 ; Set axis maxima

    Your Z minima and maxima are reversed.

    That still doesn't explain how it's moving at all, or why it's stopping at 200. Please post your homing files. I think something else is still wrong.



  • Well that's embarrassing... exchange the Z value between Z max and min and it worked... thanks @deckingman and @Phaedrux !

    Well I guess that's a good thing I don't have this file @bearer

    here are the homming files :

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 25 2018 10:06:03 GMT+0100 (heure normale d’Europe centrale)
    G91 ; relative positioning
    G1 Z-5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-585 Y-585 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-585 Y-585 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-585 F1800 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 25 2018 10:06:03 GMT+0100 (heure normale d’Europe centrale)
    G91 ; relative positioning
    G1 Z-5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-585 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000 ; go back a few mm
    G1 S1 X-585 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 25 2018 10:06:03 GMT+0100 (heure normale d’Europe centrale)
    G91 ; relative positioning
    G1 Z-5 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-585 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-585 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 25 2018 10:06:03 GMT+0100 (heure normale d’Europe centrale)
    G91 ; relative positioning
    G1 Z-5 F600 S2
    G1 S1 Z-585 F1800 ; move Z down until the endstop is triggered
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @carlitototo said in Z axis "blocked":

    G1 S1 Z-585 F1800 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    Are you using a Z probe? It looks like you have a BLTouch configured, but your homing files are setup to use endstops.

    If you plan on using mesh compensation this can lead to some issues. You will need to either switch homing Z over to using the probe, or at least ensure you do a single G30 probe at the center of the bed before creating the mesh heightmap, and before starting the print/loading the heightmap.

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z
    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • Oh ! Didn't know I could do that... this is a nice feature, going to try and implement it right now !

    Thansk @Phaedrux



  • Well that must be the most convenient thing that exist in the 3D printing world, works perfectly ! Thanks



  • Welcome to the Duet and RepRapFirmware. You've only scratched the surface.


Log in to reply