Cura 4.2.1 to Duet2Wifi plugin problem.



  • This seems to be a problem with the Duet2Wifi plugin for Cura. I get a Chamber Heater not connected warning only when I use the plugin to send the gcode to the Duet2Wifi. It's like this plugin is adding a chamber heater but I don't have it in my Cura start or stop gcode setting, nor do I have it activated on my Duet2Wifi. Normal slicing and transfer to the Duet by manual upload works fine. It's only when using this plugin to send to the gcode to the Duet that I get this chamber heater warning.



  • I had this the other day, I think it's a new addition. Cura is adding an M141 command. While it produces an annoying popup, it is effectively ignored if you don't have a chamber heater. Disable it by opening Print settings in Cura and find "Build Volume Temperature" (usually hidden), and set it to 0C. Then it won't put the M141 in the gcode.

    Ian



  • @droftarts I'll give it a try when this print is finished. Wonder why they added it by default, unless all Ultimaker Printers have heated chambers?



  • did you set the g code flavor to reprap? i get no m141 in my g code



  • Neither do I, but then again, if I change Cura's printer settings to use Marlin flavour instead of RepRap, I don't get any M141 commands in the g-code either.



  • I have my printer set as a Custom > Deltabot, and using 'Marlin' (not 'Marlin (Volumetric)' or 'RepRap') as G-code flavour, which seems to be working fine (I think I chose Marlin after a recommendation on this forum somewhere). This is with Cura 4.2.1 which was released a week ago. Can't see anything in the release notes about 'Build Volume Temperature': https://github.com/Ultimaker/Cura/releases

    It would be good if they added the 'Build Volume Temperature' as a settable value in the material profile. My guess is with the end of the Stratasys patents on heated chambers, Ultimaker will be coming out with a heated chamber version.

    Ian



  • @droftarts well that worked. It's odd though. I got the Chamber Heater warning only when using the plugin to send g-code to the Duet board. If I uploaded the g-code manually from Cura 4.2.1 to the Duet I got no Chamber Heater warning. When I activated the Build Volume Temp in Cura it was set to 28, changed it to 0, and now the plugin seems to work without the warning.



  • To be fair, I got the message when I sent direct to print from Cura, too, and then worked out what was causing it and fixed it, without trying an uploaded file. Cura does seem to put in some extra gcode before the Start G-code, particularly if it's not already stated in the Start G-code, eg M104 and M109. But it's strange the behaviour is different between sending it via the plugin and saving/uploading.

    I've noticed one other problem with using 'Marlin' rather than 'RepRap' G-code flavour, which is that it's using absolute (M82) rather than relative (M83) extrusion mode (relative is preferred). I've switched to 'RepRap' flavour because of this. My Start G-code is:

    M83 ;relative extrusion mode
    T0
    M104 S{material_print_temperature}
    M109 S{material_print_temperature}
    G32 ;Calibrate
    G29 S1 ; Load height map
    G1 Z15.0 F6000 ;Move the platform down 15mm
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0
    

    Cura spits out (to a saved file, bits in bold Cura has added):

    ;FLAVOR:RepRap
    ;TIME:1448
    ;Filament used: 0.516914m
    ;Layer height: 0.1
    ;MINX:-13.844
    ;MINY:-13.844
    ;MINZ:0.3
    ;MAXX:13.844
    ;MAXY:13.844
    ;MAXZ:10.5
    ;POSTPROCESSED
    ;Generated with Cura_SteamEngine 4.2.1
    T0
    M82 ;absolute extrusion mode
    M83 ;relative extrusion mode
    T0
    M104 S190
    M109 S190
    G32 ;Calibrate
    G29 S1 ; Load height map
    G1 Z15.0 F6000 ;Move the platform down 15mm
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0
    M83 ;relative extrusion mode
    G1 F3000 E-3.5
    ;LAYER_COUNT:103
    ;LAYER:0
    
    G0 F4500 X13.74 Y1.442 Z0.3
    etc...
    

    I also have a couple of post processing search and replace scripts, to get rid of extra M107 (Fan off, because my hot end fan is under thermostatic control, and this turns it off!) and M105 (Get Extruder temperature, which is unnecessary when using Duet).

    Ian



  • @droftarts Did Cura spit that out with Marlin or RepRap? Which are you using now Marlin or RepRap? I'm building an IDEX not sure which slicer I'll be using.



  • Says at the top of the output gcode, ';FLAVOR:RepRap'. Though I haven't actually run gcode with this setting to check it works, but it seems the way to get relative rather than absolute extrusion.

    Ian



  • @droftarts Heh, I keep scrolling past the start. Thanks for the help Ian.



  • @droftarts said in Cura 4.2.1 to Duet2Wifi plugin problem.:

    I think I chose Marlin after a recommendation on this forum somewhere

    Should definitely be RepRap flavour. It's less of an issue now that RepRapFirmware also supports a lot of the Marlin syntax commands, but RepRap flavour is the best bet.

    Cura has a checkbox for relative extrusion now. May have to search the hidden settings for it.



  • @phaedrux said in Cura 4.2.1 to Duet2Wifi plugin problem.:

    Cura has a checkbox for relative extrusion now. May have to search the hidden settings for it.

    Just found it in 'Special Modes' , usually hidden.

    Ian


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.