print quality



  • Hello. Once again I turn to the community for help. Mostly I print on Marlin, but periodically return to the Duet for experiments. Probably already a year, as I can’t get decent prints. The configuration of the machine is a Hbot, the motors XY are 0.9 degrees (Resistance 0.8, Inductance 1.8, 2.4A), 2 motors 1.8 degrees on Z (sometimes I put the screws in 2mm increments, sometimes the SFU1204), extruder titan aero, engine 1.8, nozzle 0.3. Before continuing further, I will publish a couple of photos of prints made on Marlin, so that you can see that the mechanics are is all right.

    0_1565863091359_photo_2019-08-15_12-57-39.jpg
    0_1565863128715_photo_2019-08-15_12-57-20.jpg

    On Marlin, I use mild movement values. Accelerations -1500, jerks - 8, I print at a speed of 60 to fill and 30-20 for the outer walls. Movements also at a speed of 60. The retract values are 0.65, at a speed of 8 and accelerations 5000. This is PLA, 200 degrees, 60 degrees for bed. Yes, an ordinary thermistor - 104gt-2.
    Now let's move on to the Duet.

    M92 X160.00 Y160.00 Z1600.00 E449.00 // steps
    M350 X16 Y16 Z16 I1 // microstep
    M350 E255 I0
    M906 X1700 Y1700 Z800 E1000 I70 // current
    M566 X300 Y300 Z50 E500 // jerk
    M203 X6000 Y6000 Z600 E5000 // speed
    M201 X500 Y500 Z50 E5000 // acceleration
    M305 P1 T100000 B4619 C9.390164e-8 R4700 // termistor

    M572, M592 is disabled.
    In fact, a change in any parameters given above does not actually affect the quality of the part. I can lower the current by half, increase the acceleration or jerking, the result remains approximately the same. What can seriously affect is the incorrect meaning of the retract, but it seems to be clear to everyone.
    Let's take a simple part, and print it in three layers thick, without even using a retract.
    Ta-dah!..
    0_1565865848667_photo_2019-08-15_13-40-08 (2).jpg
    0_1565865864323_photo_2019-08-15_13-40-08.jpg

    and now with a retract

    0_1565865933840_photo_2019-08-15_13-40-08 (3).jpg
    0_1565866054666_photo_2019-08-15_13-46-50.jpg

    that it is more difficult

    0_1565866828803_photo_2019-08-15_13-58-23.jpg
    0_1565866841899_photo_2019-08-15_13-59-05.jpg

    I honestly tried. It is unlikely that this is the temperature, but I calibrated the pid. With and without a fan. installed PT100 (then took it off, peaks of the signal sometimes confuse me), checked steps, turned on and off the M572, M592. Nothing helps. Only replace the board with marlin or smoothie. I changed the motor on the extruder from flat to very large. Ideas are over.



  • @denis said in print quality:

    M350 E255 I0

    M350 E255 I0 ??

    E256 ?



  • Sorry, of course 256, but 16 is the same trouble



  • @denis said in print quality:

    M92 X160.00 Y160.00 Z1600.00 E449.00 // steps

    Have you tried lowering your E steps?

    E3D is recommending to start with 837 step/mm for the extruder when using their 0.9deg Aero stepper.
    As you are using a 1.8deg stepper, your E steps should be around half of the E3D recommendation.
    Doing the math yields 418.50 - your configured 449.00 steps/mm are significantly higher.



  • I get an error message if I send:

    M350 E255 I0
    Error: M350: Drive E3 does not support 255x microstepping
    

    Not sure what the microstepping will be defaulting to. Make sure it's:
    M350 E256 I0

    Given the stringing and inconsistent layers, are the thermistor settings correct?
    M305 P1 T100000 B4619 C9.390164e-8 R4700 // termistor

    B4619 seems high, as does the C value. What thermistor is it? What are your thermistor settings in Marlin? Incorrect temperature reading would produce poor retraction.

    Ian



  • @themelle I do not use the original e3d, so I calibrated the extruder manually. It has excellent repeatability of results. I also set up the M592, but did not notice any big difference. Again, I note that on other firmware I do not have such problems. 0.9 tried the motor, the results are the same



  • @droftarts I agree, these are my experiments, because I’m always searching. However, how can I explain that with PT100 I do not improve the quality at all?



  • @denis I guess you're using a Duet Wifi. What version, and what firmware version? Probably best to concentrate on thermistor settings, as there's clearly a difference between Marlin and RRF, as that's where the inconsistency is. Would be good to know what thermistor you have.

    Ian



  • @droftarts not to be unfounded, I changed the steps to 418 and M305 P1 T100000 B4267 C0 R4700 according to the data for the thermistor 104-NT4R025H42G. Re-calibrated the PID and overloaded the board .Launched printing and expect results



  • @droftarts Yes you are right. Duet Wifi and 2.04RC1 (yesterday there was still 2.03, but with the same result)



  • @denis have you set the slicer to relative extrusion and reprap firmware?



  • @bartolomeus currently using Cura 4.2.1, reprap g-code variant and relative extrusion



  • @droftarts here is the result with the new settings. nothing of changed0_1565874459519_photo_2019-08-15_16-05-49.jpg



  • @denis said in print quality:

    I do not use the original e3d

    are you sure that you have a semitec thermistors?
    nearly all clones dont use semitec thermistors.



  • Damn, this is a tough one!

    I had similar uneven extrusion lately, and it was because my extrusion temps were way higher than my other printer given the same set point. I dialed my temp for pla from 205 down to 190 and my prints became crisper.

    I know you have tried the thermistor settings and all sorts of things, but try printing as low temp as possible while not grinding the filament.

    That’s the only thing I can think of at the moment.



  • @veti I don’t know if it’s possible to publish product links, but moderators will forgive me (probably) https://s.click.aliexpress.com/e/bVR3ictU



  • Does anyone think his printer prints perfectly? I can give this model. But only print is interested in the Cura. This is related to other models and how it builds support. S3d sometimes forgets to put them correctly, and other slicers are unstable for me



  • Just a guess into the blue: what does the file /sys/config-override.g on the Duet SD card contain?



  • @denis I wouldn't say my printer prints perfectly, but it's similar to yours (it's a big CoreXY) and I have some nice white PLA and use the latest Cura as my slicer. My printer is controlled by a Duet 2 WiFi running version 2.03 firmware.

    I use a genuine E3D V6 with a genuine Bondtech BMG extruder. (I won't buy cloned stuff as I believe my money is better spent rewarding people who innovate instead of those who produce poor quality copies.)

    By all means PM me one of your troublesome models and I'll set it printing and see what happens!

    I also find your problems puzzling and it would be very interesting to see why you can't get the Duet to print properly.



  • @denis Those thermistors used to be 3950 Hisense thermistors (on the same link) and they changed them a couple months ago to the semitec.

    I would look at your purchase history and look at the archived page info. I had the same issue (was running a 3950 at the semitec value) and my temperature was WAY high ( I think 30-40 deg)

    Try setting to 3950 and see if you can still extrude PLA at typical temps.

    My 2cents


Log in to reply